×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Regular Contributor
    Join Date
    May 2005
    Location
    Brasov, Romania
    Posts
    431

    Exclamation PA type installation does not work anymore after first removal

    PA type installation does not work anymore after first removal on several 3rd edition devices:

    - Plug a memory card with a signed PA-type installation on a 3rd edition device
    - For the first time the installation is made automatically with visual indicator "Installing"
    - After first removal of the application from the device using "App. Mgr." next installation don't work anymore. The reason differs from one device to another. E.g.: 3250 (firmware v3.23, 15-05-06, RM-38): after first removal the application image is damaged so no further installation can be done ('private' folder is removed). This does not happen on E70 (firmware 1.0610.05.07, 30-05-06, RM-10). Further more, application installs but does not start on N93 (v10.0.025, 12-07-06, RM-55) and N92 (v2.0631.0.0.8, 01-08-06, RM-100) - 'cannot execute file for security reasons'.

    The PA type installer is Symbian Signed and the devices were re-flashed last month with the latest version available.

    Can anybody help me or give me a detailed report on this issue?

    Does anybody use this kind of installation?
    Last edited by iulian_moldovan; 2006-08-30 at 13:14.

  2. #2
    Regular Contributor
    Join Date
    May 2005
    Location
    Brasov, Romania
    Posts
    431

    Re: PA type installation does not work anymore after first removal

    Hello again.
    Any news?

    Ron?

  3. #3
    Regular Contributor
    Join Date
    May 2005
    Location
    Sweden
    Posts
    272

    Re: PA type installation does not work anymore after first removal

    I have similar experiences. I guess there's not much to do about it, except hope that they fix it. Nokia deliver apps preinstalled on memory cards shipped with their phones, so it's very much in their interest to get this to work. Stuff that I've installed on the memory card of my 3250 has been behaving strange since day one.

  4. #4
    Nokia Developer Expert
    Join Date
    Dec 2003
    Posts
    50

    Re: PA type installation does not work anymore after first removal

    Do your applications change any of the installed files after the first installation? If this is the case the then the security checks (hashes in the SIS controller) do not match and things don't work.

  5. #5
    Regular Contributor
    Join Date
    May 2005
    Location
    Brasov, Romania
    Posts
    431

    Re: PA type installation does not work anymore after first removal

    No, it does not change the content of any file described in the PA type pkg file. It adds some new files during run, but this is outside the security incidence because they are not described in the pkg file.

  6. #6
    Nokia Developer Expert
    Join Date
    Dec 2003
    Posts
    50

    Re: PA type installation does not work anymore after first removal

    In that case I'd recommend making it a case for the Forum Nokia Professional support.

Similar Threads

  1. Replies: 7
    Last Post: 2004-11-30, 17:36
  2. nokia 7210 modem via IR doesn't work !
    By oussamaaiadi in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2003-03-06, 10:46
  3. Drawpixels on 7650 doesn't work anymore since firmware update
    By jtranchant in forum Mobile Java General
    Replies: 0
    Last Post: 2003-02-04, 15:09
  4. Replies: 0
    Last Post: 2002-10-09, 06:58

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×