×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Mar 2003
    Location
    51°11'4.78"N -|- 2°48'27.05"E (Belgium)
    Posts
    730

    mif file not rebuild with carbide.vs 2.0.1

    Hi,

    when I modify my .svg file for the icon (either for the emulator or the device), it doesn't show me the last one, it seems that the .mif file is not rebuild by carbide.vs !! is it true ? must I rebuild by myself thru a command line ? if yes, which one ?

    PS: the project is generated inside the VS .Net thru file/new/project/new symbian os project ; I have changed nothing to the file, I only want to modify the gfx/qgn_menu.svg file ...

    Thanks 4 your help,
    Domi.
    Last edited by Jeepy; 2006-08-31 at 15:40.
    ----------------------------------------------------------------------------------
    FExplorer is my baby !

    you can get the FREE version from www.gosymbian.com
    you can get the PRO version from http://store.ovi.com/content/339454

  2. #2
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: mif file not rebuild with carbide.vs 2.0.1

    Should do if you force a full Rebuild. Due to some default behaviour that VS associates with resources files, we were not able to connect automatic "out-of-date" detection to build steps that involve resouce building..

  3. #3
    Registered User
    Join Date
    Mar 2003
    Location
    51°11'4.78"N -|- 2°48'27.05"E (Belgium)
    Posts
    730

    Re: mif file not rebuild with carbide.vs 2.0.1

    thanks for yous reply, but you know, the "rebuild all" was the first command I had done, of course, .... meanwhile, I have made a small batch command to delete all the .mif file prior to execute the build, this forces the re-cration ...
    ----------------------------------------------------------------------------------
    FExplorer is my baby !

    you can get the FREE version from www.gosymbian.com
    you can get the PRO version from http://store.ovi.com/content/339454

  4. #4
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: mif file not rebuild with carbide.vs 2.0.1

    OK, so seems there is a bug there.. Would you mind sharing the batch file that you have done and how you invoke it? Thanks.

  5. #5
    Registered User
    Join Date
    Mar 2003
    Location
    51°11'4.78"N -|- 2°48'27.05"E (Belgium)
    Posts
    730

    Re: mif file not rebuild with carbide.vs 2.0.1

    it's a very ridiculious .bat file containing 2 del commands and invoked thru a dos command prompt like this :

    del \symbian\9.1\s60_3rd\epoc32\data\z\resource\apps\YourApp_reg.mif
    del \symbian\9.1\s60_3rd\epoc32\release\winscw\udeb\z\resource\apps\YourApp_reg.mif

    it's stupid but this help...; in fact the build process is not able to check if the included file .svg has be changed or not

    Domi.
    ----------------------------------------------------------------------------------
    FExplorer is my baby !

    you can get the FREE version from www.gosymbian.com
    you can get the PRO version from http://store.ovi.com/content/339454

Similar Threads

  1. Carbide.vs 2.0.1 installs ok but not working at all
    By pheno1 in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2006-08-28, 08:26
  2. S60 theme questions
    By Nokian_Spb in forum Symbian Media (Closed)
    Replies: 3
    Last Post: 2006-08-17, 06:11
  3. Replies: 3
    Last Post: 2006-05-02, 20:12
  4. Replies: 1
    Last Post: 2005-05-26, 14:22
  5. Replies: 0
    Last Post: 2002-06-10, 12:24

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×