×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Aug 2006
    Location
    Helsinki, Finland
    Posts
    6

    Publish and Subscribe troubles

    Hi,

    I need to publish a property at S60v3 platform so that other applications can to subscribe to it.
    Being able to Define() a property, Attach() to it, I am not able to get Its value or change it.

    I am using
    Define(KMyAppProperty, RProperty::EInt, KAllowAllPolicy, KWritePolicy);
    where
    static _LIT_SECURITY_POLICY_PASS(KAllowAllPolicy);
    static _LIT_SECURITY_POLICY_C1(KWritePolicy,ECapability_None);


    Does anybody have any ideas about this?

    Thanks in advance.

  2. #2
    Super Contributor
    Join Date
    Nov 2004
    Location
    Wiltshire, UK
    Posts
    3,644

    Re: Publish and Subscribe troubles

    Try:
    TSecurityPolicy writePolicy(TSecurityPolicy::EAlwaysPass);

    instead of _LIT_SECURITY_POLICY_C1

  3. #3
    Registered User
    Join Date
    Aug 2006
    Location
    Helsinki, Finland
    Posts
    6

    Re: Publish and Subscribe troubles

    Thanks Paul,

    But unfortunately this solution didn't help, I am still getting "KErrNotFound" error on attempts to change the property value.

Similar Threads

  1. About Publish and Subscribe
    By xhsoldier in forum Symbian
    Replies: 8
    Last Post: 2009-07-22, 11:30
  2. 3G coverage detection using Publish and Subscribe
    By david.reynolds1 in forum Symbian Networking & Messaging (Closed)
    Replies: 15
    Last Post: 2007-07-24, 09:15
  3. Voice Call status with publish & subscribe
    By hlynurjoh in forum Symbian
    Replies: 17
    Last Post: 2006-08-14, 14:45

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •