×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jun 2006
    Posts
    12

    Question error spawning 'link.exe'

    Hi,
    I have a test application that I used to test my DLL.

    I have ported this test app. to 3rd edition as I have my DLL as well.

    But when I build this test app. with the WINSCW i get error:

    /OUT:"C:\Symbian\9.1\S60_3rd_MR\\Epoc32\release\winscw\udeb\RaUpTestUi.app" /NOLOGO /LIBPATH:"C:\Symbian\9.1\S60_3rd_MR\\Epoc32\release\winscw\udeb" /DLL /NODEFAULTLIB /INCLUDE:"?_E32Dll@@YGHPAXI0@Z" /DEBUG /ASSEMBLYDEBUG /PDB:"./RaUpTestUi.pdb" /SUBSYSTEM:WINDOWS /ENTRY:"_E32Dll" /NDSProjectFile "C:\Work\RATS\RaUpTestUi\RaUpTestUi.vcproj" /NDSSDKShortName S60_30M Icsplatform.lib Icsutils.lib flogger.lib commdb.lib efsrv.lib RaUpdateMgr.lib euser.lib apparc.lib cone.lib eikcore.lib eikcoctl.lib avkon.lib edll.lib kernel32.lib user32.lib gdi32.lib winspool.lib comdlg32.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib uuid.lib odbc32.lib odbccp32.lib
    .\deb_s60_30m_winscw\RaUpTestUiApp.obj
    .\deb_s60_30m_winscw\RaUpTestUiAppUi.obj
    .\deb_s60_30m_winscw\RaUpTestUiContainer.obj
    .\deb_s60_30m_winscw\RaUpTestUiDocument.obj
    .\deb_s60_30m_winscw\rauptestui.uid.obj
    Error in linking: Object reference not set to an instance of an object.
    RaUpTestUi : error PRJ0003 : Error spawning 'link.exe'.


    can someone help me out please!!!

    thank you. :)

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,671

    Re: error spawning 'link.exe'

    It would have been better to post complete lines ("/OUT:..." is the 2nd or 3rd line of a command line), but there are a number of strange things:
    - RaUpTestUi.app: there is no .app extension in 3rd edition, your application code should be a .exe
    - E32Dll: entry point for 3rd edition applications is E32Main (since they are .exe-s)
    - NDSStuff: are you using Nokia Developer Suite? You should better get some Carbide
    - WinApi libraries: why are they there?

  3. #3
    Registered User
    Join Date
    Jun 2006
    Posts
    12

    Re: error spawning 'link.exe'

    Thanks for the help.

    I have made changes and it compiled well. :)

    Actually, I haven't gone through any douments that specify the changes that took place in v9.1

    It would be great if you can mention a link that can direct me to that webpage or website listing the changes in v9.1

    Thanks again

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,671

    Re: error spawning 'link.exe'


Similar Threads

  1. Basic Link.exe Problem
    By awasthi_vivek in forum Symbian Tools & SDKs
    Replies: 25
    Last Post: 2006-10-23, 14:27
  2. error about 'LINK.EXE' in Hello world
    By kaitree in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2004-07-12, 16:55
  3. 'LINK.EXE' problem
    By ckmeng in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2004-04-14, 00:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×