×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Jan 2005
    Posts
    31

    shared library in 3rd edition

    I have an embedded sis file including shared dlls(required by several applications).

    Until 3rd edition, sissystem (sis type) handles installation, upgrading and uninstallation of shared dlls, but in 3rd edition, sissystem seems to be removed from sis types.

    How can I get my "shared dlls"(embedded sis) to be installed when first application is installed, and keep them until last application using them is removed?
    OR
    Is there any other way to use shared library?

    SDK Help says:
    "Embedded SIS files are installed and removed together with the embedding SIS file. But note that an embedded SIS file is not removed if another installed component has declared a dependency upon it. "
    but embedded sis is always removed during uninstallation of main sis even if I declared a dependency for embedded sis within another sis file.

    (I tried this on NokiaE61)

    Is there anything that can prevent embedded sis file to be removed???

  2. #2
    Registered User
    Join Date
    Jan 2007
    Posts
    8

    Re: shared library in 3rd edition

    I'm experiencing the same problem. Did someone found a solution to this issue?

  3. #3
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,734

    Re: shared library in 3rd edition

    What happens if you do not "declare dependency upon it", but embed it in both .sisx-s?

Similar Threads

  1. Fail to build syexpat 1.3 under 2nd FP3
    By harry_zhang in forum Symbian
    Replies: 10
    Last Post: 2010-03-19, 10:24
  2. Coudn't generate library with new SDK 3rd edition
    By sdalis in forum Symbian Tools & SDKs
    Replies: 17
    Last Post: 2006-12-12, 10:22
  3. S60 2nd OR 3rd edition for new software development
    By patil_ruturaj in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2006-06-30, 09:30
  4. S60 2nd OR 3rd edition for new software development
    By patil_ruturaj in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2006-06-30, 08:57
  5. Can’t launch application on 6630
    By kaffemannen in forum Symbian
    Replies: 8
    Last Post: 2005-06-29, 10:49

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×