×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Oct 2003
    Posts
    3

    Question BT SPP Problem on 7610

    Hi,

    If I run the btsppEcho midlet (here) on my 7610, and another instance on a second phone (I've tried Moto Razr, 6230i and 6600), then whether the phone is in client or server mode, as soon as the 7610 *receives* a message it will disconnect immediately after. It has no problem sending.

    The app works fine between any other two phones I have.

    Is this a bug in the 7610 JVM?

    I tried this because I am seeing the same behaviour in my own SPP app. As soon as the app receives a blob of data it will not receive any more. The app works fine on any other J2ME phone with JSR-82.

    Thanks,

  2. #2
    Super Contributor
    Join Date
    Dec 2005
    Location
    Europe/Poland/Warsaw
    Posts
    1,697

    Re: BT SPP Problem on 7610

    hi,

    try that technote:
    http://forum.nokia.com/Technical_Lib...in_MIDlets.htm
    regards,
    Peter

  3. #3
    Registered User
    Join Date
    Oct 2003
    Posts
    3

    Re: BT SPP Problem on 7610

    Cheers for the quick response. At first glance that would appear to be it, except in my application:

    1) Both ends of the stream are kept open

    2) The read that blocks is trying to read a single byte. The previous successful read only read 15 bytes.

    So I don't think it can be neither the stream closing issue nor the buffer size one. Also the app works on a 6600 although the firmware version on mine is a lot older than the one listed in the technote.

    The technote refers to that spp example, but from a quick glance at the code, it would appear that the connection is maintained, and the buffer size only depends on the length of the text sent.

  4. #4
    Registered User
    Join Date
    Oct 2003
    Posts
    3

    Unhappy Re: BT SPP Problem on 7610

    Anyone else encountered it? Any other ideas? I'd hate to have to label our product as not working on a specific phone model, but that's my only option right now.

  5. #5
    Registered User
    Join Date
    Jul 2005
    Posts
    8

    Re: BT SPP Problem on 7610

    A have similar problem on my 3230 (which has probably the same software as 7610).

    I connect to Nokia ld-3w gps module and the first byte read after connecting is always -1 (indicating the end of stream). If I ignore this, i can continue reading bytes but after 40seconds (exactly) a get another end of stream and i must close the connection.
    After that, i must wait 1 minute until the gps module closes the connection too and then i can reconnect (in every 3minutes a have 40seconds of reading data and the rest is connecting/closing connection).

    I'm sure it's a bug in 3230 implementation.

Similar Threads

  1. WTK & 7610 Http connection problem
    By wgarnett in forum [Archived] Other Programming Discussion 关于其他编程技术的讨论
    Replies: 0
    Last Post: 2005-12-13, 14:06
  2. Smil layout problem with Nokia 6630, 6680 and 7610
    By Juergen Merkel in forum General Messaging
    Replies: 0
    Last Post: 2005-09-01, 08:57
  3. i got a problem with capture voice with 7610
    By ononokung in forum Mobile Java Media (Graphics & Sounds)
    Replies: 3
    Last Post: 2004-09-30, 05:20
  4. Problem on 7610
    By siriuschoy in forum Mobile Java General
    Replies: 3
    Last Post: 2004-09-16, 23:05
  5. 7610 softkey problem
    By alphelin in forum Mobile Java General
    Replies: 4
    Last Post: 2004-09-15, 01:49

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×