×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jan 2004
    Location
    Zagreb, Croatia
    Posts
    3

    Exclamation Problem with Cabride.c++ v1.1

    I have installed Cabride.c++ v1.1 and series 60SDK but I am unable to start the IDE. When I try running it I get the error message saying that I should check the .log file.

    The complete error log is shown below:
    !SESSION 2006-09-17 17:26:40.919 -----------------------------------------------
    eclipse.buildId=I20050627-1435
    java.version=1.5.0_05
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=hr_HR
    Command-line arguments: -os win32 -ws win32 -arch x86

    !ENTRY org.eclipse.osgi 2006-09-17 17:27:14.738
    !MESSAGE Application error
    !STACK 1
    java.lang.UnsatisfiedLinkError: no swt-win32-3139 in java.library.path
    at java.lang.ClassLoader.loadLibrary(Unknown Source)
    at java.lang.Runtime.loadLibrary0(Unknown Source)
    at java.lang.System.loadLibrary(Unknown Source)
    at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
    at org.eclipse.swt.internal.win32.OS.<clinit>(OS.java:18)
    at org.eclipse.swt.widgets.Display.<clinit>(Display.java:125)
    at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:381)
    at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:155)
    at org.eclipse.ui.internal.ide.IDEApplication.createDisplay(IDEApplication.java:128)
    at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:79)
    at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:226)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
    at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
    at org.eclipse.core.launcher.Main.run(Main.java:973)
    at org.eclipse.core.launcher.Main.main(Main.java:948)

    !ENTRY org.eclipse.osgi 2006-09-17 17:27:14.744
    !MESSAGE Bundle update@plugins/org.eclipse.emf.ant_2.1.0.jar [124] was not resolved.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.745
    !MESSAGE Missing required bundle org.eclipse.emf.codegen_0.0.0.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.745
    !MESSAGE Missing optionally required bundle org.eclipse.emf.codegen.ecore_0.0.0.

    !ENTRY org.eclipse.osgi 2006-09-17 17:27:14.749
    !MESSAGE Bundle update@plugins/org.eclipse.emf.codeg...e.ui_2.1.0.jar [125] was not resolved.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.749
    !MESSAGE Missing required bundle org.eclipse.jdt.core_0.0.0.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.749
    !MESSAGE Missing required bundle org.eclipse.emf.codegen.ecore_0.0.0.

    !ENTRY org.eclipse.osgi 2006-09-17 17:27:14.753
    !MESSAGE Bundle update@plugins/org.eclipse.emf.codegen.ecore_2.1.0.jar [126] was not resolved.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.753
    !MESSAGE Missing required bundle org.eclipse.jdt.core_0.0.0.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.753
    !MESSAGE Missing required bundle org.eclipse.jdt.launching_0.0.0.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.753
    !MESSAGE Missing required bundle org.eclipse.emf.codegen_0.0.0.

    !ENTRY org.eclipse.osgi 2006-09-17 17:27:14.755
    !MESSAGE Bundle update@plugins/org.eclipse.emf.codegen.ui_2.1.0.jar [127] was not resolved.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.755
    !MESSAGE Missing required bundle org.eclipse.emf.codegen_0.0.0.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.755
    !MESSAGE Missing required bundle org.eclipse.jdt.core_0.0.0.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.755
    !MESSAGE Missing required bundle org.eclipse.jdt.launching_0.0.0.

    !ENTRY org.eclipse.osgi 2006-09-17 17:27:14.757
    !MESSAGE Bundle update@plugins/org.eclipse.emf.codegen_2.1.2.jar [128] was not resolved.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.757
    !MESSAGE Missing required bundle org.eclipse.jdt.core_0.0.0.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.757
    !MESSAGE Missing required bundle org.eclipse.jdt.launching_0.0.0.

    !ENTRY org.eclipse.osgi 2006-09-17 17:27:14.758
    !MESSAGE Bundle update@plugins/org.eclipse.emf.ecore...itor_2.1.0.jar [136] was not resolved.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.759
    !MESSAGE Missing required bundle org.eclipse.emf.codegen.ecore_0.0.0.

    !ENTRY org.eclipse.osgi 2006-09-17 17:27:14.760
    !MESSAGE Bundle update@plugins/org.eclipse.emf.importer.ecore_2.1.2.jar [143] was not resolved.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.760
    !MESSAGE Missing required bundle org.eclipse.emf.importer_0.0.0.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.760
    !MESSAGE Missing optionally required bundle org.eclipse.emf.codegen.ecore.ui_0.0.0.

    !ENTRY org.eclipse.osgi 2006-09-17 17:27:14.762
    !MESSAGE Bundle update@plugins/org.eclipse.emf.importer.java_2.1.2.jar [144] was not resolved.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.762
    !MESSAGE Missing required bundle org.eclipse.jdt.core_0.0.0.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.762
    !MESSAGE Missing required bundle org.eclipse.emf.importer_0.0.0.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.763
    !MESSAGE Missing optionally required bundle org.eclipse.emf.codegen.ecore.ui_0.0.0.

    !ENTRY org.eclipse.osgi 2006-09-17 17:27:14.766
    !MESSAGE Bundle update@plugins/org.eclipse.emf.importer.rose_2.1.1.jar [145] was not resolved.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.767
    !MESSAGE Missing required bundle org.eclipse.emf.importer_0.0.0.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.767
    !MESSAGE Missing optionally required bundle org.eclipse.emf.codegen.ecore.ui_0.0.0.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.767
    !MESSAGE Missing optionally required bundle org.eclipse.emf.ant_0.0.0.

    !ENTRY org.eclipse.osgi 2006-09-17 17:27:14.776
    !MESSAGE Bundle update@plugins/org.eclipse.emf.importer_2.1.0.jar [146] was not resolved.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.777
    !MESSAGE Missing required bundle org.eclipse.emf.codegen.ecore_0.0.0.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.777
    !MESSAGE Missing optionally required bundle org.eclipse.emf.codegen.ecore.ui_0.0.0.

    !ENTRY org.eclipse.osgi 2006-09-17 17:27:14.779
    !MESSAGE Bundle update@plugins/org.eclipse.xsd.ecore.importer_2.1.0.jar [204] was not resolved.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.779
    !MESSAGE Missing required bundle org.eclipse.emf.importer_0.0.0.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.779
    !MESSAGE Missing optionally required bundle org.eclipse.emf.codegen.ecore.ui_0.0.0.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 17:27:14.779
    !MESSAGE Missing optionally required bundle org.eclipse.emf.ant_0.0.0.
    !SESSION 2006-09-17 20:02:19.400 -----------------------------------------------
    eclipse.buildId=I20050627-1435
    java.version=1.5.0_05
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=hr_HR
    Command-line arguments: -os win32 -ws win32 -arch x86

    !ENTRY org.eclipse.osgi 2006-09-17 20:02:32.136
    !MESSAGE Application error
    !STACK 1
    java.lang.UnsatisfiedLinkError: no swt-win32-3139 in java.library.path
    at java.lang.ClassLoader.loadLibrary(Unknown Source)
    at java.lang.Runtime.loadLibrary0(Unknown Source)
    at java.lang.System.loadLibrary(Unknown Source)
    at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
    at org.eclipse.swt.internal.win32.OS.<clinit>(OS.java:18)
    at org.eclipse.swt.widgets.Display.<clinit>(Display.java:125)
    at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:381)
    at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:155)
    at org.eclipse.ui.internal.ide.IDEApplication.createDisplay(IDEApplication.java:128)
    at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:79)
    at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:226)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
    at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
    at org.eclipse.core.launcher.Main.run(Main.java:973)
    at org.eclipse.core.launcher.Main.main(Main.java:948)

    !ENTRY org.eclipse.osgi 2006-09-17 20:02:32.154
    !MESSAGE Bundle update@plugins/org.eclipse.emf.ant_2.1.0.jar [124] was not resolved.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 20:02:32.154
    !MESSAGE Missing required bundle org.eclipse.emf.codegen_0.0.0.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 20:02:32.154
    !MESSAGE Missing optionally required bundle org.eclipse.emf.codegen.ecore_0.0.0.

    !ENTRY org.eclipse.osgi 2006-09-17 20:02:32.158
    !MESSAGE Bundle update@plugins/org.eclipse.emf.codeg...e.ui_2.1.0.jar [125] was not resolved.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 20:02:32.158
    !MESSAGE Missing required bundle org.eclipse.jdt.core_0.0.0.
    !SUBENTRY 1 org.eclipse.osgi 2006-09-17 20:02:32.158
    !MESSAGE Missing required bundle org.eclipse.emf.codegen.ecore_0.0.0.

    Any ideas what might be wrong?

    Thanks in advance,
    Marko Vuksanovic

  2. #2
    Super Contributor
    Join Date
    Dec 2005
    Location
    England,UK
    Posts
    1,600

    Re: Problem with Cabride.c++ v1.1

    Hi,
    I have not encountered this error because I have Carbide.UI loaded, which has previously loaded EMF, GEF and VE packages for Eclipse.

    You can get the EMF runtime library from
    http://www.eclipse.org/downloads/dow...me-1.1.0.1.zip

    The Visual Editor is at http://download.eclipse.org/tools/ve...822/index.html

    When starting Carbide.c++ Developer a "Plugin SDKs loaded" Please Restart" message appears. I wonder if this is when EMF package was loaded and why I did not get the error mesage.

    Carbide.UI is Java perhaps this is reason I did not have this problem

    POssible Solution
    1. Load Carbide.UI.

    If still not working load in this order
    The base version from any Eclipse mirror site
    2.
    eclipse-SDK-3.1-win32.zip
    configure to WinRAR to unload in C:\eclipse-SDK-3.1-win32\
    the main directory is C:\eclipse-SDK-3.1-win32\eclipse



    3.
    EMF
    http://archive.eclipse.org/webtools/...-SDK-2.1.0.zip
    load/unzip into "C:\eclipse-SDK-3.1-win32\eclipse"

    4.
    GEF
    http://archive.eclipse.org/webtools/...EF-SDK-3.1.zip
    load/unzip into "C:\eclipse-SDK-3.1-win32\eclipse"
    5.
    VE
    http://www.eclipse.org/downloads/dow...me-1.1.0.1.zip

    now start Eclipse from C:\eclipse-SDK-3.1-win32\eclipse\eclipse.exe
    load/unzip into "C:\eclipse-SDK-3.1-win32\eclipse"

    Hopefully this will now have fixed the problems as the program trying to do the update will find the packages it requires.

    BTW after Carbide developer has load the old Eclipse at
    C:\eclipse-SDK-3.1-win32\eclipse may not work but thats not a problem.


    Did you get "Initialising Symbian .... " and moving progress bar in the bottom right?.
    Have you got S60 3rd Ed MR loaded already?.

    If not load from http://discussion.forum.nokia.com/fo...ad.php?t=85754

    Good Luck
    Jim
    Last edited by jimgilmour1; 2006-09-18 at 15:00.

  3. #3
    Registered User
    Join Date
    Oct 2006
    Posts
    12

    Re: Problem with Cabride.c++ v1.1

    1. Download http://www.eclipse.org/downloads/dow...-win32-x86.zip
    2. If there are some errors in the zip, repar it with somethink like WinRar
    3. Unzip swt-awt-win32-3139.dll, swt-gdip-win32-3139.dll, swt-win32-3139.dll in C:\Windows\System32\
    4. Enjoy! ^__^

  4. #4
    Registered User
    Join Date
    Oct 2006
    Posts
    12

    Re: Problem with Cabride.c++ v1.1

    I meet some troubles with other java applications (like Azureus) later, so it's better to move this dlls from windows\system32 to the folder, where carbide.c++.exe is.

Similar Threads

  1. Problem with eglSwapBuffers and heap corruption
    By greatape in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2007-05-24, 03:35
  2. netcards - Problem with opening adapter
    By kernj in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-01-10, 08:56
  3. WAP service problem on Apache
    By bigg_o in forum Browsing and Mark-ups
    Replies: 3
    Last Post: 2005-04-17, 16:05
  4. Problem: S60 SDK for CW in PC with .NET
    By anttij in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2005-02-28, 11:36
  5. 7210 Silent Problem
    By MarkMckim in forum Mobile Java General
    Replies: 1
    Last Post: 2003-03-18, 12:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×