×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Sep 2006
    Posts
    3

    Carbide.c++? .vs? nothing works

    Could someone tell me what's the problem here... everything was fine couple of months ago when I was using VC++ 6.0 and S60 2nd ed. SDK. Just some minor problems but mostly things went fine.

    Then I decided to try 3rd ed. SDK in home too (as I've been doing 3rd ed. code in work for over a year now using CW). I noticed that there's no VC++ 6 support anymore, so I downloaded Carbide.c++ express and gave it a try.

    The UI and debugger were really weird at first.. in addition Carbide messed up my test project couple of times so that I needed to create them again with app. wizard. Finally when I got the WINSCW build to work I tried GCCE. Guess what? It fails always with internal compiler error and crap, I searched these forums for help and even tried couple of solutions but none of them worked.

    I decided to try Carbide.vs too, but same problem with it. Though the wizards were way better than in Carbide.c++.

    So, should I just use emulator on my spare time and build the binaries in work or what? I bet my boss wouldn't like that (guess what's the company btw.)..

  2. #2
    (Retired) Nokia Developer Admin.
    Join Date
    Jan 2006
    Location
    Michigan
    Posts
    4,664

    Re: Carbide.c++? .vs? nothing works

    Carbide and CodeWarrior use a different version of the SDK than for Visual Studio. I would think maybe you have these mixed up, generally that is what the problem is for others that have had your problems.

    For Visual Studio or GCCE ask the questions on the Symbian tools forum, ask Carbide and CodeWarrior questions on this one. Jus so there isno confusion

    Ron

  3. #3
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: Carbide.c++? .vs? nothing works

    If you have issues with the GCCE build that most likely means that you have not yet installed the Arm toolchain that comes with the S60 3.0 SDK, check the SDK installation docs for details.

  4. #4
    Regular Contributor
    Join Date
    Aug 2006
    Location
    Bangalore
    Posts
    200

    Post Re: Carbide.c++? .vs? nothing works

    With SDK 3rd edition it works properly . But no with two sdks and different Drive and space in between workspace name.

    chirag

  5. #5
    Nokia Developer Expert
    Join Date
    Oct 2004
    Location
    Austin, TX USA
    Posts
    271

    Re: Carbide.c++? .vs? nothing works

    Carbide.c++ and Carbide.vs both support multiple SDKs, but it's correct that you need to make sure your workspace path has no spaces in it, and you also need to make sure that you are using the CodeWarrior version of the SDKs and not the MSVS one.

    Regards,

    Matt P.

Similar Threads

  1. Replies: 2
    Last Post: 2006-10-06, 17:24
  2. call works on nokia6680 but not n70 or 3230
    By seacabo in forum Symbian
    Replies: 0
    Last Post: 2006-06-08, 14:15
  3. Works in emulator not in phone
    By cervera in forum Mobile Java Networking & Messaging & Security
    Replies: 3
    Last Post: 2003-11-07, 15:33
  4. OTA How does it works
    By David_Kihlström in forum Mobile Java General
    Replies: 1
    Last Post: 2003-10-06, 18:43
  5. my http connection works on series60,doesn't on series 40
    By silvolu in forum Mobile Java Networking & Messaging & Security
    Replies: 4
    Last Post: 2003-04-23, 22:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •