Hi

I have a very strange problem that seems to happen on older nokias(e.g. first n-gage, nokia 3200) with Http Connection.

The application runs smoothly and connects fine over Http for several days and then suddenly stops working
even though the client nor the server was changed (the server is running
on a dedicated machine and has been up for over a month, while the client
has been on the phone for over a week and worked for several days). The application
still runs smoothly on motorolas, imates etc.

The problem seems to be that the client just suddenly starts to read the
wrong content-length of responses (e.g. real content-length = 45 but phone
reads it as 4), I know the server is sending the correct response since all
other phones still work and I have run it through a proxy that prints
out the server response. Even if I dont use the content-length header
and just read from input stream until -1 is returned the client still reads 4 bytes instead of the 45
bytes the server really wrote!

I am really stumped on this one since no code has changed and everything
worked initially and then just stopped working. Has anyone encountered something similar on the older nokias?

Would appreciate any help!

Thanks