×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Apr 2003
    Location
    Oulu, Finland
    Posts
    6

    Question Carbide.c++ v1.1, debugging & Out of Memory

    Hi,

    I tried to debug a largish S60 3rd ed project with Carbide.c++ v1.1.

    During the launch I get a "internal error" dialog that says an out of memory error happened and it could be fixed by giving more memory to the JVM.

    Also the release notes tell: "The workaround is to either not expand binary files with very large source bases or give the VM more memory (option -Xmx #m) in the Carbide.c++.ini file found at the installation root. "

    I have tried to set -Xmx1200m instead of the default -Xmx512m in carbide.c++.ini but it hasn't helped. I have 1.5G of memory and carbide won't start if -Xmx is set higher than 1200.

    Does anyone have any info how to "not expand binary files" or anything that could help?

    Clip from .log:
    -- clip --
    !SESSION 2006-09-25 16:46:08.386 -----------------------------------------------
    eclipse.buildId=I20050627-1435
    java.version=1.5.0_05
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_GB
    Command-line arguments: -os win32 -ws win32 -arch x86

    !ENTRY com.symbian.cdt.sdk 2 2 2006-09-25 16:46:16.598
    !MESSAGE RVCT 2.2 was not found on the PATH environment variable. RVCT 2.2 targets will not build.

    !ENTRY org.eclipse.ui 4 4 2006-09-25 16:46:19.332
    !MESSAGE Unhandled event loop exception

    !ENTRY org.eclipse.ui 4 0 2006-09-25 16:46:19.332
    !MESSAGE Failed to execute runnable (org.eclipse.jface.util.Assert$AssertionFailedException: null argument
    !STACK 0
    org.eclipse.swt.SWTException: Failed to execute runnable (org.eclipse.jface.util.Assert$AssertionFailedException: null argument
    at org.eclipse.swt.SWT.error(SWT.java:2942)
    at org.eclipse.swt.SWT.error(SWT.java:2865)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:126)
    at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3102)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2761)
    at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1699)
    at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1663)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:367)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:143)
    at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:103)
    at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:226)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
    at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
    at org.eclipse.core.launcher.Main.run(Main.java:973)
    at org.eclipse.core.launcher.Main.main(Main.java:948)
    Caused by: org.eclipse.jface.util.Assert$AssertionFailedException: null argument;
    at org.eclipse.jface.util.Assert.isNotNull(Assert.java:149)
    at org.eclipse.jface.util.Assert.isNotNull(Assert.java:125)
    at org.eclipse.jface.viewers.StructuredSelection.<init>(StructuredSelection.java:66)
    at org.eclipse.cdt.internal.ui.buildconsole.BuildConsolePage.setInitialSelection(BuildConsolePage.java:354)
    at org.eclipse.cdt.internal.ui.buildconsole.BuildConsolePage.createControl(BuildConsolePage.java:203)
    at org.eclipse.ui.internal.console.ConsoleView.doCreatePage(ConsoleView.java:260)
    at org.eclipse.ui.part.PageBookView.createPage(PageBookView.java:315)
    at org.eclipse.ui.part.PageBookView.partActivated(PageBookView.java:613)
    at org.eclipse.ui.internal.console.ConsoleView$1.run(ConsoleView.java:331)
    at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:123)
    ... 18 more

    !ENTRY org.eclipse.ui 4 4 2006-09-25 16:48:26.525
    !MESSAGE Unhandled event loop exception

    !ENTRY org.eclipse.ui 4 0 2006-09-25 16:48:26.525
    !MESSAGE Requested array size exceeds VM limit
    !STACK 0
    java.lang.OutOfMemoryError: Requested array size exceeds VM limit

    !ENTRY org.eclipse.core.runtime 4 2 2006-09-25 16:48:26.585
    !MESSAGE An internal error occurred during: "Launching".
    !STACK 0
    java.lang.OutOfMemoryError: Requested array size exceeds VM limit
    -- clip --

  2. #2
    Product Specialist
    Join Date
    Jun 2003
    Location
    UK
    Posts
    191

    Re: Carbide.c++ v1.1, debugging & Out of Memory

    Hi Kauppi,

    I also have this problem and wondered whether you were able to resolve it?

    Regards

    Mark

  3. #3
    Regular Contributor
    Join Date
    Jun 2006
    Posts
    54

    Re: Carbide.c++ v1.1, debugging & Out of Memory

    Hi,

    I face the same problem.
    Till now no luck.
    Has anybody found out the soultion?

    regards,
    Bharat

Similar Threads

  1. CAknForm/CAknDialog and memory management
    By ValentinK in forum Symbian
    Replies: 0
    Last Post: 2006-07-10, 20:16
  2. Memory leak debugging
    By cputoaster in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 6
    Last Post: 2005-02-04, 21:01
  3. 7650 and 3650 Canvas and FullCanvas memory
    By marcilgen in forum Mobile Java General
    Replies: 5
    Last Post: 2003-07-08, 12:24
  4. can not successfully link any sample using .NET
    By lobotomat in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2002-08-20, 00:29
  5. 9210 and 9210i java memory
    By allams in forum Mobile Java General
    Replies: 0
    Last Post: 1970-01-01, 02:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×