×

Discussion Board

Results 1 to 6 of 6

Threaded View

  1. #1
    Registered User
    Join Date
    Jun 2006
    Location
    Hong Kong, China
    Posts
    10

    Error >>> java.lang.RuntimeException: command failed with Symbian error code: -4

    I have using NetBeans with S60 3rd Ed. to develop a program.

    My program mainly contains some binary files, and I put it as resource file (in res folder)
    The jar is built with arround 5MB.

    And I try to run this program with S60 emulator, however it promt out an error of "java.lang.RuntimeException: command failed with Symbian error code: -4"

    I also doing some testing:
    1,The testing is a resource of binary file arround 400KB, and write a normal read data code. Build as a jar and it's running normally in S60 emulator.

    2,Then I copy that resource file 1 times and put it in resource without any reading process. Build as a jar and run it in emulator and get the same error.

    3, I also run the Carbide J stand alone, and get the same error as NetBeans promted.

    Moreover, I can run all the programs with emulator of Java Wireless Toolkit 2.3 normally.

    What happen for this error?
    Is it related to Carbide J, or the file size, or the S60 SDK...


    Regards,
    Frank
    Last edited by hkfrankchan; 2006-09-27 at 08:01.

Similar Threads

  1. Current Symbian Development Opportunities...!!
    By mobile2004 in forum Symbian
    Replies: 0
    Last Post: 2005-01-17, 17:58
  2. Replies: 0
    Last Post: 2004-05-21, 11:16
  3. Replies: 2
    Last Post: 2004-05-08, 09:09
  4. Global Symbian Development Opportunities *High Importance*
    By sara.lindsay in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2004-05-07, 12:17
  5. Replies: 0
    Last Post: 2004-05-07, 11:45

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •