×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Jul 2005
    Posts
    40

    Exclamation CARBIDE: Missing library 'edllstub'

    Though I'm not aware of anything having changed (I've been able to run this app in the emulator no probs) after attempting to run in debug mode I am now getting this 'missing library' console (see below) message. The library has been included for a considerable time. I've looked in the path "C:/Symbian/8.0a/S60_2nd_FP2_CW/epoc32/release/WINSCW/UDEB/" and it is indeed not there!!

    Anybody any idea what may have happended at what I should do next??

    Code:
    CONSOLE EXTRACT:
    'Building target: C:/Symbian/8.0a/S60_2nd_FP2_CW/epoc32/release/WINSCW/UDEB/PSA03.app'
    'Invoking: WINSCW C/C++ Linker'
    mwldsym2.exe -sym full -subsystem windows -msgstyle parseable -nowraplines -nodefaultlibs -shared -export dllexport -stdlib -m=?_E32Dll@@YGHPAXI0@Z -L"C:\Symbian\8.0a\S60_2nd_FP2_CW\epoc32\release\winscw\udeb" -o "C:/Symbian/8.0a/S60_2nd_FP2_CW/epoc32/release/WINSCW/UDEB/PSA03.app" -search  ./src/PSA03App.o ./src/PSA03AppUi.o ./src/PSA03Container.o ./src/PSA03Container2.o ./src/PSA03DbEngine.o ./src/PSA03Document.o ./src/PSA03Model.o ./src/PSA03View.o ./src/PSA03View2.o  ./.generated/winscw_uid.o   -ledllstub.lib -llibedllstub.lib -ledll.lib -legcc.lib -leuser.lib -lapparc.lib -lcone.lib -leikore.lib -lavkon.lib -leikcoctt.lib -lbafl.lib -lefsrv.lib -leikapp.lib -lestor.lib
    mwldsym2.exe|Usage|Error
    
    Errors caused tool to abort.
    >No library file found matching 'libedllstub.lib{.lib|.a}' or 'edllstub.lib'
    make: *** [C:/Symbian/8.0a/S60_2nd_FP2_CW/epoc32/release/WINSCW/UDEB/PSA03.app] Error 1
    make: Target `all' not remade because of errors.
    Build complete for project PSA03
    Last edited by ltomuta; 2008-02-07 at 11:02. Reason: Formatting

  2. #2
    Regular Contributor
    Join Date
    Nov 2007
    Location
    Ukraine
    Posts
    56

    Re: CARBIDE: Missing library 'edllstub'

    Yes, It's true. This library isn't present for gcce configuration
    but it's present for armv5

    Can anybody help me with Tls library?
    Last edited by sashaslonmailer; 2008-02-07 at 10:21.

  3. #3
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: CARBIDE: Missing library 'edllstub'

    Quote Originally Posted by sashaslonmailer View Post
    Yes, It's true. This library isn't present for gcce configuration
    but it's present for armv5

    Can anybody help me with Tls library?
    You do realize, I hope, that you are replying to a 16 months old post which refers to an SDK missing both the GCCE and ARMV5 configurations.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. Fail to build syexpat 1.3 under 2nd FP3
    By harry_zhang in forum Symbian
    Replies: 10
    Last Post: 2010-03-19, 10:24
  2. need information about j2me polish
    By rathikathangaraj in forum Mobile Java General
    Replies: 4
    Last Post: 2007-12-19, 09:01
  3. Compilation series 60 3rd edition
    By asmobease in forum Symbian Tools & SDKs
    Replies: 32
    Last Post: 2006-09-13, 09:46
  4. Can’t launch application on 6630
    By kaffemannen in forum Symbian
    Replies: 8
    Last Post: 2005-06-29, 10:49
  5. "Not found" on target 9500
    By alex_makarov in forum Symbian
    Replies: 10
    Last Post: 2004-12-03, 14:05

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×