×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Sep 2006
    Posts
    34

    CAknWaitDialog - Problem?

    Hello!
    I want to show the waiting note during load a image.

    What problems are there in my code?

    CAknWaitDialog never has been shown in both the emulator and phone.

    If there is no STEP 3. line, It was shown.

    Help me!


    void PhotoListView::LoadSelectedPhoto(TFileName szSelPhoto)
    {
    //CAknWaitDialog* iWaitDialog = NULL;
    if(iWaitDialog)
    delete iWaitDialog;
    iWaitDialog = NULL;

    iWaitDialog = new ( ELeave )CAknWaitDialog(reinterpret_cast <CEikDialog**> (&iWaitDialog)
    , ETrue );

    iWaitDialog->PrepareLC(R_WEBCLIENT_DOWNLOAD_WAIT_NOTE);
    iWaitDialog->SetTone(CAknNoteDialog::EConfirmationTone);
    iWaitDialog->RunLD(); // STEP 1.
    // iWaitDialog->ExecuteLD( R_WEBCLIENT_DOWNLOAD_WAIT_NOTE );

    LoadImage(szSelPhoto); //STEP 2.

    AppUi()->ActivateLocalViewL (TUid::Uid (ESelectPersonView));//STEP 3.
    }
    Mobile Software Developer

    C++ for Symbian OS S60 2nd/3rd Edition SDK

    Multimedia Process

  2. #2
    Regular Contributor
    Join Date
    Apr 2006
    Location
    India
    Posts
    383

    Re: CAknWaitDialog - Problem?

    Hi!

    1. Derive a class publically from MAknBackgroundProcess.
    e.g CMyWaitDialog
    2. Implement all its virtual functions there.
    3. write a method there to show wait dialog.
    4. Use CAknWaitNoteWrapper's ExecuteL(---) to execute ur wait
    dialog.
    5. U need to instantiate CAknWaitNoteWrapper in CMyWaitDialog
    6. IsProcessDone() return ETrue
    7. Now instantiate CMyWaitDialog in ur view.
    8. when ur image loading starts call function of CMyWaitDialog which
    executes the wait dialog.
    9. when loading completes call ProcessFinished() callback function.
    10. Write the resource dlg neatly in .rss, delete the pointers neatly

    Hope this helps . It works fine for me.

    Still any problems.. let me know
    Regards,
    Shilpa Kulkarni

Similar Threads

  1. Problem with eglSwapBuffers and heap corruption
    By greatape in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2007-05-24, 03:35
  2. netcards - Problem with opening adapter
    By kernj in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-01-10, 08:56
  3. WAP service problem on Apache
    By bigg_o in forum Browsing and Mark-ups
    Replies: 3
    Last Post: 2005-04-17, 16:05
  4. Problem: S60 SDK for CW in PC with .NET
    By anttij in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2005-02-28, 11:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×