×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Oct 2006
    Posts
    7

    carbide.c++ s60v3.0 SDK - EPOCROOT pb

    Hi guys,

    I'm using Carbide C++ Express. I installed UIQ v3 SDK and Nokia S60v3.0 and MR SDKs.
    The projects and SDKs are installed on the same drive (H
    I have no problem with UIQ sdk.
    When I try to cimpile with s60 sdk I get the following error:
    ERROR: EPOCROOT must be an absolute path, not containing a drive letter.

    After searching the forum I modified the file devices.xml to set EPOCROOT to:
    S60_3rd -> \Symbian\9.1\S60_3rd\
    S60_3rd_MR -> \Symbian\9.1\S60_3rd_MR\
    and added the system env var: EPOCROOT and set it to "\".
    But it doesn't solve my problem.
    I notice a funny thing, when I have a look at the project properties->C/C++ build->environment in the system variables table.
    - SDK S60_3rd EPOCROOT is set to C:\Symbian\9.1\S60_3rd\
    I don't know where the C: comes from
    - SDK S60_3rd_MR EPOCROOT is present only when I check "show parent level var" and its value is "\"

    When I modify devices.xml and set EPOCROOT to:
    S60_3rd -> Symbian\9.1\S60_3rd\
    S60_3rd_MR -> Symbian\9.1\S60_3rd_MR\
    just removed the "\" at the beginning of the path
    I get the following result in the sys var table:
    - SDK S60_3rd EPOCROOT is set to C:\Program Files\Carbide\Symbian\9.1\S60_3rd\ !!!!!
    - SDK S60_3rd_MR EPOCROOT is present only when I check "show parent level var" and its value is "\"

    I don't know what's wrong!!
    I have no problem with UIQ SDK!

    Should I install Carbide.C++ Express on drive H?
    Any suggestion would be very appreciated.
    Thanks in advance.

    Vincent.

  2. #2
    Registered User
    Join Date
    Oct 2006
    Posts
    7

    Re: carbide.c++ s60v3.0 SDK - EPOCROOT pb

    Hi again

    uninstalled s60v3_MR sdk then re-installed s60v3 SDK and it works!

    Vincent.

Similar Threads

  1. MIDP applicatyion accessing a servlet not working in series 60 emulator
    By ferozekadamapuzha in forum Mobile Java General
    Replies: 11
    Last Post: 2008-05-07, 18:04
  2. Multple Sdk + EPOCROOT problem
    By chishti.hameed in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2005-07-12, 07:55
  3. Which Java SDK to use for Nokia 3650?
    By pcarew in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2004-02-12, 16:21
  4. Http connection problem in 6310i
    By teahola in forum Mobile Java General
    Replies: 1
    Last Post: 2002-10-03, 18:46
  5. How do I set the classpath end the epocroot for nokia 9210 SDK
    By polimorfus in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2002-07-13, 02:33

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×