×

Discussion Board

Results 1 to 11 of 11
  1. #1
    Registered User
    Join Date
    Oct 2006
    Posts
    10

    Which development tool?

    Hi,

    I m new to this stuff. I would like to know what kind of tool i need to write app. for mobile phones?

    i have borland developer studio 2006 and MS visual studio 2005.I can write code in them but then how to put the code into mobiles?

    thanks

  2. #2
    Super Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,560

    Re: Which development tool?

    You could use the free Carbide.c++ Express, if you wish to do C++ development for Symbian OS based phones.

    Visual Studio 2005 is not supported for Symbian development (Visual Studio 2003 would work with Carbide.vs).

    Other alternatives is the commercial Carbide.c++ Developer or the older CodeWarrior 3.1.

    I don't think anything has been done to support Borland tools in the last 2-3 years.

    Carbide.j would work for Java development (or use Sun's Wireless Tool Kit).

    More here: http://forum.nokia.com/main/resource...dks/index.html

  3. #3
    Registered User
    Join Date
    Oct 2006
    Posts
    10

    Re: Which development tool?

    hi, i have just downloaded and installed S60 3rd Edition SDK Version 1.0 and Carbide.c++ Express V 1.0, after a few setbacks n browsing through the forum i was able to build and emulate the hello world example.. the problem is when i try to install the sis file on my 6600 it shows "file corupted" message..
    so what is wrong, am i using the right tools??
    shud i go for CodeWarrior, coz i've heard its better for beginers..
    please help !

  4. #4
    Registered User
    Join Date
    Jul 2005
    Location
    Bengaluru, India
    Posts
    747

    Re: Which development tool?

    Quote Originally Posted by SunLikeStar
    hi, i have just downloaded and installed S60 3rd Edition SDK Version 1.0 and Carbide.c++ Express V 1.0, after a few setbacks n browsing through the forum i was able to build and emulate the hello world example.. the problem is when i try to install the sis file on my 6600 it shows "file corupted" message..
    so what is wrong, am i using the right tools??
    shud i go for CodeWarrior, coz i've heard its better for beginers..
    please help !
    It's better using Carbide.c++ a latest version (v 1.1 thought I didn’t try it might be better that the old version) can be obtained from here: Carbide.c++ Professional and Developer versions are out. And more over Nokia is going to give more support for Carbide.c++ in the future. The latest version of Code Warrior is 3.1 and they are not supposed to come with a new version.

    Now in your case the problem is that you've build the application in 3.0 SDK but that is not supporting by Nokia 6600. For Nokia 6600 you've to build your application against 2.0 SDK.

  5. #5
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,344

    Smile Re: Which development tool?

    Hello SunLikeStar,

    Your Nokia 6600 falls into Symbian OS v7.0s. Series 60 2nd Edition device.
    You need to download the appropriate SDK to get worked with.

    You would find 3rd last entry in the download section from the following link:
    http://www.forum.nokia.com/info/sw.n...16-3.0-mr.html

    For future reference you can check for device specifications from the following link:
    http://www.forum.nokia.com/devices/

    Regards.
    Kiran.

  6. #6
    Registered User
    Join Date
    Oct 2006
    Posts
    10

    Re: Which development tool?

    thanks a lot vin2ktalks & kiran10182..
    i'l do the required & post a follow up

    hey kiran the 3rd last entry is "2nd edition, wins", but i can see other 2n edition sdks in the list.. r u sure that the 3rd last entry is the latest one.. i mean for 6600..

    also i checked the device specification befor downloading the sdk, in the recomended sdk's in 6600 specifications the 3rd edition sdk for os 9.1 is mentioned, (here: http://www.forum.nokia.com/devices/6600 ) that's why i downloaded it..
    a bit confused here, waiting for ur guidance....
    Last edited by SunLikeStar; 2006-10-11 at 19:56.

  7. #7
    Registered User
    Join Date
    Oct 2006
    Posts
    10

    Re: Which development tool?

    Hi,

    I installed carbide c++ and the appropriate SDK. Should i need to install ActivePerl?? because on a tutorial i saw that.

    thanks

  8. #8
    Registered User
    Join Date
    Jul 2005
    Location
    Bengaluru, India
    Posts
    747

    Re: Which development tool?

    Quote Originally Posted by SunLikeStar
    thanks a lot vin2ktalks & kiran10182..
    i'l do the required & post a follow up

    hey kiran the 3rd last entry is "2nd edition, wins", but i can see other 2n edition sdks in the list.. r u sure that the 3rd last entry is the latest one.. i mean for 6600..

    also i checked the device specification befor downloading the sdk, in the recomended sdk's in 6600 specifications the 3rd edition sdk for os 9.1 is mentioned, (here: http://www.forum.nokia.com/devices/6600 ) that's why i downloaded it..
    a bit confused here, waiting for ur guidance....
    This page is general for all SDKs, you have to select the appropriate SDK from the combo box. For your 6600 the right one is 2nd Edition, there you can find two one for Visual Studio (2nd Edition, WINS (101 MB)) and another for CodeWarrior (2nd Edition, CW (101 MB)). I hope as you are supposed to work in Carbide.c++ you would download the one which supports CodeWarrior.

  9. #9
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,344

    Smile Re: Which development tool?

    To raysefo,

    Yes, You need to have Active Perl Installed.
    Check Out Follwoing Link for more details.
    http://discussion.forum.nokia.com/fo...ad.php?t=74925

    Regards.
    Kiran.

  10. #10
    Super Contributor
    Join Date
    Oct 2005
    Location
    Hyderabad,India
    Posts
    1,156

    Re: Which development tool?

    Quote Originally Posted by raysefo
    Hi,

    I installed carbide c++ and the appropriate SDK. Should i need to install ActivePerl?? because on a tutorial i saw that.

    thanks
    Yea, you need to install Active Perl and Java to get the emulator working.I have Perl5.8.7 installed in my system.you can also try one of those versions or higher versions.

    Bst Regrdz
    Priju

  11. #11
    Registered User
    Join Date
    Oct 2006
    Posts
    10

    Re: Which development tool?

    thanx vin2ktalks, ya i'l be workin on Carbide.c++ .. so i'l go ahead with downloadin "2nd Edition, CW (107 MB)"..

Similar Threads

  1. Mobile Application Development Tool with Sync Server
    By thiagu74 in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2010-07-25, 09:37
  2. Tool Development
    By CH_Tang in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2005-08-15, 08:06
  3. Mobile Application Development Tool - Best Download
    By thiagu74 in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2004-10-07, 08:18
  4. Mobile Application Development Tool
    By thiagu74 in forum PC Suite API and PC Connectivity SDK
    Replies: 0
    Last Post: 2004-10-07, 08:14
  5. Which development tool is used for 9110?
    By WhileTrue in forum Mobile Java General
    Replies: 1
    Last Post: 2002-12-05, 05:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×