×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Oct 2006
    Posts
    1

    CarbideC++ linker error

    I am getting the following linker error:-
    mwldsym2.exe|Linker|Error
    >Undefined symbol: 'RPhone::RPhone(void) (??0RPhone@@QAE@XZ)'
    mwldsym2.exe|Linker|Error
    >Undefined symbol: 'RLine::RLine(void) (??0RLine@@QAE@XZ)'

    I am using UIQ3SDK for building my project.
    I added etel3rdparty.lib.
    The other etel libraries are DLLs...

    Some one... pls help with the solution

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,689

    Re: CarbideC++ linker error

    Try adding etel.lib. At least in S60 3rd edition these symbols are defined there.

Similar Threads

  1. error LNK2019: unresolved external symbol ???
    By wgarnett in forum Symbian
    Replies: 3
    Last Post: 2009-09-28, 06:53
  2. carbide build problem help please
    By berkcekisbas in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2006-09-26, 19:41
  3. My BuilderX (with S60 SDK 2.1.NET MS version) cannot build ARMI UREL
    By danielvidonyi@hotmail.com in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2006-05-04, 21:30
  4. Compiling error (Urgent)
    By waelali in forum Symbian
    Replies: 2
    Last Post: 2006-02-06, 04:32
  5. Link errors
    By georgica1979 in forum Symbian
    Replies: 4
    Last Post: 2003-04-03, 17:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×