×

Discussion Board

Results 1 to 3 of 3

Thread: emulator error

  1. #1
    Registered User
    Join Date
    Oct 2006
    Posts
    12

    emulator error

    Hi all,

    I am using the software:

    symbian 8.0a
    CodeWarrior for Symbian v3.1
    2nd Edition SDK Feaure Pack 2

    My helloworld basic program worked well.

    But for my dialog creation application, problem arised....

    my application has no compilation and linking errors...In the emulator also the application icon is seen... but when i try to open that application by clicking on the icon "system error " pops up....

    so I pursued a lot and saw the preferences of the emulator where it was shown that java runtime version 1.4.1_02 is needed so i uninstalled my previous java runtime version 1.3.1_18 and installed jre 1.4.1_02.

    Now when I execute the application of creating the dialog there are no errors but when the emulator starts then an error is shown as
    "etelsat.dll is not found. The application is failed to start.Reinstalling the application may fix the problem."
    But if I click ok the emulator is starting still the the dialog is not popping instead "system error" is shown.(Helloworld is working still).

    I reinstalled codewarrior,sdk and also jre but could not rectify this.
    What should I do?



    Thanks and regards,
    Devi.

  2. #2
    Registered User
    Join Date
    Jun 2006
    Posts
    259

    Re: emulator error

    Hi,

    Which class are you using? CEikDialog? Check the Dialog resource in .rss, did fields entered properly?

    cheer's

  3. #3
    Registered User
    Join Date
    Jul 2005
    Location
    Bengaluru, India
    Posts
    747

    Re: emulator error

    Quote Originally Posted by india.iet
    ...
    But if I click ok the emulator is starting still the the dialog is not popping instead "system error" is shown.(Helloworld is working still).
    ...
    If you're getting the "System error" while opening a application or while running the application probably some APIs are getting Panic. Do the following steps:

    1. Enable the Extended panic option from the preference of the emulator (if it's device then you have to create an ErrRd file in the c:\system\bootdata\ in your case as you are working in 2nd Ed. FP2). That will give you proper error information rather than a "System error".
    2. Then you've to find out which line of code is giving this error.
    3. Still if you are unable to fix the problem post the line of code which is giving you the error with possible details.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×