×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    200

    A HelloWorld casualty

    I am attempting to run my first Symbian code - HelloWorld.mmp and am following Leigh Edward's "Developing Series 60 Applications". On Build, I get the following 2 warnings:

    - CTags not installed or not in path
    - Invalid project path: Include path not found (C:\workspace\HelloWorld\group)

    When I select Run as->Run, a dialogue box opens. Here, however, the 'Run' button is not activated!

    Would appreciate all advise on how to proceed.

    cheers,
    wirefree
    Last edited by wirefree101; 2006-10-24 at 05:14.

  2. #2
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    200

    Re: A HelloWorld casualty

    ADDITION:

    I have been able to build & run the HelloWorld program on a different machine successfully. The following warnings, however, remain:

    - CTags not installed or not in path
    - Invalid project path: Include path not found (C:\Labs\workspace\HelloWorld\group).
    - The system cannot find the file specified.[make ]

    The emulator opens successfully too. But the HelloWorld application is not present in the applications menu!

    Would appreciate some advise here.

    cheers,
    wirefree101

  3. #3
    Super Contributor
    Join Date
    Oct 2005
    Location
    Hyderabad,India
    Posts
    1,156

    Re: A HelloWorld casualty

    Quote Originally Posted by wirefree101
    - The system cannot find the file specified.[make ]
    could you please check your Active build configuration in carbide c++.
    1)Right click on the helloworld project
    2) move to Active Build configuration
    3) Check whether Active configuration is " emulator Debug"

    Regrdz
    Priju

  4. #4
    Registered User
    Join Date
    Oct 2006
    Posts
    3

    Re: A HelloWorld casualty

    Joining the list of casualties

    I have s60_2nd_fp2_sdk_msb installed on my system along with Perl and J2Se development kit 5 Update 9.
    My Path file reads as follows
    D:\Perl\bin\;C:\Program Files\Common Files\Symbian\Tools;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;D:\Symbian\8.0a\S60_2nd_FP2\epoc32\gcc\bin\;D:\Symbian\8.0a\S60_2nd_FP2\epoc32\tools\;C:\Program Files\Microsoft Visual Studio .NET\Vc7\bin;

    And EPOCROOT = D:\Symbian\8.0a\S60_2nd_FP2

    Now, when I try to run the following like at command prompt(well at D:\Symbian\8.0a\S60_2nd_FP2\Series60Ex\helloworldbasic\group\ )

    makmake helloworldbasic.mmp vc7

    I get

    "LINK.exe" is not recognised

  5. #5
    Registered User
    Join Date
    Oct 2006
    Posts
    3

    Re: A HelloWorld casualty

    Oops I missed out the following

    "LINK.exe" is not recognised as an internal or external command, operable program or batch file.
    ERROR: failed to find version information for LINK.exe"

    Please help. What am I doing wrong?

  6. #6
    Registered User
    Join Date
    Oct 2006
    Posts
    3

    Re: A HelloWorld casualty

    Found an old thread that helped solve my problem.

    http://discussion.forum.nokia.com/fo...ad.php?t=49332

  7. #7
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    200

    Re: A HelloWorld casualty

    Hi Jacob,

    On right-clicking the project name in the C++ Projects window, I get the following options:

    - New
    - Go Into
    - Open in New Window
    - Build Project
    - Rebuild Project
    - Copy
    - Delete
    - Move
    - Rename
    - Import...
    - Export...
    - Refresh
    - Close project
    - Run as
    - Debug as
    - Team
    - Compare with
    - Restore from Local History
    - Properties
    - Convert to...


    Where should I be looking for "Active Build configuration"?

  8. #8
    Super Contributor
    Join Date
    Dec 2005
    Location
    England,UK
    Posts
    1,600

    Re: A HelloWorld casualty

    Quote
    2) move to Active Build configuration
    This function is not available in Carbide Expresss only Developer and Pro.

    To get Hello World working.
    Create a new workspace name without spaces like.
    C:\symbian\NewHello

    "->" represents the arrow to next function or the next command.
    From the main menu Select
    NEW-> s60 C++ application for S60
    In the new wizard window
    ProjectName is required "HelloWorld"
    Click "Next"
    Select the s60 2.x Hello World application"
    Click Next
    wait for all available SDK to show in the Box
    Click/tick box next to "S60_2nd_FP2_CW"
    the tick next to "S60 2.6 Emulator Debug" appears
    Click "Next"
    In Author box enter your name
    Click "Next"
    In the next screen Click "Finish"

    The project is now created.
    "Top" means the left Window Project Explorer Pane on the word "HelloWorld",Project name.

    In the left pane right click mouse on the Top Hello world.
    Select Properties from near the bottom of the list
    In the new properties window Click on the third down "C/C++ Build"
    In the new display drop down there is a Configuration drop down,
    which lets you select the build Emulator or Phone. Default is Emulator.
    Click "Apply" and "OK"

    In the left pane right click mouse on the Top Hello world.
    Select rebuild.
    Click run in background
    Click console
    Click Maximize screen icon and watch build take place.

    When complete
    In the left pane right click mouse on the Top Hello world.
    Select "Debug As" -> Debug.
    In the Debug window. Click Debug and debug starts.
    Select HelloWorld in the emulator , same way as in phone.
    Click on HelloWorld application.


    Only "S60_2nd_FP2_CW" is supported in Carbide Express. I cannot see any other 2nd Edition version in the available SDK versions.
    Available at

    http://forum.nokia.com/info/sw.nokia...16-3.0-mr.html

    Use the drop down and Select the 2nd Ed CW version with (150MB) at end of line.


    Good Luck,
    Jim
    Last edited by jimgilmour1; 2006-10-25 at 10:53.

Similar Threads

  1. Replies: 4
    Last Post: 2006-02-15, 03:33
  2. Replies: 5
    Last Post: 2004-11-13, 20:42
  3. Failed to run the HelloWorld MIDlet in the emulator
    By ckchui in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2004-09-17, 04:47
  4. 求助:没有调用到包的问题
    By youpengli in forum [Archived] Other Programming Discussion 关于其他编程技术的讨论
    Replies: 1
    Last Post: 2004-05-10, 03:03
  5. 求助:N9200 Series SDK上的问题
    By youpengli in forum [Archived] Other Programming Discussion 关于其他编程技术的讨论
    Replies: 3
    Last Post: 2004-05-10, 02:56

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×