×

Discussion Board

Results 1 to 15 of 15
  1. #1
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    200

    Right version of Perl, CW, & SDK

    Hi Guys,

    - I am following Leigh Edward's "Developing Series 60 Applications" book.
    - The sample code that comes along with it is titled "EMCCSoft_S60_2x_Installer".
    - The examples in the book are for CodeWarrior IDE.

    My question is:

    Which version of Perl, CW, & SDK should I install so as to circumvent any compatibility issues?

    Would appreciate a prompt response.

    cheers,
    wirefree101

    P.S.: Do you know of any book which illustrates examples using Carbide.c++?

  2. #2
    Super Contributor
    Join Date
    Oct 2005
    Location
    Hyderabad,India
    Posts
    1,156

    Re: Right version of Perl, CW, & SDK

    Quote Originally Posted by wirefree101
    Hi Guys,

    My question is:

    Which version of Perl, CW, & SDK should I install so as to circumvent any compatibility issues?
    Hi,

    for runing the examples that comes along with emcc you can download FP2 sdk,
    you would find it here:
    http://www.forum.nokia.com/info/sw.n...16-3.0-mr.html

    for codewarior you can use CW version 3.1
    follow this link:
    http://www.forum.nokia.com/info/sw.n...rsion_3_1.html

    and for perl:- you can use Perl 5.8.7 or later versions.
    check out www.perl.com

    Best Regardz
    Priju

  3. #3
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    200

    Re: Right version of Perl, CW, & SDK

    Appreciate the reply, Priju.

    With reference to your response, I request some specifics:

    1) When you say FP2 SDK, do you mean FP2 WINS or FP2 CW? I suppose its obvious but I just want to confirm.
    2) Whats the difference between ActivePerl & Perl? I just downloaded "ActivePerl-5.8.8.819-MSWin32-x86-267479". Can I substitute this for Perl 5.8.7?

    Thx in advance.

  4. #4
    Registered User
    Join Date
    Jul 2005
    Location
    Bengaluru, India
    Posts
    747

    Re: Right version of Perl, CW, & SDK

    Quote Originally Posted by wirefree101
    1) When you say FP2 SDK, do you mean FP2 WINS or FP2 CW? I suppose its obvious but I just want to confirm.
    The choice between WINS and WINCW depends on the IDE which you supposed to choose for the development. From the above posts I guess you are supposed to use CodeWarrior, in that case WINCW would be a better choice for you.
    Quote Originally Posted by wirefree101
    2) Whats the difference between ActivePerl & Perl? I just downloaded "ActivePerl-5.8.8.819-MSWin32-x86-267479". Can I substitute this for Perl 5.8.7?
    ActivePerl is a free Perl open source binary language from ActiveState. I think the version of Perl you've downloaded would sufficient.

  5. #5
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    200

    Re: Right version of Perl, CW, & SDK

    Thanks for the quick response.

    I have obtained the following:

    - CodeWarrior_Personal_Edition_31
    - stable.tar (Perl 5.8.8)
    - s60_2nd_fp2_sdk
    - EMCCSoft_S60_2x_Installer

    As I understand, these must be installed in a particular order. What should be the order of installation?




    P.S.: Since my target device is Nokia6600, the appropriate SDK would be 2nd Ed. FP0 (so to speak, or Symbian 7.0s). Should this indeed be the case, how do the versions of CW & Perl I use get affected?
    Last edited by wirefree101; 2006-10-25 at 09:45.

  6. #6
    Super Contributor
    Join Date
    Oct 2005
    Location
    Hyderabad,India
    Posts
    1,156

    Re: Right version of Perl, CW, & SDK

    Quote Originally Posted by wirefree101
    - CodeWarrior_Personal_Edition_31
    - stable.tar (Perl 5.8.8)
    - s60_2nd_fp2_sdk
    - EMCCSoft_S60_2x_Installer

    As I understand, these must be installed in a particular order. What should be the order of installation?
    you need to install in this order:-
    1) Perl
    2) Java
    3) CW
    4) sdk
    5) EMCCSoft installer..

    Priju

  7. #7
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    200

    Re: Right version of Perl, CW, & SDK

    Hi Priju,

    Could you please ellborate a lil' on Java (point #2) as you didn't mention it earlier.


    Thx,
    wirefree101

  8. #8
    Super Contributor
    Join Date
    Oct 2005
    Location
    Hyderabad,India
    Posts
    1,156

    Re: Right version of Perl, CW, & SDK

    you should install the Java as well. it has been mentioned in the release notes. and also it is used by the tools, and also by the emulator.

    Priju

  9. #9
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    200

    Re: Right version of Perl, CW, & SDK

    What I meant to ask was - version, etc.

    Would J2SE v 1.4.2_12 JRE be sufficient for my purposes?


    Thx,
    wirefree101

  10. #10
    Registered User
    Join Date
    Jul 2005
    Location
    Bengaluru, India
    Posts
    747

    Re: Right version of Perl, CW, & SDK

    That version of Java Runtime will do.

    ========================================================================
    RELEASE NOTE FOR SERIES 60 2ND EDITION SDK FOR SYMBIAN OS, 18.11.2004
    SUPPORTING FEATURE PACK 2
    SUPPORTING METROWERKS CODEWARRIOR
    ========================================================================
    ...
    ...
    Additional Requirements:
    - Installation/uninstallation of the SDK requires local admin rights.
    - Active Perl 5.6.1 build 531 for SDK build tools. Newer or older
    versions of Perl may not be fully compatible with Symbian toolchain.
    Perl must be installed before using the SDK to build applications.
    - Use of the emulator menubar, Application Wizard and Symbian UI tools:
    Sisar, AIFBuilder and CS Help Compiler require a Java runtime
    to be installed.
    Java Runtime version 1.4.1_02 or later is required.
    - EnvironmentSwitch tool requires Microsoft XML Core Services (MSXML)
    to work. Preferred version is 4.0 or later.
    - When developing Bluetooth applications, a fast (recommended >2GHz, 512
    MB of memory) desktop machine is required. The supported Bluetooth card
    protocols are BCSP and H4.
    ...
    ...

  11. #11
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    200

    Re: Right version of Perl, CW, & SDK

    Hi there,

    While installing ActivePerl-5.8.8.819-MSWin32-x86-267479, the 3rd step of the Install batch file reads:

    "If you have a development environment (e.g. Visual Studio) that you wish to use with Perl, you should ensure that your environment (e.g. %LIB% %INCLUDE% is set before installing, for example, by running vcvars32.bat first."

    However, the folder does not contain the aforementioned file vcvars32.bat.

    Would appreciate advise.

    Thx in advance,
    wirefree101

  12. #12
    Registered User
    Join Date
    Jul 2005
    Location
    Bengaluru, India
    Posts
    747

    Re: Right version of Perl, CW, & SDK

    I hope you can ignore that step as you are supposed to use CodeWarrior.

  13. #13
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    200

    Re: Right version of Perl, CW, & SDK

    Well, I went ahead with your suggestion.

    When I try to import HelloWorld.mmp, I get:

    SymbianMmpImporter
    Failed to run makmake.
    System error: The system cannot find the file specified.

    HELP

  14. #14
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    200

    Re: Right version of Perl, CW, & SDK

    I downloaded the MSI package for A/Perl, and that solved the A/Perl issue.

    However, now when I try to import a .mmp file, I get the following error:

    "The makmake tool failed to run. Project creation aborted."

    I have searched for that error on the forum. Most threads either die out without a solution or the initiator didn't post the solution (if at all she got it).

    Would appreciate some advise here.

    cheers,
    wirefree101

    P.S.: Could the error be related to the fact that the releaseNotes state that the version of SDK works with CW2.8? If yes, where can I download it?
    Last edited by wirefree101; 2006-10-25 at 18:46.

  15. #15
    Super Contributor
    Join Date
    Oct 2005
    Location
    Hyderabad,India
    Posts
    1,156

    Re: Right version of Perl, CW, & SDK

    Quote Originally Posted by wirefree101
    I downloaded the MSI package for A/Perl, and that solved the A/Perl issue.


    "The makmake tool failed to run. Project creation aborted."

    I have searched for that error on the forum. Most threads either die out without a solution or the initiator didn't post the solution (if at all she got it).

    Would appreciate some advise here.

    cheers,
    wirefree101

    P.S.: Could the error be related to the fact that the releaseNotes state that the version of SDK works with CW2.8? If yes, where can I download it?
    Hi,
    this error message "The makmake tool failed to run. Project creation aborted." deals with installation of perl.i just came across this thread
    http://www.allaboutsymbian.com/forum...ad.php?t=40084 and the poster seems to have got the result.by the way, which version of perl have you installed?

    i would rather say, the error is related to PERL and not related to CW2.8 as you have installed CW 3.1

    Priju

Similar Threads

  1. Replies: 1
    Last Post: 2006-07-17, 11:49
  2. My BuilderX (with S60 SDK 2.1.NET MS version) cannot build ARMI UREL
    By danielvidonyi@hotmail.com in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2006-05-04, 21:30
  3. Replies: 0
    Last Post: 2005-12-30, 13:18
  4. Help! Need Series 60 SDK Version 1.0
    By neomedia in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2003-10-30, 20:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×