×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    200

    ActivePerl Installation Query

    Hi there,

    I am looking at installing the following software in this order:

    1) ActivePerl-5.8.8.819-MSWin32-x86-267479
    2) J2SE v 1.4.2_12 JRE
    3) CodeWarrior_Personal_Edition_31
    4) s60_2nd_fp2_sdk


    While installing ActivePerl-5.8.8.819-MSWin32-x86-267479, the 3rd step of the Install batch file reads:

    "If you have a development environment (e.g. Visual Studio) that you wish to use with Perl, you should ensure that your environment (e.g. %LIB% %INCLUDE% is set before installing, for example, by running vcvars32.bat first."

    Would appreciate advise here with ensuring the environment is set correctly.

    Thx in advance,
    wirefree101

  2. #2
    Super Contributor
    Join Date
    Oct 2005
    Location
    Hyderabad,India
    Posts
    1,156

    Re: ActivePerl Installation Query

    Hi Mate,

    This is what VCVARS32.BAT is used for in vc++ env:

    When you install Visual C++, setup creates a batch file, VCVARS32.BAT, containing commands to modify the PATH, LIB, and INCLUDE environment variables. If these variables haven't been set properly, run VCVARS32.BAT before you compile at the command prompt. VCVARS32.BAT is located in the \bin subdirectory..

    and also to install it

    1.At the command prompt, change to the \bin subdirectory of your Visual C++ installation.2.Run VCVARS32.BAT by typing VCVARS32.

    But what i feel is that, you can ignore that message as you are installing CW as your ide and not VC++..

    Best Regrdz
    Priju

  3. #3
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    200

    Re: ActivePerl Installation Query

    Hi again Priju,

    As suggested, I went ahead and installed Perl, then JRE, next CW, and finally SDK.

    When I import the HelloWorld.mmp, I get the following error:

    SymbianMmpImporter
    Failed to run makmake.
    System error: The system cannot find the file specified.

    On googling, I found:

    http://discussion.forum.nokia.com/fo...p/t-52751.html

    It refers me back to improper Perl installation!

    HELP.

  4. #4
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    200

    Re: ActivePerl Installation Query

    ADDITION:

    I came across perlivp which is a tool that tests for a correct installation of ActivePerl:

    http://aspn.activestate.com/ASPN/doc...n/perlivp.html

    Where & how can I use this to test my ActivePerl installation? I am a beginner as far as this is concerned. I did, however, execute the command in C:\Perl but received the following error:

    'perlivp' is not recognized as an internal or external command, operable program or batch file.

    Would appreciate a prompt response.

    cheers,
    wirefree101

  5. #5
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    200

    Re: ActivePerl Installation Query

    I downloaded the MSI package for A/Perl, and that solved the installation issue.

    However, now when I try to import a .mmp file, I get the following error:

    "The makmake tool failed to run. Project creation aborted."

    I have searched for that error on the forum. Most threads either die out without a solution or the initiator didn't post the solution (if at all she got it).

    Would appreciate some advise here.

    cheers,
    wirefree101

    P.S.: Could the error be related to the fact that the releaseNotes state that the version of SDK works with CW2.8? If yes, where can I download it?
    Last edited by wirefree101; 2006-10-25 at 18:47.

Similar Threads

  1. ActivePerl installation problem
    By Dark London in forum Symbian Tools & SDKs
    Replies: 3
    Last Post: 2009-01-16, 05:21
  2. ProGuard Installation
    By davidmanpearl in forum Mobile Java Tools & SDKs
    Replies: 5
    Last Post: 2007-10-03, 16:28
  3. Multiline Query in 3rd edition sdk
    By parag_purkar in forum Symbian User Interface
    Replies: 1
    Last Post: 2006-09-26, 03:54
  4. Query the Series 60 version at installation time
    By AlfredoRU in forum Symbian
    Replies: 2
    Last Post: 2006-02-08, 13:32
  5. Installation Problem on the Nokia 6600
    By ManishPatil in forum Symbian
    Replies: 1
    Last Post: 2005-02-02, 09:51

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×