×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    May 2006
    Posts
    4

    Still can't import an MMP!

    Its still not possible to import an MMP into Carbide.C++ Pro / Dev !!
    I thought this could have been fixed by now as there were problems since the Express version was first released.

    The error I get is:

    Unable to import file: org.eclipse.core.internal.resources.ResourceException:
    C:\somefolder is not a valid folder for linked resources

    I think the problem is caused by
    #include "..\..\another.mmp" in the initial MMP file. This is necessary when building very large projects for multiple versions of Symbian OS S60 and UIQ whilst maintaining a similar build process for all. It worked fine in CodeWarrior.

    In addition to be compatible with Codewarrior the SOURCEPATH statement needs to resolve relative paths from the directory the MMP thats being read is in. This may be different to the directory the initial MMP is in.

  2. #2
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,142

    Re: Still can't import an MMP!

    Dunno would it help, but have you tried on putting mmp files into bld.inf file and then inporting the bld.inf instead.

    yucca

  3. #3
    Registered User
    Join Date
    May 2006
    Posts
    4

    Re: Still can't import an MMP!

    No! Carbide can't import from bld.inf either. I've tried Express / Dev / Pro none of these can import a complex MMP that includes other MMP's properly. So I'm reverting to Codewarrior 3.1 hopefully this extremely simple functionality can be fixed soon.

  4. #4
    Registered User
    Join Date
    Mar 2006
    Posts
    11

    Re: Still can't import an MMP!

    I got the same error but I've found a work around temporarily.

    You need to modify your bld.inf file so that the importer can handle it. I'm not sure if your case is similar to mine here is my config and what I did to get around this issue:

    My source code tree:
    C:\Source\Symbian\me2u\app\U2U\Me2U <--- Carbide workspace directory
    C:\Source\Symbian\me2u\app\U2U\cmn\StreamTransmit\bld\bld.inf
    C:\Source\Symbian\me2u\app\U2U\cmn\StreamTransmit\bld\StreamTransmit.mmp
    C:\Source\Symbian\me2u\app\U2U\cmn\StreamTransmit\src\<some files>
    C:\Source\Symbian\me2u\app\U2U\cmn\StreamTransmit\inc\<some files>

    If I try to import this into Carbide I get the exact same error you do. I finally figured out that if you make a modification to the bld.inf and comment out all the USERINCLUDE lines then Carbide will import the project. The include directories are off of course, but it builds everything else correctly.

    My guess is that the import tool has a problem when it tries to parse the bld.inf include directives. It seems as though the tool is trying to do too much and it thinks that there is a circular reference. To illustrate this point, open a new workspace somewhere like c:\TestDirectory. Perform the import and it should work. If you click on the + signs to open up the project you will notice that the importer is linking practically everything under the include directory tree structure. This would cause the tool to have a circular reference.

    After importing, to use relative paths in the project the base directory is located at the directory which represents your platform/build under the project directory. My example above would have the base directory at:

    C:\Source\Symbian\me2u\app\U2U\Streamtransmit\S60 3.0 Emulator Debug [S60_3rd_MR]

    To get to my normal include files I would put: ..\..\cmn\Streamtransmit\inc

    I hope this helps. PM me if you have questions. I don't scour the board too often.

  5. #5
    Super Contributor
    Join Date
    Jun 2006
    Location
    India
    Posts
    3,037

    Re: Still can't import an MMP!

    may be your mmp file having some error? or if you are working on 3rd sdk then you have to download the latest version of perl.

Similar Threads

  1. Import MMP and BLD.INF fails in Carbide.c++
    By csovi in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 15
    Last Post: 2006-10-19, 08:09
  2. MMP file import problem
    By sanju in forum Symbian C++
    Replies: 1
    Last Post: 2006-07-27, 12:08
  3. import MMP problems in Carbide C++
    By parf in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2006-05-26, 02:33
  4. SocketConnection Work on 6600&Emulators BUT NOT IN 6680
    By eerant in forum Mobile Java Networking & Messaging & Security
    Replies: 4
    Last Post: 2006-03-11, 00:35
  5. Import MMP with different option to UREL ou UDEB
    By Altexia in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 0
    Last Post: 2005-11-30, 17:54

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •