×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Regular Contributor
    Join Date
    Apr 2006
    Posts
    66

    unable to load dlls in 3rd edition

    hi,
    I have an exe file that loads a dll. When i try to run the application on the phone(n91) it gives an error unable to execute for security reasons. when i remove the dll and run the application it runs fine.
    The problem is its not loading the dll.
    the capability i have specified is NetworkServices LocalServices ReadUserData WriteUserData UserEnvironment
    .I have specified it in both the mmp files.
    My application uses gprs and has been signed using a developer certificate.

    wat should i do to make it work

  2. #2
    Super Contributor
    Join Date
    May 2005
    Location
    Hyderabad,India
    Posts
    704

    Re: unable to load dlls in 3rd edition

    Hi,

    Have u copied ur DLL files to \sys\bin folder.

    regards,
    eswar

  3. #3
    Registered User
    Join Date
    Jun 2006
    Posts
    10

    Re: unable to load dlls in 3rd edition

    see dll example from your sdk. in uiq there is such a dll example.
    br
    marius

  4. #4
    Regular Contributor
    Join Date
    Apr 2006
    Posts
    66

    Re: unable to load dlls in 3rd edition

    yup i have done it. one id an ordinary dll and the other is an ecom plugin
    i guess they need extra capabilities
    In the sdk eg the capability for ecom plugin is CAPABILITY All -TCB.
    I cannot give it because i have a basic developer certificate

    Could someone tell me for an ecom plugin which capability i have to specify

  5. #5
    Nokia Developer Champion
    Join Date
    Jul 2004
    Posts
    2,015

    Re: unable to load dlls in 3rd edition

    >>the capability i have specified is NetworkServices LocalServices ReadUserData WriteUserData UserEnvironment
    .I have specified it in both the mmp files.




    Run it on the emulator and then look in epocwind.out and see if there is a diagnostic message - if the dll can't be loaded because it doesn't have the correct capabilites then this will be logged. However, if by the quote above you mean the exe has these capabilites and the dll it is loading also has these capabilites then there should be no problem.

Similar Threads

  1. Python for S60 3rd Edition
    By jplauril in forum Symbian
    Replies: 82
    Last Post: 2008-06-04, 04:47
  2. Replies: 4
    Last Post: 2008-04-16, 11:29
  3. Replies: 5
    Last Post: 2006-08-16, 08:18
  4. S60 2nd OR 3rd edition for new software development
    By patil_ruturaj in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2006-06-30, 09:30
  5. S60 2nd OR 3rd edition for new software development
    By patil_ruturaj in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2006-06-30, 08:57

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×