×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    10

    Problems compiling GCCE Release with Carbide.c++ and Windows Vista

    Hello,

    I'm previewing Vista RC1 and Carbide.c++ and everything has been fine so far. Building for emulator works nicely without any problems.

    But now as I try to compile for GCCE problems start. GCCE Toolchain has been installed properly and arm-none-symbianelf-g++.exe is in the PATH.

    Build output gives the following error for each source file. No .o files are generated. I use S60 3.0 Phone (GCCE) Release [S60_3rd_MR] target.

    'Building file: ../src/helloworldbasicappui.cpp'
    'Invoking: GCCE Compiler'
    arm-none-symbianelf-g++.exe -MD -c -pipe -mapcs -nostdinc -x c++ -march=armv5t -fexceptions -mfloat-abi=soft -DNDEBUG -D_UNICODE -D__GCCE__ -D__SYMBIAN32__ -D__EPOC32__ -D__MARM__ -D__EABI__ -D__MARM_ARMV5__ -D__EXE__ -D__SUPPORT_CPP_EXCEPTIONS__ -D__SERIES60_30__ -D__SERIES60_3X__ -D__PRODUCT_INCLUDE__=\"W:\Symbian\9.1\S60_3rd_MR\epoc32\include\variant\Symbian_OS_v9.1.hrh\" -include "W:\Symbian\9.1\S60_3rd_MR\EPOC32\INCLUDE\GCCE\GCCE.h" -Wall -Wno-ctor-dtor-privacy -Wno-unknown-pragmas -I "W:\Nokia\Carbide.c++ v1.1\include" -I . -I "W:\Projects\workspace\helloworldbasic\data" -I "W:\Projects\workspace\helloworldbasic\inc" -I "W:\Symbian\9.1\S60_3rd_MR\epoc32\include" -I "W:\Symbian\9.1\S60_3rd_MR\epoc32\include\variant" -o src/helloworldbasicappui.o ../src/helloworldbasicappui.cpp
    (null) tried to spawn cc1plus but failed: The system cannot find the file specified.

    Can somebody help?

  2. #2
    Registered User
    Join Date
    Jan 2007
    Posts
    1

    Re: Problems compiling GCCE Release with Carbide.c++ and Windows Vista

    Has anyone found a solution for this problem?

    Thanks.

  3. #3
    Registered User
    Join Date
    Nov 2006
    Posts
    5

    Re: Problems compiling GCCE Release with Carbide.c++ and Windows Vista

    Same problem here, no solution yet. Codewarrior cannot see the toolchain binaries even if they're in the path. Maybe environment problems with vista?

  4. #4
    Regular Contributor
    Join Date
    Feb 2006
    Location
    Slovakia
    Posts
    76

    Re: Problems compiling GCCE Release with Carbide.c++ and Windows Vista

    still no solution?

  5. #5
    Registered User
    Join Date
    Mar 2007
    Posts
    1

    Re: Problems compiling GCCE Release with Carbide.c++ and Windows Vista

    Hi,

    I've just got around this by adding c:\program files\csl arm toolchain\libexec\gcc\arm-none-symbianelf\3.4.3 to my path as well as ...\bin and ...\arm-none-symbianelf\bin
    Also make sure these are in the path before c:\program files\common files\symbian\tools (if its there).

    HTH,
    Cheers,
    Gary

  6. #6
    Regular Contributor
    Join Date
    Feb 2006
    Location
    Slovakia
    Posts
    76

    Re: Problems compiling GCCE Release with Carbide.c++ and Windows Vista

    now i get another error...

    'Invoking: GCCE Linker'
    arm-none-symbianelf-ld.exe --check-sections --no-undefined --no-allow-shlib-undefined -nostdlib -shared --entry _E32Startup -Tdata 0x400000 -Ttext 0x8000 --target1-abs --discard-locals --default-symver -u_E32Startup -L"C:\Program Files\Nokia\Carbide.c++ v1.1" -L"C:\Program Files\Nokia\Carbide.c++ v1.1" -soname "Hello{000a0000}.exe" "C:\Symbian\9.1\S60_3rd_MR\EPOC32\RELEASE\ARMV5\UREL\eexe.lib" C:\Symbian\9.1\S60_3rd_MR\EPOC32\RELEASE\ARMV5\LIB\dfpaeabi.dso C:\Symbian\9.1\S60_3rd_MR\EPOC32\RELEASE\ARMV5\LIB\drtaeabi.dso C:\Symbian\9.1\S60_3rd_MR\EPOC32\RELEASE\ARMV5\LIB\dfprvct2_2.dso C:\Symbian\9.1\S60_3rd_MR\EPOC32\RELEASE\ARMV5\LIB\scppnwdl.dso C:\Symbian\9.1\S60_3rd_MR\EPOC32\RELEASE\ARMV5\LIB\drtrvct2_2.dso C:\Symbian\9.1\S60_3rd_MR\EPOC32\RELEASE\ARMV5\UREL\usrt2_2.lib -o "C:\Symbian\9.1\S60_3rd_MR\epoc32\release\GCCE\UREL\Hello.sym" -Map C:\Symbian\9.1\S60_3rd_MR\epoc32\release\GCCE\UREL\\Hello.exe.map ./src/Hello.o ./src/HelloAppUi.o ./src/HelloAppView.o ./src/HelloApplication.o ./src/HelloDocument.o C:\Symbian\9.1\S60_3rd_MR\epoc32\release\ARMV5\LIB\euser.dso C:\Symbian\9.1\S60_3rd_MR\epoc32\release\ARMV5\LIB\apparc.dso C:\Symbian\9.1\S60_3rd_MR\epoc32\release\ARMV5\LIB\cone.dso C:\Symbian\9.1\S60_3rd_MR\epoc32\release\ARMV5\LIB\eikcore.dso C:\Symbian\9.1\S60_3rd_MR\epoc32\release\ARMV5\LIB\avkon.dso C:\Symbian\9.1\S60_3rd_MR\epoc32\release\ARMV5\LIB\commonengine.dso C:\Symbian\9.1\S60_3rd_MR\epoc32\release\ARMV5\LIB\efsrv.dso C:\Symbian\9.1\S60_3rd_MR\epoc32\release\ARMV5\LIB\estor.dso -lsupc++ -lgcc
    arm-none-symbianelf-ld.exe: cannot find -lsupc++
    make: *** [Hello.sym] Error 1

  7. #7
    Super Contributor
    Join Date
    Dec 2005
    Location
    England,UK
    Posts
    1,600

    Re: Problems compiling GCCE Release with Carbide.c++ and Windows Vista

    Hi frizi,

    There is now a Wiki page on moving to Vista and a discussion thread.
    See wiki and thread http://discussion.forum.nokia.com/fo...547#post327547

    Good Luck
    Jim

  8. #8
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    50

    Re: Problems compiling GCCE Release with Carbide.c++ and Windows Vista

    Hi Jim,
    I have tried the steps mentioned in the link given by you. But i still got stuck with the linker error.
    I am using Carbide C++ 1.1 on windows vista.
    I have updated SYMBIAN_UREL_LINK_FLAGS in GCCE.MK as mentioned.
    I am able to build for gcce urel on command prompt, but getting the following error with carbide.

    Any solution would be great..

    - Naveen


    'Invoking: GCCE Linker'
    arm-none-symbianelf-ld.exe --check-sections --no-undefined --no-allow-shlib-undefined -nostdlib -shared --entry _E32Startup -Tdata 0x400000 -Ttext 0x8000 --target1-abs --discard-locals --default-symver -u_E32Startup -L"C:\Program Files\Nokia\Carbide.c++ v1.1" -L"C:\Program Files\Nokia\Carbide.c++ v1.1" -soname "HelloWorldBasic{000a0000}.exe" "C:\Symbian\9.2\S60_3rd_FP1\EPOC32\RELEASE\ARMV5\UREL\eexe.lib" C:\Symbian\9.2\S60_3rd_FP1\EPOC32\RELEASE\ARMV5\LIB\dfpaeabi.dso C:\Symbian\9.2\S60_3rd_FP1\EPOC32\RELEASE\ARMV5\LIB\drtaeabi.dso C:\Symbian\9.2\S60_3rd_FP1\EPOC32\RELEASE\ARMV5\LIB\dfprvct2_2.dso C:\Symbian\9.2\S60_3rd_FP1\EPOC32\RELEASE\ARMV5\LIB\scppnwdl.dso C:\Symbian\9.2\S60_3rd_FP1\EPOC32\RELEASE\ARMV5\LIB\drtrvct2_2.dso C:\Symbian\9.2\S60_3rd_FP1\EPOC32\RELEASE\ARMV5\UREL\usrt2_2.lib -o "C:\Symbian\9.2\S60_3rd_FP1\epoc32\release\GCCE\UREL\HelloWorldBasic.sym" -Map C:\Symbian\9.2\S60_3rd_FP1\epoc32\release\GCCE\UREL\\HelloWorldBasic.exe.map ./src/helloworldbasic.o ./src/helloworldbasicapplication.o ./src/helloworldbasicappui.o ./src/helloworldbasicappview.o ./src/helloworldbasicdocument.o ./src/helloworldbasicquerydialog.o "C:\Symbian\9.2\S60_3rd_FP1\epoc32\release\ARMV5\LIB\eikdlg.dso" "C:\Symbian\9.2\S60_3rd_FP1\epoc32\release\ARMV5\LIB\eikcoctl.dso" "C:\Symbian\9.2\S60_3rd_FP1\epoc32\release\ARMV5\LIB\estor.dso" "C:\Symbian\9.2\S60_3rd_FP1\epoc32\release\ARMV5\LIB\efsrv.dso" "C:\Symbian\9.2\S60_3rd_FP1\epoc32\release\ARMV5\LIB\commonengine.dso" "C:\Symbian\9.2\S60_3rd_FP1\epoc32\release\ARMV5\LIB\avkon.dso" "C:\Symbian\9.2\S60_3rd_FP1\epoc32\release\ARMV5\LIB\eikcore.dso" "C:\Symbian\9.2\S60_3rd_FP1\epoc32\release\ARMV5\LIB\cone.dso" "C:\Symbian\9.2\S60_3rd_FP1\epoc32\release\ARMV5\LIB\apparc.dso" "C:\Symbian\9.2\S60_3rd_FP1\epoc32\release\ARMV5\LIB\euser.dso" -lsupc++ -lgcc
    arm-none-symbianelf-ld.exe: cannot find -lsupc++
    make: *** [HelloWorldBasic.sym] Error 1
    make: Target `all' not remade because of errors.
    Build complete for project HelloWorldBasic

Similar Threads

  1. Problems with the detection of phones on Windows 2000
    By mgarstecki in forum PC Suite API and PC Connectivity SDK
    Replies: 0
    Last Post: 2006-10-19, 13:40
  2. Nokia 6310i IrDA Connection Problems under Windows 2000
    By Cj in forum PC Suite API and PC Connectivity SDK
    Replies: 3
    Last Post: 2003-05-20, 08:43
  3. Major problems with Windows 2000, Infrared, and 6210
    By searled in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2003-03-18, 10:19
  4. D211 & Windows 98 startup problems
    By antenet in forum Multimodecards
    Replies: 2
    Last Post: 2002-07-04, 12:39
  5. 6210, Windows 2000, DAU-9P - problems connecting PC Suite 4.05
    By ajrobinson in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2002-05-23, 08:47

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×