×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Oct 2006
    Posts
    30

    Carbide C++ madness #1

    Hi,
    Do the following:
    1) New Project Symbian S60 3rd Ed., add no additional code to the sources
    2) Build emulator debug one time
    3) Change project settings to GCCE Release
    4) Build the GCCE release, all ok
    5) Make your settings for symbian certifications in projects CreateSiS section
    6) Build the release
    7) Restore defaults in project settings to clear CreateSiS settings
    6) Build the release again

    ************** 72 errors was reported suddenly *************
    fragment of console output:
    ../src/oooDocument.cpp:12:22: oooAppUi.h: No such file or directory
    ../src/oooDocument.cpp:13:25: oooDocument.h: No such file or directory
    ../src/oooDocument.cpp:22: error: expected constructor, destructor, or type conversion before '*' token
    ../src/oooDocument.cpp:22: error: expected `,' or `;' before '*' token
    ../src/oooDocument.cpp:35: error: expected constructor, destructor, or type conversion before '*' token
    ../src/oooDocument.cpp:35: error: expected `,' or `;' before '*' token
    ../src/oooDocument.cpp:51: error: `CoooDocument' has not been declared
    ../src/oooDocument.cpp:61: error: `CoooDocument' has not been declared
    ../src/oooDocument.cpp:61: error: expected constructor, destructor, or type conversion before '(' token
    ../src/oooDocument.cpp:61: error: expected `,' or `;' before '(' token
    ../src/oooDocument.cpp:72: error: expected constructor, destructor, or type conversion before '::' token
    ../src/oooDocument.cpp:72: error: expected `,' or `;' before '::' token
    ../src/oooDocument.cpp:82: error: expected constructor, destructor, or type conversion before '*' token
    ../src/oooDocument.cpp:82: error: expected `,' or `;' before '*' token
    console output was too long for this post

    Hi Hi Hi - Carbide as hard as an egg ...

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: Carbide C++ madness #1

    it could be that re-setting to default values clears user-paths, thus your own headers are not found, since you just cleared the path for them

    yucca

Similar Threads

  1. Getting started using Carbide c++ 1.1 -> how to import the sample code
    By terchris in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 3
    Last Post: 2007-11-20, 09:12
  2. huge carbide initialization problem
    By imzadi_il in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 8
    Last Post: 2006-11-26, 07:43
  3. Problems we are facing with Carbide C++. Please help with the solutions
    By bharath_hegde in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2006-11-15, 18:22
  4. Import\Export Project Problem in Carbide
    By mohsin.sohail in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 4
    Last Post: 2006-07-17, 20:20
  5. Issues with Carbide vs 2.0 installer!
    By kt10208 in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2006-01-16, 09:27

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×