×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Jun 2006
    Location
    Lahore, Pakistan
    Posts
    162

    Installation problem on Memory Card in OS 9.1

    I have encountered a problem in OS 9.1 while installing application on memory card in. let me define the problem. The application is working fine if I install the app on phone memory but when I intall the app on memory card it does not work fine. The possible cause according to my point of view is the creation of files, as I am making some files and also placing some files through pkg. e.g

    \private\AppSID\abc.ext

    So what should I do to remove this problem
    Sajid Iqbal
    ASD, Accredited S60 Developer
    [EMAIL]saji.iq@gmail.com[/EMAIL]

  2. #2
    Regular Contributor
    Join Date
    May 2004
    Posts
    462

    Re: Installation problem on Memory Card in OS 9.1

    Since you know where is the possible reason, when you try to open the abc.ext file in your application, don't assume it is default in C:, get the correct driver first, and append the path, file name for the file full path.

  3. #3
    Registered User
    Join Date
    Jun 2006
    Location
    Lahore, Pakistan
    Posts
    162

    Re: Installation problem on Memory Card in OS 9.1

    thanks for ur suggestion but how can I can i determine the installation drive at runtime?
    Sajid Iqbal
    ASD, Accredited S60 Developer
    [EMAIL]saji.iq@gmail.com[/EMAIL]

  4. #4
    Super Contributor
    Join Date
    Oct 2005
    Location
    Hyderabad,India
    Posts
    1,156

    Re: Installation problem on Memory Card in OS 9.1

    Quote Originally Posted by saji_iq
    thanks for ur suggestion but how can I can i determine the installation drive at runtime?
    Hi,

    Use AppFullName() or CompleteWithAppPath()

    Check this http://www.forum.nokia.com/Technical...ation_path.htm
    it works in 2nd ed..hope it does the job with 3rd too as i have not personally worked in this..

    Br,
    Priju

  5. #5
    Regular Contributor
    Join Date
    May 2004
    Posts
    462

    Re: Installation problem on Memory Card in OS 9.1

    You can use RApaLsSession::GetAppInfo() to get related information, which also includes the application FULL path.

    Skygyl

  6. #6
    Registered User
    Join Date
    Jun 2006
    Location
    Lahore, Pakistan
    Posts
    162

    Re: Installation problem on Memory Card in OS 9.1

    Thanks a lot to all , The problem is solved.
    Sajid Iqbal
    ASD, Accredited S60 Developer
    [EMAIL]saji.iq@gmail.com[/EMAIL]

Similar Threads

  1. How to format a corrupted memory card
    By tijah999 in forum General Development Questions
    Replies: 5
    Last Post: 2012-06-19, 14:01
  2. Can't run native Symbian apps on memory card after phone restart
    By stewart.hector in forum General Development Questions
    Replies: 5
    Last Post: 2007-05-28, 11:19
  3. Problem MMC+USB Connection
    By Fede81 in forum General Development Questions
    Replies: 3
    Last Post: 2006-07-19, 15:21
  4. Exploring memory card on 6230
    By wayneab in forum PC Suite API and PC Connectivity SDK
    Replies: 2
    Last Post: 2005-05-18, 17:01
  5. What type of Memory Card Shud I buy for N6600?
    By creativesoumik in forum Symbian
    Replies: 2
    Last Post: 2005-03-09, 09:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •