×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Sep 2006
    Posts
    32

    Angry Emulator Freezes -3rd -gone mad

    Hello All,

    It's really frustrating.
    I have already posted the same question in other places but no response at all.

    Let me put up here also as it's related to carbide.
    I am using Carbide.vs(Visual Studio 2003) with 3rd edition SDK-MR ( symbian c++).

    Everything works fine. I can build my application from command line very fine.

    Now the time has come to debug the application.
    I set breakpoints in my code and start debugging.
    But when i start debugging, emulator freezes. I just can see a white screen of emulator for minutes of time. But no successs.

    Strange thing is that i can run EPOC command from command line and it works very fine.

    If anybody has solved such problem then please help me!!!!!!!!!!!!!!
    I am really stuck. I want to find errors in my code........
    Thanks.................
    Any clue would be appreciated.
    Thanks.........

  2. #2
    Registered User
    Join Date
    Jul 2005
    Location
    Bengaluru, India
    Posts
    747

    Re: Emulator Freezes -3rd -gone mad

    If you are using the normal 3rd Ed SDK, it would be recomended to use the 3rd Ed. MR SDK as the maintenance release (MR) fixing several issues with the emulator and toolchain.

    Still in the release note of MR says:

    - Emulator freezes if files are deployed into
    \private\10003a3f\import\apps. Therefore, it is recommended to use
    following template to define _reg.rss resources in the .mmp file:
    START
    RESOURCE HelloWorldBasic_reg.rss
    #ifdef WINSCW
    TARGETPATH
    \private\10003a3f\apps
    #else
    TARGETPATH
    \private\10003a3f\import\apps
    #endif
    END //RESOURCE
    For more information check the release note of 3rd Ed. MR SDK.

  3. #3
    Registered User
    Join Date
    Sep 2006
    Posts
    32

    Re: Emulator Freezes -3rd -gone mad

    Hello Vin2ktalks,

    Quote Originally Posted by vin2ktalks
    If you are using the normal 3rd Ed SDK, it would be recomended to use the 3rd Ed. MR SDK as the maintenance release (MR) fixing several issues with the emulator and toolchain.
    It is clearly seen from my post that i m using 3rd Edition MR.
    Quote Originally Posted by RunL
    I am using Carbide.vs(Visual Studio 2003) with 3rd edition SDK-MR ( symbian c++).
    From default wizard, i have following entries in my .mmp file
    START RESOURCE HelloWorld_reg.rss
    TARGETPATH \private\10003a3f\apps
    END
    Anyways magically it works fine now without any changes.
    So would you suggest me the reason behind this???

    Thanks......

  4. #4
    Registered User
    Join Date
    Jul 2005
    Location
    Bengaluru, India
    Posts
    747

    Re: Emulator Freezes -3rd -gone mad

    I'm sorry for my negligence in reading your post.

    By the way the reason may be the first time your PC's RAM was fully occupied with some other applications.

Similar Threads

  1. Python for S60 3rd Edition
    By jplauril in forum Symbian
    Replies: 82
    Last Post: 2008-06-04, 04:47
  2. Replies: 7
    Last Post: 2007-11-30, 14:49
  3. [Pys60, 3rd Ed.] build problems
    By MHOOO in forum Symbian
    Replies: 3
    Last Post: 2007-04-09, 19:00
  4. Carbide c++ and S60 3rd Edition Feature Pack 1 Working
    By jimgilmour1 in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2006-10-18, 20:39

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×