×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Nov 2006
    Posts
    13

    problems trying to compile

    Hello, Im having serious problems trying to compile an application using the series60 v.21 SDK with VC6 When trying to build the .exe i keep getting the error "Can't find epocrc_ide6.pl on PATH.
    NMAKE : fatal error U1077: 'perl' : return code '0x2'"

    what does that mean? Does someone know, please help me out. Im a begginner. Also, when trying to create project files for vc6 I get some error about a file called "edll_vc6.dll" not found! at c:\symbian\7.0s\Series60_v21\epoc32\tools/abld.pl line 390
    I have perl 5.6.1 installed and on the system environment paths.

    What could be the problem?

  2. #2
    Regular Contributor
    Join Date
    May 2004
    Posts
    462

    Re: problems trying to compile

    Have you tried to install the latest perl?

  3. #3
    Registered User
    Join Date
    Nov 2006
    Posts
    13

    Re: problems trying to compile

    Well, in the documentation of the SDK im using, it said that it needed at least 5.6.1., which is the one I have. Would the latest perl work?

  4. #4
    Registered User
    Join Date
    Nov 2006
    Posts
    13

    Re: problems trying to compile

    Also, I tried launching the Sisar application, but it gave an error saying JRE 1.5 is not supported. I thought I had the latest java runtime, do I need a previous version of JRE for sisar to run? Plz help a noob out :(

    thanks

  5. #5
    Registered User
    Join Date
    Nov 2006
    Posts
    13

    Re: problems trying to compile

    Im trying to give as much info as I can to help correct this, I've lookd into the files in the sdk, and I cant find a file called epocrc_ide6.pl, which is the one vc6 is complaining that it cant find. Where do I get it?

  6. #6
    (Retired) Nokia Developer Admin.
    Join Date
    Jan 2006
    Location
    Michigan
    Posts
    4,664

    Re: problems trying to compile

    Moved to Sybmian C++ Tools forum

  7. #7
    Registered User
    Join Date
    Nov 2006
    Posts
    13

    Re: problems trying to compile

    Can someone offer suggestions?

  8. #8
    Registered User
    Join Date
    Nov 2006
    Posts
    13

    Re: problems trying to compile

    I solved the epocrc_vc6.pl error, but I need to create different vc6 files, and when I try to create them with abld it gives an error about not finding edll_vc6.lib Any suggestions?

  9. #9
    Registered User
    Join Date
    Nov 2006
    Posts
    13

    Re: problems trying to compile

    I solved both of the problems, but the abld is complaing that it cant find severl sdl related files in the sys include paths., and that it hasnt found both a SYSTEMINCLUDE and USERINCLUDE paths. Do I have to create those paths in the user or in the system variables under Advanced in System from Control Panel? As you might have guessed, Im using winxp.

    thanks

Similar Threads

  1. Example 3D Compile Problems with Carbide.c++
    By infosekr in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2006-06-07, 22:17
  2. Several problems with NMIT 4.1 MMS
    By jtalviva in forum General Messaging
    Replies: 0
    Last Post: 2006-03-10, 11:03
  3. Several problems with NMIT 4.1
    By jtalviva in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2006-03-10, 10:59
  4. Theme Studio 3 and n90 / n70 Problems
    By Ezz666 in forum Streaming and Video
    Replies: 0
    Last Post: 2006-02-04, 13:18

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×