×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    May 2004
    Posts
    7

    Problem connecting S60 SDK Content Authoring 2.0 for Symbian Emulator to internet

    Dear Board,

    I need all browser emulators to work I can get to test out a mobile web project. I managed to get the Browser Simulator 4.0 and the SDK40 6230i emulator to work in NMIT 4.1 but I failed to connect the S60 emulator to the internet.

    I read the docs that came with the SDK and searched forum.nokia and this board but found nothing valuable.

    Here's the setup :

    Win2000 SP4 machine with Sygate Personal Firewall Pro and Kaspersky AntiVirus

    Installed the S60 SDK without problems, using the default settings.
    When I try to access a URL the emulator asks me if i want to create a connection, I reply yes.

    Firewall says "npacket.sys tries to connect to 255.255.255.255 using port 67 (BOOTPS Dynamic Host Configuration Protocoll [DHCP] Server). Allow ?" - I reply yes, and sometimes the emulator crashes, sometimes the connection seems to time out, as the progressbar "Connecting via G" is visible some time, then dissapears after a while, emulator showing the Bookmards screen again.

    If I try to connect again after a while, the emulator says "No gateway reply".

    In network configuration the default settings are active, means "Network adapter in promisious mode" and "Obtain IP adress automatically/Obtain DNS server adress automatically".

    In "Adapters" there's one adapter listed "Device {xxxxx-xxx-xx-xxxx},Description NDIS 5.0 Driver, a mac adress is listed, speed is 10Mbps", but no gateway adress is given.

    I'm not sure if the nokia Wap gateway is needed, I tested with and without gateway running, still nothing happening.

    In my firewall I can see EPOC.EXE running, but not sending or receiving any traffic, there's the Ethernet Packet Driver running, it sends some Bytes but receives none.

    I might add that I have to network cards installed, one for LAN and one for DSL internet connection. The DSL connection obtains the IP adress automatically and it changes with every connection to the internet. I'm not sure if DHCP is running on my machine, in "Services" I can see "DHCP Client started".

    I'd appreciate any help and suggestions, thanks in advance !!!

    papasosa

    PS.: I've seen numerous threads here concerning the problem that didn't get answered ( ie searching the forum with key words "SDK internet" etc. ). The documentation pdf (the "user guide" v1.0 Feb 2004) that came with the software was of little help, too...

    "5.1.3 By opening a URL on the Internet
    This method is called browsing. In order to browse Internet content, the Series 60 Content Authoring SDK v2.0 for Symbian OS must be configured to use an Ethernet card. See the chapter Opening Content on the SDK Standalone Application for details." Unfortunately there is _nothing_ in that said chapter about netconfiguration or "opening a URL on the Internet" !!!!

    I find this very frustrating as I lost 2 days of development time trying to get this to work.. and I need the emulator desperately for testing on S60 devices. There's definitely room for improvement concerning documentation, not only for this SDK, but for all software I use by Nokia (NMIT, Gateway, etc.).
    Last edited by papasosa; 2006-11-08 at 14:13. Reason: altered thread title

  2. #2
    Registered User
    Join Date
    May 2004
    Posts
    7

    Re: Problem connecting S60 SDK Content Authoring 2.0 for Symbian to internet

    Hm, well. No replies until now - can't say I'm surprised after observing this forum for quite some time..

    Thought about the problem, analysed a bit more and found out some things...
    I'm no network or OS specialist, but I guess the problem is related to my network setup somehow.

    The SDK network setup doesn't find the network adapter that is used for DSL, only the one that is used for LAN. I remember reading that only adapters that are compatible get found, seems as if my noname network card isn't supported ?!?

    Maybe it's about the setup of said network adapter... There's a LAN connection and a dialup component that work with DSL. As I'm using a RAS PPPoe driver, there'S no TCP/IP installed in the dialup adapter, maybe that's why it's not working...

    I'm still hesistant to deinstall all my network connections to get this working though, because everything else is working fine.... aarrrghh

    Cheers,

    papasosa

  3. #3
    Registered User
    Join Date
    May 2004
    Posts
    7

    Re: Problem connecting S60 SDK Content Authoring 2.0 for Symbian to internet

    Ok, what i found is that the network configuration tool wouldn't find my network card because of the dialup adapter used to use the adsl internet connection.

    The way I connected was through a pppoe driver 'rasppoe' which uses a windows modem dialup connection which itself works with a LAN connection to the adsl modem (recommendend method by my ISP).

    The only way my network-conf tool would find the network card was when I set my modem up to act as a router. Then I could reconfigure the LAN connection to use TCP/IP with a fixed IP that would connect to the modem through the modem/routers IP as the standard gateway.

    Didn't solve my problems though. Tried the approach to start netpacketadmin.exe and selecting the appropriate networkcard and starting the service manually, _then_ running the emulator, still didn't work.

    Tried out a million different settings in network conf, static IP automatic, promiscuous mode etc etc - to no avail. Same with settings in netpacketadmin.exe (filters).

    Read a ton of posts here too concerning connection problems with different SDK's, but most of them were the C++ tools that were mentioned, so probably most of the info doesn't apply to my content authoring SDK ?!?

    My last guess after reading a particular post here which I'm not able to find at the moment would be that the router settings may have to be configured to support the virtual MAC-adress the emulator uses... but until now I don't have a clue how to do it. Hell, I don't even know if my network card supports "promiscuous mode" or not.

    After lost days of trying to make this thing run I'm very frustrated. This really is not very developer friendly software. I mean, here I am hacking my ADSL modem in order to get a mobile browser emulator to work, delving deep into obscure symbian configuration tools and files - just to get the browser to show up a lame WAP page on the internet !!!!

Similar Threads

  1. Audio Input Stream on N80
    By tkaihock in forum Symbian Media (Closed)
    Replies: 9
    Last Post: 2006-06-30, 09:15
  2. Error In The Connecting Symbian (S 60 2.0) SDK Emulator To Internet
    By mubx2000 in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2006-05-06, 14:11
  3. Connecting Emulator to the Internet using SDK 2.0
    By khurshed79 in forum Symbian
    Replies: 2
    Last Post: 2005-10-12, 13:43
  4. Replies: 0
    Last Post: 2005-03-16, 13:42
  5. Http connection problem in 6310i
    By teahola in forum Mobile Java General
    Replies: 1
    Last Post: 2002-10-03, 18:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×