I m running This Code in my WML File. it is not complete but it has link with ASP file...it is working fine as it is WML file.
=======================================================
<anchor>
<go method="get" href="http://mtalib/study/processing.asp">
<postfield name="name" value="$(myName)"/>
<postfield name="gender" value="$(myGender)"/>
<postfield name="tutorial_part" value="$(favorite_tutorial_part)"/>
<postfield name="temp_id" value="$(my_temp_id)"/>
</go>
Submit Data
</anchor>
===================================================


The PROBLEM IS with this Code I guess or may be somthing else
This is my ASP FILE
============================================
<% Response.ContentType = "text/vnd.wap.wml"%>

<?xml version="1.0"?>
<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.3//EN" "http://www.wapforum.org/DTD/wml13.dtd">


<wml>
<card id="card1" title="WML Form">
<p>
Data received at the server:<br/>
Name: <% =Request.QueryString("name") %><br/>
Gender: <% =Request.QueryString("gender") %><br/>
Which part of our WML tutorial do you like?
<% =Request.QueryString("tutorial_part") %><br/>
temp_id: <% =Request.QueryString("temp_id") %>
</p>
</card>
</wml>
===============================================

When ever I press button on my mobile browser screen I got and Error
Error
==================================================
cannot load http://mtalib/study/processing.asp?n..._id=12345(HTTP Error 500 Server Error)
=====================================================

I have set my IIS MIME type and it is Running fine I mean my IIS is running fine....I dont know what is wrong I have tried everything

Please help me out here I will be very thankful to you.

From Faisal