×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Jun 2006
    Posts
    8

    No library file found matching 'libedll.lib{.lib|.a}' or 'edll.lib'

    Hi,
    I am manish.I am using Carbide.c++ professional edition and
    symbian s60 second eddition fp3 version 8.1.
    when i build my code it gives me 2 errors;
    1. No library file found matching 'libedll.lib{.lib|.a}' or 'edll.lib'.
    2. Specified file '.lib' not found.
    Can anyone please help me to solve this problem?
    a lot of thanks in advance.

    here is my build file output :
    **** Full rebuild of configuration S60 2.8 Emulator Debug for project TicTacToe ****
    make -k all
    'Building file: ../src/TicTacToeMenuContainer.cpp'
    'Invoking: WINSCW C/C++ Compiler'
    mwccsym2.exe -sym full -c -wchar_t off -align 4 -enum int -str pool -nostdinc -msgstyle parseable -nowraplines -cwd source -O0 -D_UNICODE -D__SYMBIAN32__ -D__CW32__ -D__WINS__ -D__DLL__ -D__WINSCW__ -D_DEBUG -i "C:\Symbian\Carbide\workspace\TicTacToe\inc" -i "C:\Symbian\Carbide\workspace\TicTacToe\data" -i- -i "C:\Symbian\8.1a\S60_2nd_FP3\epoc32\include" -w cmdline -w pragmas -w empty -w possible -w unusedarg -w unusedvar -w extracomma -w pedantic -w largeargs -w ptrintconv -w tokenpasting -w missingreturn -MD -o src/TicTacToeMenuContainer.o ../src/TicTacToeMenuContainer.cpp
    mwccsym2.exe|Compiler|Warning
    (C:\Symbian\Carbide\workspace\TicTacToe\src\TicTacToeMenuContainer.cpp|83|0|11|2829|11)
    =CCoeControl* CTicTacToeMenuContainer::ComponentControl( TInt aIndex ) const
    >variable / argument 'aIndex' is not used in function
    'Finished building: ../src/TicTacToeMenuContainer.cpp'
    ' '
    'Building file: ../src/TicTacToeMenuView.cpp'
    'Invoking: WINSCW C/C++ Compiler'
    mwccsym2.exe -sym full -c -wchar_t off -align 4 -enum int -str pool -nostdinc -msgstyle parseable -nowraplines -cwd source -O0 -D_UNICODE -D__SYMBIAN32__ -D__CW32__ -D__WINS__ -D__DLL__ -D__WINSCW__ -D_DEBUG -i "C:\Symbian\Carbide\workspace\TicTacToe\inc" -i "C:\Symbian\Carbide\workspace\TicTacToe\data" -i- -i "C:\Symbian\8.1a\S60_2nd_FP3\epoc32\include" -w cmdline -w pragmas -w empty -w possible -w unusedarg -w unusedvar -w extracomma -w pedantic -w largeargs -w ptrintconv -w tokenpasting -w missingreturn -MD -o src/TicTacToeMenuView.o ../src/TicTacToeMenuView.cpp
    mwccsym2.exe|Compiler|Warning
    (C:\Symbian\Carbide\workspace\TicTacToe\src\TicTacToeMenuView.cpp|33|0|4|825|4)
    =void CTicTacToeMenuView::ConstructL(const TRect& aRect)
    >variable / argument 'aRect' is not used in function
    'Finished building: ../src/TicTacToeMenuView.cpp'
    ' '
    'Building file: ../src/TicTacToeNewgameContainer.cpp'
    'Invoking: WINSCW C/C++ Compiler'
    mwccsym2.exe -sym full -c -wchar_t off -align 4 -enum int -str pool -nostdinc -msgstyle parseable -nowraplines -cwd source -O0 -D_UNICODE -D__SYMBIAN32__ -D__CW32__ -D__WINS__ -D__DLL__ -D__WINSCW__ -D_DEBUG -i "C:\Symbian\Carbide\workspace\TicTacToe\inc" -i "C:\Symbian\Carbide\workspace\TicTacToe\data" -i- -i "C:\Symbian\8.1a\S60_2nd_FP3\epoc32\include" -w cmdline -w pragmas -w empty -w possible -w unusedarg -w unusedvar -w extracomma -w pedantic -w largeargs -w ptrintconv -w tokenpasting -w missingreturn -MD -o src/TicTacToeNewgameContainer.o ../src/TicTacToeNewgameContainer.cpp
    'Finished building: ../src/TicTacToeNewgameContainer.cpp'
    ' '
    'Building file: ../src/TicTacToeNewgameView.cpp'
    'Invoking: WINSCW C/C++ Compiler'
    mwccsym2.exe -sym full -c -wchar_t off -align 4 -enum int -str pool -nostdinc -msgstyle parseable -nowraplines -cwd source -O0 -D_UNICODE -D__SYMBIAN32__ -D__CW32__ -D__WINS__ -D__DLL__ -D__WINSCW__ -D_DEBUG -i "C:\Symbian\Carbide\workspace\TicTacToe\inc" -i "C:\Symbian\Carbide\workspace\TicTacToe\data" -i- -i "C:\Symbian\8.1a\S60_2nd_FP3\epoc32\include" -w cmdline -w pragmas -w empty -w possible -w unusedarg -w unusedvar -w extracomma -w pedantic -w largeargs -w ptrintconv -w tokenpasting -w missingreturn -MD -o src/TicTacToeNewgameView.o ../src/TicTacToeNewgameView.cpp
    mwccsym2.exe|Compiler|Warning
    (C:\Symbian\Carbide\workspace\TicTacToe\src\TicTacToeNewgameView.cpp|35|0|21|1029|21)
    =CTicTacToeNewgameView* CTicTacToeNewgameView::NewLC(const TRect& aRect) {
    >variable / argument 'aRect' is not used in function
    'Finished building: ../src/TicTacToeNewgameView.cpp'
    ' '
    'Building file: ../.generated/winscw_uid.cpp'
    'Invoking: WINSCW C/C++ Compiler'
    mwccsym2.exe -sym full -c -wchar_t off -align 4 -enum int -str pool -nostdinc -msgstyle parseable -nowraplines -cwd source -O0 -D_UNICODE -D__SYMBIAN32__ -D__CW32__ -D__WINS__ -D__DLL__ -D__WINSCW__ -D_DEBUG -i "C:\Symbian\Carbide\workspace\TicTacToe\inc" -i "C:\Symbian\Carbide\workspace\TicTacToe\data" -i- -i "C:\Symbian\8.1a\S60_2nd_FP3\epoc32\include" -w cmdline -w pragmas -w empty -w possible -w unusedarg -w unusedvar -w extracomma -w pedantic -w largeargs -w ptrintconv -w tokenpasting -w missingreturn -MD -o .generated/winscw_uid.o ../.generated/winscw_uid.cpp
    'Finished building: ../.generated/winscw_uid.cpp'
    ' '
    'Invoking: Def file Manager'
    perl -S winscwTreatDef.pl -L[-sym full -subsystem windows -msgstyle parseable -nowraplines -shared -stdlib -m=?_E32Dll@@YGHPAXI0@Z -ledll.lib -L"epoc32\release\winscw\udeb" -export dllexport -warnings off -nocompactimportlib -implib \".lib\" -addcommand \"out:.\" -search ./src/TicTacToeAboutusContainer.o ./src/TicTacToeAboutusView.o ./src/TicTacToeApp.o ./src/TicTacToeAppUi.o ./src/TicTacToeDocument.o ./src/TicTacToeInstructionsContainer.o ./src/TicTacToeInstructionsView.o ./src/TicTacToeMenuContainer.o ./src/TicTacToeMenuView.o ./src/TicTacToeNewgameContainer.o ./src/TicTacToeNewgameView.o ./src/TicTacToeSplashContainer.o ./src/TicTacToeSplashView.o ./helperfunctions/bitmapmethods.o ./helperfunctions/eikonenvironment.o ./.generated/winscw_uid.o ] -I[-S -show only,names,unmangled,verbose -o \".infi\" \".lib\"] -M[-Inffile \".infi\" \".defi\"] -C[.defi .def]
    mwldsym2.exe -sym full -subsystem windows -msgstyle parseable -nowraplines -shared -stdlib -m=?_E32Dll@@YGHPAXI0@Z -ledll.lib -Lepoc32\release\winscw\udeb -export dllexport -warnings off -nocompactimportlib -implib ".lib" -addcommand "out:." -search ./src/TicTacToeAboutusContainer.o ./src/TicTacToeAboutusView.o ./src/TicTacToeApp.o ./src/TicTacToeAppUi.o ./src/TicTacToeDocument.o ./src/TicTacToeInstructionsContainer.o ./src/TicTacToeInstructionsView.o ./src/TicTacToeMenuContainer.o ./src/TicTacToeMenuView.o ./src/TicTacToeNewgameContainer.o ./src/TicTacToeNewgameView.o ./src/TicTacToeSplashContainer.o ./src/TicTacToeSplashView.o ./helperfunctions/bitmapmethods.o ./helperfunctions/eikonenvironment.o ./.generated/winscw_uid.o

    Errors caused tool to abort.
    mwldsym2.exe|Usage|Error
    >No library file found matching 'libedll.lib{.lib|.a}' or 'edll.lib'

    mwldsym2.exe -S -show only,names,unmangled,verbose -o ".infi" ".lib"

    Errors caused tool to abort.
    ### mwldsym2.exe Usage Error:
    # Specified file '.lib' not found

    perl -S makedef.pl -Inffile ".infi" ".defi"
    MAKEDEF ERROR: .infi: Inffile not found

    perl -S ecopyfile.pl .defi .def
    .defi does not exist

    'Finished building: .defi'
    ' '
    'Building target: C:/Symbian/8.1a/S60_2nd_FP3/epoc32/release/WINSCW/UDEB/Z/system/apps/TicTacToe/TicTacToe.app'
    'Invoking: WINSCW C/C++ Linker'
    mwldsym2.exe -sym full -subsystem windows -msgstyle parseable -nowraplines -shared -stdlib -noimplib -m=?_E32Dll@@YGHPAXI0@Z -ledll.lib -L"C:\Symbian\8.1a\S60_2nd_FP3\epoc32\release\winscw\udeb" -o "C:/Symbian/8.1a/S60_2nd_FP3/epoc32/release/WINSCW/UDEB/Z/system/apps/TicTacToe/TicTacToe.app" -search ./src/TicTacToeAboutusContainer.o ./src/TicTacToeAboutusView.o ./src/TicTacToeApp.o ./src/TicTacToeAppUi.o ./src/TicTacToeDocument.o ./src/TicTacToeInstructionsContainer.o ./src/TicTacToeInstructionsView.o ./src/TicTacToeMenuContainer.o ./src/TicTacToeMenuView.o ./src/TicTacToeNewgameContainer.o ./src/TicTacToeNewgameView.o ./src/TicTacToeSplashContainer.o ./src/TicTacToeSplashView.o ./helperfunctions/bitmapmethods.o ./helperfunctions/eikonenvironment.o ./.generated/winscw_uid.o -ledll.lib -leuser.lib -lapparc.lib -lcone.lib -leikcore.lib -lavkon.lib -leikcoctl.lib
    'Finished building target: C:/Symbian/8.1a/S60_2nd_FP3/epoc32/release/WINSCW/UDEB/Z/system/apps/TicTacToe/TicTacToe.app'
    ' '
    Build complete for project TicTacToe

  2. #2
    Super Contributor
    Join Date
    Oct 2005
    Location
    Hyderabad,India
    Posts
    1,156

    Re: No library file found matching 'libedll.lib{.lib|.a}' or 'edll.lib'

    check whether you have included proper/valid libraried in your mmp file and also in your project properties -> c++ build -> Wincw c/c++ linker -> libraries.

    seems like you have included a unknown library..something like libedll.lib

    Priju

  3. #3
    Registered User
    Join Date
    Jun 2006
    Posts
    8

    Re: No library file found matching 'libedll.lib{.lib|.a}' or 'edll.lib'

    Thanks very much for ur sugession

    these are the lib files which are
    in the project properties-> c/c++ build-> winscw c/c++ linker->
    and also in my .mmp file

    edll.lib
    euser.lib
    apparc.lib
    cone.lib
    eikcore.lib
    avkon.lib
    eikcoctl.lib

    I havan't included the libedll.lib.

  4. #4
    Regular Contributor
    Join Date
    Apr 2005
    Location
    Wellington
    Posts
    80

    Unhappy Re: No library file found matching 'libedll.lib{.lib|.a}' or 'edll.lib'

    Hello fellow developers,

    any resolution to this library not found error?

    I've moved from Carbide.C++ express to Carbide.C++ dev. This error never eventuated on "express" but on "dev" I can't get rid of it.

    I've tried adding(and deleting) different libraries but with no joy.

    Any help, as always, is much appreciated. Someone please make my $600 NZD expenditure to buy Carbide.C++ Dev worth the pain I'm currently experiencing.

    Ciao,

    S60N

    PS: Carbide.C++ Dev is worth it in regards to the GUI stuff, would be nice if everything else functioned too.
    Humpty dumpty sat on the wall ...

  5. #5
    Regular Contributor
    Join Date
    Apr 2005
    Location
    Wellington
    Posts
    80

    Question Re: No library file found matching 'libedll.lib{.lib|.a}' or 'edll.lib'

    Hello fellow developers,

    Code:
    Errors caused tool to abort.
    mwldsym2.exe|Usage|Error
    >No library file found matching 'libedll.lib{.lib|.a}' or 'edll.lib'
    
    mwldsym2.exe  -S -show only,names,unmangled,verbose -o ".infi" ".lib"
    
    Errors caused tool to abort.
    ### mwldsym2.exe Usage Error:
    #   Specified file '.lib' not found
    
    perl -S makedef.pl  -Inffile ".infi" ".defi"
    MAKEDEF ERROR: .infi: Inffile not found
    
    perl -S ecopyfile.pl  .defi .def
    .defi does not exist
    
    'Finished building: .defi'
    This seems to be a Carbide.C++ Dev IDE farkup as my application IS compiled (even though it complains that it is not).

    If anyone else has any thoughts on this I'd like to hear from you. But I would tentatively say that this error can be ignored.

    Ciao,

    S60N
    Humpty dumpty sat on the wall ...

  6. #6
    Registered User
    Join Date
    Aug 2007
    Posts
    74

    Re: No library file found matching 'libedll.lib{.lib|.a}' or 'edll.lib'

    Quote Originally Posted by Priju Jacob Paul View Post
    check whether you have included proper/valid libraried in your mmp file and also in your project properties -> c++ build -> Wincw c/c++ linker -> libraries.

    seems like you have included a unknown library..something like libedll.lib

    Priju
    Hi Priju,

    Thanks for your help.

Similar Threads

  1. need information about j2me polish
    By rathikathangaraj in forum Mobile Java General
    Replies: 4
    Last Post: 2007-12-19, 09:01
  2. Compilation series 60 3rd edition
    By asmobease in forum Symbian Tools & SDKs
    Replies: 32
    Last Post: 2006-09-13, 09:46
  3. adding new library in mmp file
    By liafail in forum Symbian
    Replies: 1
    Last Post: 2005-12-12, 06:50
  4. edll.lib file
    By shay_morim in forum Symbian
    Replies: 2
    Last Post: 2002-09-23, 13:00
  5. can not successfully link any sample using .NET
    By lobotomat in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2002-08-20, 00:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •