×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Oct 2006
    Location
    Austria - Vienna
    Posts
    30

    Red face UI Designer generated error in his code

    I've insert an image via UI designer. But his code don't work:

    iImage2 = new (ELeave) CEikImage;
    {
    CFbsBitmap* bitmap = iEikonEnv->CreateBitmapL( KProquizFile, EMbmProquizQlamp );
    CFbsBitmap* mask = iEikonEnv->CreateBitmapL( KProquizFile, EMbmProquizQlamp_mask );
    iImage2->SetPicture( bitmap, mask );
    }
    iImage2->SetAlignment( EHCenterVCenter );


    forces two errors:

    function call '[CEikonEnv].CreateBitmapL({lval} const TLitC<33>, {lval} CFbsBitmap *)' does not match 'CEikonEnv::CreateBitmapL(const TDesC16 &, int)' (non-static)

    undefined identifier 'EMbmProquizQlamp_mask'


    What can I do?

  2. #2
    Nokia Developer Expert
    Join Date
    Oct 2004
    Location
    Austin, TX USA
    Posts
    271

    Re: UI Designer generated error in his code

    What SDK are you using, and how did you insert the image? Can you tell me exactly what you did so I can try to reproduce the problem here?

    Regards,

    Matt P.

  3. #3
    Registered User
    Join Date
    Oct 2006
    Location
    Austria - Vienna
    Posts
    30

    Re: UI Designer generated error in his code

    Hi,

    SDK S60 2nd FP3 with Carbide.c++
    Making a project "s60 2nd Ed GUI Application with UI Designer"
    Changing to Gallery > MyAppContainer.uidesign
    From the Palette selecting "Image" and moving the mouse to the shown device-screen of the UI designer. Then via "Edit Image Property" setting the image-file and parameters.

    Remarks:

    1) at the beginning it works, so the implementation of the programm icons was without problems

    2) Now, I also see, that bei starting that project, also an error "*BMCONV failed" occurs ?? May there is a problem with the converter?

    thx for help
    regards
    ProAndi

  4. #4
    Nokia Developer Expert
    Join Date
    Oct 2004
    Location
    Austin, TX USA
    Posts
    271

    Re: UI Designer generated error in his code

    I'm having trouble reproducing this behavior. What do you do -- add one image, build it and everything's fine, and then add a second one? Or delete the first one and re-add it? Is there a specific bitmap size and depth you're using? Also, what type of UI Designer project is this -- Blank screen? Control panel? List?

    Regards,

    Matt P.

  5. #5
    Registered User
    Join Date
    Oct 2006
    Location
    Austria - Vienna
    Posts
    30

    Re: UI Designer generated error in his code

    It was the only one image, what I was inserting. I was meaning, that the making of the app icons (list and contex plane icon) was no problem. I choose the blank screen project. Size is 162 x 48 24bit (but target color depth 12). I also already tried source color depth 12bit.

Similar Threads

  1. Replies: 2
    Last Post: 2007-10-05, 20:40
  2. Replies: 0
    Last Post: 2003-09-26, 15:07
  3. Testing HTTP client for Nokia 3650; Looking to share code
    By nawkboy in forum Symbian Networking & Messaging (Closed)
    Replies: 2
    Last Post: 2003-09-10, 15:30
  4. Why is client code to CSocketEngine hanging at Access Point dialogue?
    By nawkboy in forum Symbian Networking & Messaging (Closed)
    Replies: 2
    Last Post: 2003-03-11, 11:16
  5. Replies: 0
    Last Post: 2003-02-24, 04:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×