×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    May 2006
    Posts
    8

    Problem with embedded browser on N80 not loading url

    Hi !
    Im trying to create an embedded browser control using the Browser control API, it works on emulator but on the target N80 the browser does not load the requested url. There is jus a blank window showing up, but the indicator shows that the browser is connected.

    Does anyone have a suggestion about this problem ?
    I'm using the following code

    void myclass::func()
    {
    CreateWindowL();
    TRect myRect = aRect;
    myRect.Shrink(40,40);
    SetRect( myRect );
    ActivateL();

    mCommandBase = TBrCtlDefs::ECommandIdBase;
    mBrCtlCapabilities = TBrCtlDefs::ECapabilityDisplayScrollBar | TBrCtlDefs::ECapabilityLoadHttpFw;
    TRect rect(Position(), Size());
    mBrCtlInterface = CreateBrowserControlL( this, rect, mBrCtlCapabilities, mCommandBase, NULL, NULL, NULL, NULL, NULL);

    _LIT(KUrl, "http://mobile.nokia.com/");
    mBrCtlInterface->LoadUrlL(KUrl);
    }

  2. #2
    Registered User
    Join Date
    Feb 2007
    Posts
    4

    Re: Problem with embedded browser on N80 not loading url

    Hey,
    I had the same problem - everything works on the Emulator, but on target device just blank page.

    Try this

    Code:
    _LIT(KUrl, "http://mobile.nokia.com/");
    mBrCtlInterface->LoadUrlL(KUrl);
    //////// It helps
    mBrCtlInterface->ActivateL ();

Similar Threads

  1. N80 memory card problem after update
    By fjorge_ht in forum General Development Questions
    Replies: 6
    Last Post: 2006-11-04, 16:59
  2. Personal certificate problem on N80 rendering https useless
    By dominox in forum General Development Questions
    Replies: 0
    Last Post: 2006-09-13, 09:58
  3. ! Solution found for Opening WAP Browser with a url
    By jpankaj in forum Symbian Networking & Messaging (Closed)
    Replies: 2
    Last Post: 2002-11-27, 10:18
  4. launch wap browser with a specific url.. 7650
    By asangamneheri in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2002-09-10, 13:36
  5. Starting 7650 browser sedded with a url
    By gmccollum in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2002-08-06, 20:45

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×