×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    66

    Question SIP SendSubscribeL returning -11 error

    Hi
    i am writting an IM application without using dialogs,i am using MESSAGE method and i am using SUBSCRIBE for checking the presence status, so when sending Subscribe method it is returning with -11 error(i.e KErrAlreadyExist).
    so what is the mistake i did in my code.

    code snippet which i used for sending subscribe method
    //------------------------------------------------------------------------
    iSIPSubscribeDialogAssoc = CSIPSubscribeDialogAssoc::NewL(conn, fromHeader, uri8, eventHdr, toHeader, aContact);

    CSIPClientTransaction* clientTx ;

    TRAPD(err,clientTx = iSIPSubscribeDialogAssoc->SendSubscribeL(msgElem, iRefresh));
    if (err!=KErrNone)
    {
    RDebug::Print(_L("Error in iSIPSubscribeDialogAssoc->SendSubscribeL:%d"),err);
    User::Leave(err);
    }
    //-------------------------------------------------------------------------

    so what may be the reason for that.
    plz help me out.
    Thanks in advance

    Regards
    satya.

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    30

    Re: SIP SendSubscribeL returning -11 error

    Quote Originally Posted by satya3050
    ...Subscribe method it is returning with -11 error(i.e KErrAlreadyExist)....
    Hi!
    I recently wrote a similar problem at:
    http://discussion.forum.nokia.com/fo...ad.php?t=91193

    (not related to SUBSCRIBE method, but related to MESSAGE)

    Please, if you solve yours, let me know. I will do the same.
    BTW, could you tell me what have you taken as starting point to construct a SUBSCRIBE? I'm doing it for 2.2SDK (6680), and I know that probably you are working for 3rd ED, but less is nothing...

    Cheers.

    Fran

  3. #3
    Registered User
    Join Date
    Mar 2003
    Posts
    30

    Re: SIP SendSubscribeL returning -11 error

    Hi Satya!
    Please, have you solved the -11 Error when sending SUBSCRIBE?
    I'm just facing the same problem, and even posted a lot here, but it seems that nobody cares... or nobody has had the same problem.
    So, have you solved that for MESSAGE and SUBSCRIBE?
    I had the SAME error code than you, and I was wondering if you could reach to any solution...

    Thanks a lot
    Fran.

Similar Threads

  1. error LNK2019: unresolved external symbol ???
    By wgarnett in forum Symbian
    Replies: 3
    Last Post: 2009-09-28, 06:53
  2. SIP STACK ERROR -17720 (SUBSCRIBE)
    By Priju Jacob Paul in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2006-12-05, 14:40
  3. My BuilderX (with S60 SDK 2.1.NET MS version) cannot build ARMI UREL
    By danielvidonyi@hotmail.com in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2006-05-04, 21:30
  4. User break point error in Grid
    By ag24master in forum Symbian User Interface
    Replies: 0
    Last Post: 2003-08-07, 08:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×