×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Regular Contributor
    Join Date
    Nov 2006
    Posts
    89

    listbox cannot display

    i created a view supported app by 2nd SDK fp2,and add the code below in the first container cpp and create corresponding resource in the rss file.but the listbox doesn't display wherever on emulator or on my N72.

    any advice would be appreciated.

    (CEikColumnListBox* iListBox; //in .h )

    iListBox = new(ELeave) CAknSingleStyleListBox();
    iListBox->SetContainerWindowL(*this);
    iListBox->SetListBoxObserver(this);

    TResourceReader reader;
    CEikonEnv::Static()->CreateResourceReaderLC( reader, R_TEXT_SINGLE );
    iListBox->ConstructFromResourceL( reader );
    CleanupStack::PopAndDestroy(); // resource stuffs.

    iListBox->CreateScrollBarFrameL(ETrue);
    iListBox->ScrollBarFrame()->SetScrollBarVisibilityL(CEikScrollBarFrame::EOff,CEikScrollBarFrame::EAuto);

    iListBox->SetRect(Rect());
    iListBox->ActivateL();

    TInt pos( iListBox->View()->CurrentItemIndex() );
    if ( iListBox->ScrollBarFrame() )
    {
    iListBox->ScrollBarFrame()->MoveVertThumbTo( pos );
    }

    DrawNow();

  2. #2
    Super Contributor
    Join Date
    Oct 2005
    Location
    Hyderabad,India
    Posts
    1,156

    Re: listbox cannot display

    Have you given proper implementation in CountComponentControl() and ComponentControl() after adding your listbox.If an improper count is given in CountComponentControl() the controls wouldnt be displayed.
    Please post your .rss too.

    Priju

  3. #3
    Regular Contributor
    Join Date
    Nov 2006
    Location
    Brebes, Indonesia
    Posts
    129

    Re: listbox cannot display

    cek your CountComponentControls() in app view or SizeChanged().
    http://blogehendrawan.blogspot.com - Kembangin symbian di Indonesia yukk....

  4. #4
    Regular Contributor
    Join Date
    Nov 2006
    Posts
    89

    Re: listbox cannot display

    thanks a lot.
    having changed some code of ComponentControl and CountComponentControls,the listbox seems to be displayed.but only one item is displayed and no content on it.why?
    below is the resource in the .rss

    RESOURCE LISTBOX r_text_single
    {
    array_id = r_array_single;
    flags = EAknListBoxSelectionList;
    }

    RESOURCE ARRAY r_array_single
    {
    items =
    {
    LBUF
    {
    txt = " /taaaaaa";
    },
    LBUF
    {
    txt = " /taaaaaa";
    },
    LBUF
    {
    txt = " /taaaaaa";
    },
    LBUF
    {
    txt = " /taaaaaa";
    },
    LBUF
    {
    txt = " /taaaaaa";
    },
    LBUF
    {
    txt = " /taaaaaa";
    },
    LBUF
    {
    txt = " /tbbbbbb";
    }
    };
    }
    Last edited by bodybo; 2006-11-24 at 05:29.

  5. #5
    Super Contributor
    Join Date
    Oct 2005
    Location
    Hyderabad,India
    Posts
    1,156

    Re: listbox cannot display

    Hi,
    if your format of the items to be appended is wrong the contents wont be displayed.so you could check that.

    Priju

  6. #6
    Regular Contributor
    Join Date
    Nov 2006
    Posts
    89

    Re: listbox cannot display

    hi,priju

    you are right.save .rss file as UTF-8 format,the listbox works well.

    thank you very much!

Similar Threads

  1. Recording in Amr Format
    By losym in forum Symbian Media (Closed)
    Replies: 12
    Last Post: 2009-03-26, 06:41
  2. Nokia N-Series Complete Model Line-Up
    By Dopod in forum General Development Questions
    Replies: 6
    Last Post: 2008-07-22, 20:16
  3. read a file and then display in form of listbox
    By Kapil Kaushik in forum Symbian
    Replies: 7
    Last Post: 2006-11-27, 04:17
  4. Listbox Display
    By shilpav in forum Symbian User Interface
    Replies: 2
    Last Post: 2004-11-08, 07:37
  5. Replies: 0
    Last Post: 2003-03-06, 11:43

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×