I've discovered few days ago the nokia open source community. So I deceided to test the s60webkit browser.
After some hours spent into understand how it works, how to compile and which files I need to compile, I'm still facing an error on the installation: "Required application access not granted".
This is what I did:
1. I followed all the instructions to install the sdk and webkit which are given on the website http://trac.webkit.org/projects/webkit/wiki/S60Webkit.
2. I tried to compile the .pkg to a .sis but I got a lot of missing files.
3. So I opened the .pkg and changed all the relative links to absolut ones, then made correctly the .sis
4. Then I tried to install it on my nokia e50 (symbian, s60 3rd), but I got the error "Unable to install a protected application from an untrusted supplier".
5. I created a certificate following the instructions given by www.symbiansigned.com to obtain a Symbian Signed Developer Certificate.
6. After having signed the .sis, I tried again to install it. I got no problem with certification, but after choosing where I wanted to install it (mobilephone or memory card), I got the error "Required application access not granted".
What suprised me is that normally I can use all capabilities because of my certification (which lets me use all capabilities for one IMEI serial). (and I seleted all the capabilities when created the .csr)

Thank you for your help
WyzoK