Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Nov 2006

    Re: Granting sensitive capabilities

    I've discovered few days ago the nokia open source community. So I deceided to test the s60webkit browser.
    After some hours spent into understand how it works, how to compile and which files I need to compile, I'm still facing an error on the installation: "Required application access not granted".
    This is what I did:
    1. I followed all the instructions to install the sdk and webkit which are given on the website http://trac.webkit.org/projects/webkit/wiki/S60Webkit.
    2. I tried to compile the .pkg to a .sis but I got a lot of missing files.
    3. So I opened the .pkg and changed all the relative links to absolut ones, then made correctly the .sis
    4. Then I tried to install it on my nokia e50 (symbian, s60 3rd), but I got the error "Unable to install a protected application from an untrusted supplier".
    5. I created a certificate following the instructions given by www.symbiansigned.com to obtain a Symbian Signed Developer Certificate.
    6. After having signed the .sis, I tried again to install it. I got no problem with certification, but after choosing where I wanted to install it (mobilephone or memory card), I got the error "Required application access not granted".
    What suprised me is that normally I can use all capabilities because of my certification (which lets me use all capabilities for one IMEI serial). (and I seleted all the capabilities when created the .csr)

    Thank you for your help

  2. #2
    (Retired) Nokia Developer Admin.
    Join Date
    Jan 2006

    Re: Granting sensitive capabilities

    New thread started

  3. #3
    Super Contributor
    Join Date
    Nov 2005

    Re: Required application access not granted

    You selected all the capabilities? You would however only have got assigned a limited set for the devcert bound to 1 IMEI, because you can't get certain capabilities (eg DRM) without going through a specific application process to Nokia. Others require an ACS publisher ID, as you probably saw on the Symbian signed site.

    If you've not already seen it, this entry is a really useful way of determining what's causing your installation issue:

    This is another one.

    In your case, it does sound as if you're signing something which has more capabilities than your devcert can cover.

Similar Threads

  1. Replies: 50
    Last Post: 2012-09-14, 07:53
  2. Connecting J2ME application to Internet using WAP access point?
    By khurshed79 in forum Mobile Java Networking & Messaging & Security
    Replies: 12
    Last Post: 2012-09-12, 09:53
  3. Thawte Premium Server CA
    By Thygrrr in forum Mobile Java Networking & Messaging & Security
    Replies: 10
    Last Post: 2006-09-12, 05:04
  4. IrDA access through J2ME application
    By in forum Bluetooth Technology
    Replies: 0
    Last Post: 2002-04-13, 02:21
  5. IrDA access through J2ME application
    By in forum Bluetooth Technology
    Replies: 0
    Last Post: 2002-04-13, 02:18

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts