×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Nov 2006
    Posts
    6

    Problem with user include Paths in WINSCW C/C++ Compiler

    Hi,

    Is there a possibilty tu use two SDKs at once for example UIQ3.0 and S60_3rd?

    I have UIQ3.0 project and I've added user include path under WINSCW C/C++ include options but whilst compiling a get this:

    ### mwccsym2.exe Usage Error:
    # Unknown option 'iD:\symbian\9.1\S60_3rd_MR\Epoc32\include'

    because of this:
    'Building file: ../src/XlatorUIQAppUi.cpp'
    'Invoking: WINSCW C/C++ Compiler'
    mwccsym2.exe -sym full -c -wchar_t off -align 4 -enum int -str pool -nostdinc -exc ms -inline off -msgstyle parseable -nowraplines -cwd source -O0 -D_UNICODE -D__SYMBIAN32__ -D__CW32__ -D__WINS__ -D__EXE__ -D__WINSCW__ -D_DEBUG -D__SUPPORT_CPP_EXCEPTIONS__ -include "D:\symbian\UIQ\UIQ3SDK\epoc32\include\variant\UIQ_3.0.hrh" -i"D:\symbian\9.1\S60_3rd_MR\Epoc32\include" -i "D:\symbian\Carbide\workspace\XlatorUIQ\inc" -i "D:\symbian\Carbide\workspace\XlatorUIQ\data" -i- -i "D:\symbian\UIQ\UIQ3SDK\epoc32\include" -i "D:\symbian\UIQ\UIQ3SDK\epoc32\include\variant" -w cmdline -w pragmas -w empty -w possible -w unusedarg -w unusedvar -w extracomma -w pedantic -w largeargs -w ptrintconv -w tokenpasting -w missingreturn -MD -o src/XlatorUIQAppUi.o ../src/XlatorUIQAppUi.cpp

    Is this a syntax bug or smth like that??
    or am I doing smth wrong?

    I am using Carbide Express 1.1

    I will appreciate any help.

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,688

    Re: Problem with user include Paths in WINSCW C/C++ Compiler

    Note that the other -i / -include options have a space following them. This one has no space. Go through the settings page to check if it can be modified.

  3. #3
    Registered User
    Join Date
    Nov 2006
    Posts
    6

    Re: Problem with user include Paths in WINSCW C/C++ Compiler

    Yes I have noticed it of course, that's why it is in red color. But the question is if there is any way to change this situation. There is no way to change it in properties page because everything I am writing in is between " and " signs. So I suppose it is Carbide team fault. Does anybody from Carbide team can confirm or deny it?
    Last edited by mjoachimiak; 2006-11-30 at 13:18.

  4. #4
    Registered User
    Join Date
    Dec 2006
    Posts
    6

    Re: Problem with user include Paths in WINSCW C/C++ Compiler

    i had the same poroblem and it seems to be a bug in carbide. i solved it by writing a space in front of the include paths in the carbide project settings. ('"X:\XXX\XXX"' -> ' X:\XXX\XXX')

Similar Threads

  1. Problem MMC+USB Connection
    By Fede81 in forum General Development Questions
    Replies: 3
    Last Post: 2006-07-19, 15:21
  2. Problem with Nokia30 user control mode
    By ttchiew in forum Nokia M2M
    Replies: 3
    Last Post: 2003-07-01, 11:19
  3. "HelloWorld" doesn't work on 7650.
    By Falcons in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2003-05-29, 11:35
  4. i have a PDU user data coding converted problem......
    By torto in forum Smart Messaging
    Replies: 1
    Last Post: 2002-10-07, 09:10
  5. Nokia User Agent problem or Gateway problem ??
    By pbipin in forum WAP Servers
    Replies: 2
    Last Post: 2002-10-04, 02:43

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×