×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Regular Contributor
    Join Date
    Aug 2006
    Location
    Rawalpindi, Pakistan
    Posts
    486

    Preverifier error

    Guys i am having an Odd problem.

    i am using jbuilder 9 enterprise edition. i am udsing cldc 1.1 and midp 2.0

    when i compilmy program it says Error previerfying class no floating point allowed. i am using it with J2mE wireless toolkit 2.2 and it supports cldc which i think should support floating point. the error is like this

    ERROR: floating-point arguments should not appear
    Error preverifying class javax.microedition.m2g.SVGAnimator

    C:\WTK22\bin\preverify.exe -cldc -classpath "D:\SVG PGC_SDK\classes;C:\JBuilder9\classes;C:\JBuilder9\lib\xmlbeans.jar;C:\JBuilder9\lib\xercesImpl.jar;C:\JBuilder9\lib\xmlParserAPIs.jar;C:\JBuilder9\extras\xalan\bin\xalan.jar;C:\JBuilder9\lib\xmldbms.jar;C:\FileConnection_DEMO\dist\FileConnection_DEMO.jar;D:\Midlet Libraries\ksoap-midp.jar;C:\j2mepolish-1[1].2.4;D:\jar files\m2g.zip;C:\WTK22\lib\midpapi20.jar;C:\WTK22\lib\cldcapi11.jar;C:\WTK22\lib\wma20.jar;C:\WTK22\lib\mmapi.jar;C:\WTK22\lib\j2me-ws.jar;C:\WTK22\lib\jsr75.jar;C:\WTK22\lib\jsr082.jar;C:\WTK22\lib\jsr184.jar;D:\jar files\scalable_vector_graphics-1_1-mrel-spec.zip" -d "D:\SVG PGC_SDK\preverified-classes" @"D:\SVG PGC_SDK\preverified-classes\params"

    now if i am correcr tis giveing preverify.exe -cldc shouldnt it give -cldc1.1
    is there any way to change the preverifier setting in jbuilder or in j2me.

    would love ur help.
    thanx
    Regards
    Nouman

  2. #2
    Super Contributor
    Join Date
    Dec 2005
    Location
    Europe/Poland/Warsaw
    Posts
    1,699

    Re: Preverifier error

    hi Nouman,

    shouldn't you use Sun 2.5 beta WTK for SVG authoring? I wonder why it does not fails while coding (prior to compilation) (e.g. NetBeans won't allow to use api not specified in emulator descriptor)

    regards,
    Peter

  3. #3
    Regular Contributor
    Join Date
    Aug 2006
    Location
    Rawalpindi, Pakistan
    Posts
    486

    Re: Preverifier error

    Thanx for reply peter

    i downloaded the WTK 2.5 beta it still did not solve my problem.

    same error as stated above. i think it might be a bug on jbuilder side.
    what do u think peter?
    Regards
    Nouman

  4. #4
    Super Contributor
    Join Date
    Dec 2005
    Location
    Europe/Poland/Warsaw
    Posts
    1,699

    Re: Preverifier error

    hi,

    there is a decent thread with possible solution (could be pricey):
    JBuilder9 (and older versions) are configured so that it always preverifies in "CLDC 1.0 mode", so building the MIDlet fails during the preverification phase.
    http://discussion.forum.nokia.com/fo...ad.php?t=47835

    regards,
    Peter

  5. #5
    Regular Contributor
    Join Date
    Aug 2006
    Location
    Rawalpindi, Pakistan
    Posts
    486

    Re: Preverifier error

    Thanx peterblazejewicz

    atleast i have a solution and a reason why this serror is occuring
    Regards
    Nouman

Similar Threads

  1. Linkage error (Urgent)
    By waelali in forum Symbian Tools & SDKs
    Replies: 8
    Last Post: 2006-02-07, 10:20
  2. S80 Platform SDK and Visual Studio .NET Linking Error
    By jayantjain in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2005-10-07, 22:14
  3. User break point error in Grid
    By ag24master in forum Symbian User Interface
    Replies: 0
    Last Post: 2003-08-07, 08:20
  4. Dialogs within Symbian 6.0 based SDK
    By georgica1979 in forum Symbian User Interface
    Replies: 14
    Last Post: 2003-04-07, 15:29
  5. Preverifier error
    By kapot in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2002-10-28, 18:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •