×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Nov 2006
    Posts
    22

    Signing Problem : Certificate chaining

    Hi All,

    I am another victim of the midlet sigining circle. My application (accessing PIM API) installs & works fine without signing.

    Now, I have signed it with a CA whose root certificate IS available in my mobile (6111). My certificate is the fourth in the certificate chain. (Meaning that I am at the fourth level from the root certificate that is installed in the mobile).

    After signing trying to install the signed file on 6111 gives "Invalid application" error and removing the signing part from JAD cures this.

    My JAD looks something like this:
    MIDlet-Certificate-1-1: MIIDzD..
    MIDlet-Certificate-1-2: MIIEOj...
    MIDlet-Certificate-1-3: MIIEW...
    MIDlet-Certificate-1-4: MIICW...
    MIDlet-Jar-RSA-SHA1: YdU4x+2....

    Trying to install it on E61 gives "Certificate error", while it also has the root certificate.

    Seems to be a certificate chaining issue. ANY URGENT HELP WOULD BE GREATLY APPRECIATED.

    TIA.

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    4,105
    Please provide the full entries, do not shorten, in a code tag here. Anyway, is this a VeriSign or thawte certificate? Three intermediates look wrong … just give these lines to us as they do not conatin any private information. They are just public keys.

  3. #3
    Registered User
    Join Date
    Feb 2005
    Posts
    10

    Unhappy Signing Problem : Certificate chaining

    Hi ,

    I got a certificate from verisign class 3(I think it is RSA with SHA algorithm) and sign the application then install it on sony-ericsson phones it worked fine and didn't ask any question for pim .

    Now the problem is that when I tried it with nokia phones(model 6681, N70), the midlet signed properly and installed on the phone with no error. After that I have set the permission "always allowed" for read user data, and edit user data.
    But when the application tries to edit or read the PIM data it ask questions everytime.

    So please clarify me on this.
    1)Is the verisign certificates are working for nokia phones???
    2)If yes then what root certificates is required to sign the midlet???
    3)My midlet is signed with RSA-SHA algorithm but on the phone when I checked the verisign class 3, it has used the RSAMD2 algorithm is it going to create a problem while accessing the security apis???

    Please help me

  4. #4
    Super Contributor
    Join Date
    Mar 2005
    Location
    Paris
    Posts
    814

    Re: Signing Problem : Certificate chaining

    1)yes
    2)consequently, none
    3)i have always been working with rsa-sha and never experienced incompatibility. Therefore, i think it should work.

Similar Threads

  1. Problem signing with developer certificate
    By greatape in forum Symbian
    Replies: 11
    Last Post: 2013-02-15, 11:23
  2. Thawte certificate and S60 3rd edition
    By simsiem in forum Mobile Java General
    Replies: 12
    Last Post: 2007-05-05, 09:14
  3. Midlet signing with certificate
    By cforstner in forum Mobile Java General
    Replies: 3
    Last Post: 2004-12-13, 14:06
  4. Signing midlets with Verisign certificate for Nokia 6600
    By rmellado in forum Mobile Java General
    Replies: 0
    Last Post: 2004-07-02, 10:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×