×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 19
  1. #1
    Registered User
    Join Date
    Mar 2006
    Posts
    44

    Unable to Install. Constrained by the certificate.

    Hi,

    I got the developer certificate from symbiansigned site. Generated the sis file with this certification and my private key. And tried to install this sis file on to the NOKIA E60 which is S60 3rd Edition. When i am trying to install on this device, it is asking some steps for installing.
    "RunApp" is my sample application.

    Step1 : Install RunApp? Yes/No
    clicked on the Yes.

    Step2 : Details:
    Name: RunApp
    Version: 1.00
    Supplier: My Test EN
    Application Size: UnKnown
    Format: Symbian OS
    Type: Application
    Certificates: View details
    buttons: Continue/Cancel
    clicked on the Continue

    Step3 : Security warning:
    Application is for development use only. Continuing installation may cause serious problems to your device. Continue? Yes/No
    Clicked on the Yes.

    Step4 : Application not compatible with phone. Continue anyway? Yes/No
    Clicked on the Yes.

    Step5 : In this step, it just shown a message and stopped the installation.
    The below is that message.

    Unable to Install. Constrained by the certificate.

    please give me the solution to this problem.

  2. #2
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,336

    Question Re: Unable to Install. Constrained by the certificate.

    Hi,

    May i know which Phone's IMEI did you send with Developer Certificate Request?

    I hope it is same IMEI of your NOKIA E60 on which you are installing, isn't it?

    Regards.
    Kiran.

  3. #3
    Registered User
    Join Date
    Mar 2006
    Posts
    44

    Re: Unable to Install. Constrained by the certificate.

    Quote Originally Posted by kiran10182
    Hi,

    May i know which Phone's IMEI did you send with Developer Certificate Request?

    I hope it is same IMEI of your NOKIA E60 on which you are installing, isn't it?

    Regards.
    Kiran.
    Hi Kiran,

    previously i just generated the IMEI value by using GenerateIMEIs.bat.
    Now i got the IMEI value in NOKIA E60 by pressing the below keys
    *#06#
    The NOkia E60 IMEI's is 356219000687950.
    And generated the certification request file .cer, submit in the smybian signed site.
    Downloaded the Developer certification file this site.
    The below contents are capabilities and IMEI's value shown in this site for that certification.

    IMEIs for the certificate
    356219000687950


    Capabilities for the certificate
    LocalServices
    Location
    NetworkServices
    PowerMgmt
    ProtServ
    ReadDeviceData
    ReadUserData
    SurroundingsDD
    SwEvent
    TrustedUI
    UserEnvironment
    WriteDeviceData
    WriteUserData


    Now i tried to install on Nokia E60 device. i got same results as in the begining in this thread.

    From the below steps:

    Step4 : Application not compatible with phone. Continue anyway? Yes/No
    Clicked on the Yes.

    Step5: it is showing a Progress bar and after completion of progress bar,
    it is shown a message i.e.
    Unable to install.


    Now this time it is not given "Constrained by the certificate."message in the above.
    it is just given "Unable to install".

    please give me what exact problem and solution for that.

    thanks

  4. #4
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,336

    Re: Unable to Install. Constrained by the certificate.

    Hi,
    Quote Originally Posted by manjunaths
    Now this time it is not given "Constrained by the certificate."message in the above.
    it is just given "Unable to install".
    Are you using other application's private folder?
    List down your .pkg file entires.

    Regards.
    Kiran.

  5. #5
    Registered User
    Join Date
    Mar 2006
    Posts
    44

    Re: Unable to Install. Constrained by the certificate.

    Quote Originally Posted by kiran10182
    Hi,


    Are you using other application's private folder?
    List down your .pkg file entires.

    Regards.
    Kiran.
    Hi kiran,

    the below details are related .pkg file contents.

    ; RunApp.pkg
    ;
    ;Language - standard language definitions
    &EN

    ; standard SIS file header
    #{"RunApp"},(0x02CE67A6),1,0,0

    ;Supports Series 60 v 3.0
    (0x101F7961), 0, 0, 0, {"Series60ProductID"}

    ;Localized Vendor Name
    %{"My Test EN"}

    ;Unique Vendor name
    :"Vendor"

    ; Files to copy
    "C:\Apps\RunApp\group\RunApp_Data\GCCE_UREL\RunApp.exe"-"!:\sys\bin\RunApp.exe"
    "C:\Apps\RunApp\group\RunApp_Data\GCCE_UREL\RunApp_reg.rsc"-"!:\private\10003a3f\import\apps\RunApp_reg.rsc"
    "C:\Apps\RunApp\group\RunApp_Data\GCCE_UREL\RunApp_loc.Rsc"-"!:\resource\apps\RunApp_loc.Rsc"
    "C:\Apps\RunApp\group\RunApp_Data\GCCE_UREL\RunApp.Rsc"-"!:\resource\apps\RunApp.Rsc"


    Can you give me what exact problem.

  6. #6
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,336

    Smile Re: Unable to Install. Constrained by the certificate.

    Hello Manjunath,

    Refer to the following blog from Antony:
    http://blogs.forum.nokia.com/view_entry.html?id=93

    Search for "Unable to Install" phrase in the blog.
    You may get some useful work-arounds there.

    Regards.
    Kiran.

  7. #7
    Registered User
    Join Date
    Mar 2006
    Posts
    44

    Re: Unable to Install. Constrained by the certificate.

    Quote Originally Posted by kiran10182
    Hello Manjunath,

    Refer to the following blog from Antony:
    http://blogs.forum.nokia.com/view_entry.html?id=93

    Search for "Unable to Install" phrase in the blog.
    You may get some useful work-arounds there.

    Regards.
    Kiran.
    Hi Kiran,
    I installed successfully on the device.
    In .pkg file i was changed the file paths to my application path where it is created.
    Now i changed those paths to symbian epoc32 path.
    Now it is working fine.
    Thanks for giving the solutions.

  8. #8
    Registered User
    Join Date
    Dec 2008
    Posts
    3

    Re: Unable to Install. Constrained by the certificate.

    Hi,

    I bought the Mobiola Screen Capture application from the Nokia Software market. When I tried to install it on my Nokia 5800 XpressMusic, I get an error message saying "Unable to Install. Constrained by certificate". I installed the S60v3 version. It installed properly but when I run it, I see a green screen on my PC. It doesn't show my phone's screen. Please advise.

  9. #9
    Nokia Developer Champion
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: Unable to Install. Constrained by the certificate.

    Quote Originally Posted by ajaind View Post
    Hi,

    I bought the Mobiola Screen Capture application from the Nokia Software market. When I tried to install it on my Nokia 5800 XpressMusic, I get an error message saying "Unable to Install. Constrained by certificate". I installed the S60v3 version. It installed properly but when I run it, I see a green screen on my PC. It doesn't show my phone's screen. Please advise.
    Welcome to forum nokia DiBo.

    If application is not developed by you than it is recommended to ask this question to your application supplier.

    Note that if this application is developed in S603rd edition, than its not work on 5800, as 5800 is of 5th edition.

    If your error message is exactly "Unable to Install" then probably you are trying to access private folder of other app.

    Refer this blog to know the exact reason of your error.
    http://blogs.forum.nokia.com/index.p...&articleId=93&

  10. #10
    Regular Contributor
    Join Date
    Jan 2009
    Posts
    74

    Re: Unable to Install. Constrained by the certificate.

    Quote Originally Posted by manjunaths View Post
    Hi Kiran,
    I installed successfully on the device.
    In .pkg file i was changed the file paths to my application path where it is created.
    Now i changed those paths to symbian epoc32 path.
    Now it is working fine.
    Thanks for giving the solutions.
    Hi,

    I am getting the same error like "Unable to Install". Can you kindly explain me what are all the changes you done to ur .pkg file??

    Here is mine,

    ; symbian_ua_gui.pkg
    ; This is an auto-generated PKG file by Carbide.
    ; This file uses variables specific to Carbide builds that will not work
    ; on command-line builds. If you want to use this generated PKG file from the
    ; command-line tools you will need to modify the variables with the appropriate
    ; values: $(EPOCROOT), $(PLATFORM), $(TARGET)
    ; Also, the resource file entries should be changed to match the language
    ; used in the build. For example, if building for LANGUAGE_01, change the file
    ; extensions .rsc to .r01.
    ;
    ;Language - standard language definitions
    &EN

    ; standard SIS file header
    #{"symbian_ua_gui"},(0xEBD12EE4),1,0,0

    ;Localised Vendor name
    %{"Vendor-EN"}

    ;Unique Vendor name
    :"Vendor"

    ;Supports Series 60 v 3.0
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}

    ;Files to install
    ;You should change the source paths to match that of your environment
    ;<source> <destination>
    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\symbian_ua_gui.exe" -"!:\sys\bin\symbian_ua_gui.exe"
    "$(EPOCROOT)Epoc32\data\z\resource\apps\symbian_ua_gui.r01" -"!:\resource\apps\symbian_ua_gui.r01"
    "$(EPOCROOT)Epoc32\data\z\private\10003a3f\apps\symbian_ua_gui_reg.r01" -"!:\private\10003a3f\import\apps\symbian_ua_gui_reg.r01"
    "$(EPOCROOT)epoc32\data\z\resource\apps\symbian_ua_gui_aif.mif" -"!:\resource\apps\symbian_ua_gui_aif.mif"
    "$(EPOCROOT)epoc32\data\z\resource\apps\symbian_ua_gui.mbm" -"!:\resource\apps\symbian_ua_gui.mbm"
    ; Add any installation notes if applicable
    ;"symbian_ua_gui.txt" -"!:\private\0xEBD12EE4\symbian_ua_gui.txt"

  11. #11
    Nokia Developer Champion
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: Unable to Install. Constrained by the certificate.

    Quote Originally Posted by sathiyapriyanm
    ;"symbian_ua_gui.txt" -"!:\private\EBD12EE4\symbian_ua_gui.txt"
    Must not use 0x in path.

    Read this blog carefully if your problem is still not resolved.
    http://blogs.forum.nokia.com/index.p...&articleId=93&

  12. #12
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,336

    Re: Unable to Install. Constrained by the certificate.

    Quote Originally Posted by savaj View Post
    Must not use 0x in path.
    That line is commented out so it should not be a cause of the problem.

    Anyways I have observed that such a problem occurs with the .sisx file created from Carbide.c++ UI designer. I don't know what is the solution but there is a bug in the auto-generated .pkg file from Carbide.c++ ui designer(Even though it is commented but it should not have "0x" for the last entry in the .pkg file)
    Nokia Developer Wiki Moderation team

  13. #13
    Nokia Developer Champion
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: Unable to Install. Constrained by the certificate.

    Quote Originally Posted by Kiran10182
    That line is commented out so it should not be a cause of the problem.
    Right, actually i have not noticed that this line was commented.

    Interestingly, today i observed that UI designer generates that line with path having 0x in it.

  14. #14
    Regular Contributor
    Join Date
    Jan 2009
    Posts
    74

    Re: Unable to Install. Constrained by the certificate.

    Quote Originally Posted by savaj View Post
    Right, actually i have not noticed that this line was commented.

    Interestingly, today i observed that UI designer generates that line with path having 0x in it.
    i am not clear with all ur solutions..can u kinldy explain a bit more?

  15. #15
    Nokia Developer Champion
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: Unable to Install. Constrained by the certificate.

    There might be some issue in auto-generated .pkg file from Carbide.c++ ui designer. So create .pkg file by your own and use that one.

Similar Threads

  1. is it possible to install personal certificate?
    By btosic in forum Symbian Networking & Messaging (Closed)
    Replies: 3
    Last Post: 2008-04-10, 15:00
  2. 7710. how install new certificate?
    By carapapaa in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 0
    Last Post: 2006-11-10, 08:34
  3. Self-signed CA certificate
    By blackbuddha in forum Mobile Java Networking & Messaging & Security
    Replies: 6
    Last Post: 2006-07-25, 11:03
  4. Failed MIDlet install with VeriSign certificate
    By chgru in forum Mobile Java Networking & Messaging & Security
    Replies: 14
    Last Post: 2006-06-06, 16:57
  5. Please help implementing WTLS
    By Nokia_Archived in forum WAP Servers
    Replies: 1
    Last Post: 2002-05-20, 13:27

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •