×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 19
  1. #1
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    364

    Blank Screen Emulator

    i,

    I'm trying to Run any symbian Application Under the symbian Emulator (S6 2.0 wins udeb) the strange thing Happened today when I tried to run my application there is no any application (ICONS) system e.g.: (Calender,Telephone Directory ,...etc) or my runing application not displayed on the emulator to run it (See the attached (Jif) file) , I Un-Installed and re-Installed sysmbian SDK again but the same problem continued , How I can Solve it please I need your Help.

    My Platform Is : WinXP/SP2, epoc 32.
    IDE: VS.NET 2003 With Carbide.
    SDK (S60 v2.0) (7.0s).


    http://discussion.forum.nokia.com/fo...ad.php?t=97815

  2. #2
    Super Contributor
    Join Date
    May 2005
    Location
    Hyderabad,India
    Posts
    704

    Re: Blank Screen Emulator

    Hi,

    Check your taskmanager, is epoc is already running. remove the epoc from taskmanager and try it.

    regards,
    eswar

  3. #3
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    364

    Re: Blank Screen Emulator

    Quote Originally Posted by eswar_illuri
    Hi,

    Check your taskmanager, is epoc is already running. remove the epoc from taskmanager and try it.

    regards,
    eswar
    If I remove it from the task manager thats mean it will be stopped?! Can you explain again your answer?

  4. #4
    Regular Contributor
    Join Date
    Mar 2003
    Location
    Helsinki
    Posts
    63

    Question Re: Blank Screen Emulator

    mubx2000,

    Have you got a standard Intel 32 bit processor? (Just thought a 64 bit CPU might behave differently, who knows.)

    Have you started the emulator directly from the Windows Start menu? (Start -> Series 60 Developer Tools -> SDK 2.1 ... -> Enulator (Debug). It might work better from there than from the IDE (Visual Studio).

    Have you checked the contents of the epocwind.out file? Where does the emulator halt?

    The Symbian Emulator requires lots of memory and a fast CPU.

    -Jyrki

  5. #5
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    364

    Re: Blank Screen Emulator

    Quote Originally Posted by jyrkiettila
    mubx2000,

    Have you got a standard Intel 32 bit processor? (Just thought a 64 bit CPU might behave differently, who knows.)

    Have you started the emulator directly from the Windows Start menu? (Start -> Series 60 Developer Tools -> SDK 2.1 ... -> Enulator (Debug). It might work better from there than from the IDE (Visual Studio).

    Have you checked the contents of the epocwind.out file? Where does the emulator halt?

    The Symbian Emulator requires lots of memory and a fast CPU.

    -Jyrki
    Can You Descripe Precisely How I Can Check the contents of this file (epocwind.out )?

  6. #6
    Regular Contributor
    Join Date
    Sep 2006
    Location
    Australia, NSW
    Posts
    200

    Re: Blank Screen Emulator

    Quote Originally Posted by mubx2000
    If I remove it from the task manager thats mean it will be stopped?! Can you explain again your answer?
    There may be previous instance of the emulator left running. If you start a second one at the same time, it will show only blank screen. Kill all "epoc.exe" processes in the task manager and restart it.

    Quote Originally Posted by mubx2000
    Can You Descripe Precisely How I Can Check the contents of this file (epocwind.out )?
    C:\Documents and Settings\<Your Windows user name>\Local Settings\Temp\epocwind.out

  7. #7
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    364

    Re: Blank Screen Emulator

    Quote Originally Posted by sysctl
    There may be previous instance of the emulator left running. If you start a second one at the same time, it will show only blank screen. Kill all "epoc.exe" processes in the task manager and restart it.

    If You Start Your PC The Task Mgr Will Not List (eopc.exe) because it is not (Background task) but If You Run (eopc.exe) it will be of course listed on the (Task Mgr),If You remove it then (eopc) will be off.

    C:\Documents and Settings\<Your Windows user name>\Local Settings\Temp\epocwind.out
    This File Is Not Available at all may be it is available with other series or SDKs.

  8. #8
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,752

    Re: Blank Screen Emulator

    Quote Originally Posted by mubx2000
    This File Is Not Available at all may be it is available with other series or SDKs.
    It is available in all Symbian SDK-s.
    Is it so that you have not seen your emulator running for more than a month? :-(
    You should try re-installing again. If you have more than one SDK-s installed, you should remove all of them. Then delete the c:\Symbian folder (if you have works in it, save them before :-).
    You may also remove the c:\Program Files\Common Files\Symbian folder.
    Then you may try re-installing the SDK.
    Also consider that S60 2.1 still uses Symbian 7.0s, but it has a bit more stable emulator (actually I do not know what phone model you have, but I develop for 6600 with S60 2.1 SDK).

  9. #9
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    364

    Re: Blank Screen Emulator

    Quote Originally Posted by wizard_hu_
    It is available in all Symbian SDK-s.
    Is it so that you have not seen your emulator running for more than a month? :-(
    You should try re-installing again. If you have more than one SDK-s installed, you should remove all of them. Then delete the c:\Symbian folder (if you have works in it, save them before :-).
    You may also remove the c:\Program Files\Common Files\Symbian folder.
    Then you may try re-installing the SDK.
    Also consider that S60 2.1 still uses Symbian 7.0s, but it has a bit more stable emulator (actually I do not know what phone model you have, but I develop for 6600 with S60 2.1 SDK).
    Thanks Wizard_hu for your recommendation I'll try to do it today Althogh that I did remove it before then reinstall again however I'll do it again may be I did some mistakes before and please try to followup my next post replay.

    Thanks again.

  10. #10
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    364

    Re: Blank Screen Emulator

    Quote Originally Posted by wizard_hu_
    It is available in all Symbian SDK-s.
    Is it so that you have not seen your emulator running for more than a month? :-(
    You should try re-installing again. If you have more than one SDK-s installed, you should remove all of them. Then delete the c:\Symbian folder (if you have works in it, save them before :-).
    You may also remove the c:\Program Files\Common Files\Symbian folder.
    Then you may try re-installing the SDK.
    Also consider that S60 2.1 still uses Symbian 7.0s, but it has a bit more stable emulator (actually I do not know what phone model you have, but I develop for 6600 with S60 2.1 SDK).

    I did all your recommended steps , still the emulator Is Blank , One Step remaining is to format the hole (Laptop) ?!!!! I'm wondering after this also it will remain blank emulator what I Do? the file (epocwind.out) It is not available on the whole (HD) and (symbian) Directory even after installation so what I should do later , can any one help?

  11. #11
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,752

    Re: Blank Screen Emulator

    Could you try disabling the audio hardware of your laptop (Right-click on My Computer, Properties, Hardware tab, Device Manager, Sound, video and game controllers, <your device>, Right-click, Disable)?

  12. #12
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,563

    Re: Blank Screen Emulator

    I am not too aware of SDK 2.1 SDK modalities, but could registration prompt that I had been prompted when the emulator is coming up be the issue here(I had registered immediately when prompted)?? pls check on that one

    Good Luck
    cheers
    Neil

  13. #13
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,752

    Re: Blank Screen Emulator

    Pre-3rd edition SDK-s need no registration (I am not sure about 2nd ed. FP3, but I am sure about the others).

  14. #14
    Super Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,569

    Re: Blank Screen Emulator

    And, if you do not use the default installation drive and path for the SDK (which I've learned is the safest route, usually), check that the path doesn't have spaces in/between directory names and if necessary, edit the emulator's configuration file, epoc.ini, to have absolute path for _EPOC_DRIVE_D

  15. #15
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    364

    Re: Blank Screen Emulator

    Quote Originally Posted by petrib
    And, if you do not use the default installation drive and path for the SDK (which I've learned is the safest route, usually), check that the path doesn't have spaces in/between directory names and if necessary, edit the emulator's configuration file, epoc.ini, to have absolute path for _EPOC_DRIVE_D
    I did all the recommended steps that stated by (wizard_hu_) in one of previous posts , I do all types of installation in its default directories and there were no spaces on it.

Similar Threads

  1. Emulator Problem
    By jackxie in forum Symbian Tools & SDKs
    Replies: 8
    Last Post: 2007-09-27, 12:06
  2. SDK Emulator bug - does not show radiobutton
    By TQProGuy in forum Tools and SDK Feedback (Closed)
    Replies: 0
    Last Post: 2006-06-28, 16:53
  3. Camera capturing 6630 working, 6681 shows blank screen
    By jascco in forum Mobile Java Media (Graphics & Sounds)
    Replies: 2
    Last Post: 2006-06-18, 14:49
  4. Emulator screen gone... Help needed
    By meihuadao in forum Symbian Tools & SDKs
    Replies: 4
    Last Post: 2006-03-22, 13:30
  5. Can not find my app on the emulator screen
    By nguyenhoaiduc in forum Symbian
    Replies: 1
    Last Post: 2005-11-15, 04:34

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×