×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    2

    Problem to send a Service Indication with delivery-method="confirmed" .

    Hello,

    When I send a SI push message with the next quality of service in the PAP message:

    <quality-of-service
    priority="high"
    delivery-method="confirmed"
    network="GSM"
    network-required="true"
    bearer="CSD"
    bearer-required="false">
    </quality-of-service>

    A SIA SMS is send to my Nokia 6310 but nothing appears on it?

    Anyone have any ideas?

    Thank's in advance, Luc.

  2. #2
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    466

    RE: Problem to send a Service Indication with delivery-method="confirme d" .

    Hello!

    Have you created your WAP Push message according to the instructions given in the "Getting Started with WAP Push" document? The document can be found at the Forum Nokia web site under Nokia XHTML/WML -> Documents section. Please go through the instructions and example codes given there and if you still have problems, let us know.

    Secondly, have you checked that your Nokia 6310 is set to receive Push messages? Please check that you have selected ON in Service messages settings (Services -> Settings -> Service inbox settings -> Service messages).

    Kind regards,
    Satu/Forum Nokia Developer Support

  3. #3
    Registered User
    Join Date
    Jun 2007
    Posts
    3

    Re: Problem to send a Service Indication with delivery-method="confirmed" .

    For me I receive the WAPPush correctly if I set the "delivery-method" attribute to "unconfirmed", but when I try to modify it to "confirmed" I don't receive the WAPPush.

    Anyone has an idea about this problem please.

  4. #4
    Registered User
    Join Date
    Jun 2007
    Posts
    3

    Re: Problem to send a Service Indication with delivery-method="confirmed" .

    I have the same problem also. Any ideas please

  5. #5
    Super Contributor
    Join Date
    May 2003
    Posts
    839

    Re: Problem to send a Service Indication with delivery-method="confirmed" .

    Hello

    Maybe the reason is that PPG could not deliver the message using the delivery-method specified in the request.

    -tum-

  6. #6
    Registered User
    Join Date
    Jun 2007
    Posts
    3

    Re: Problem to send a Service Indication with delivery-method="confirmed" .

    For the problem of the "confirmed" & "unconfirmed", I found in the logs of the PPG that the push-id in PAP file is not unique. So, I make it unique but in fact this didn't solve the problem. I still cannot receive the WAPPush when the delivery-method="confirmed".


    I found another idea to get a delivery report when the WAPPush is received by the phone. I added the following headers to the WAPPush request:
    X-KANNEL-DLR-URL: [URL to the servlet that will receive the delivery]
    X-KANNEL-DLR-MASK: 31 /* To get any delivery */
    /**
    * 31 is a combination of the numbers:
    *1: Delivered to phone, 2: Non-Delivered to Phone, 4: Queued on SMSC, 8: Delivered to * SMSC, 16: Non-Delivered to SMSC
    */

    But in fact I get only the delivery report number 8 which is "Delivered to SMSC" and I get nothing when the WAPPush is received by the phone.

    I searched alot in the net but I could't get a clue.

    Please, help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×