×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Jan 2007
    Posts
    7

    S60 (FP1) Verification Problem

    Hi,

    I just download S60-SDK-200634-3.1-Cpp-f.1090b.zip and try to do the installation. I following the instructions installed perl version5.6.1. I have JDK1.5 installed. My machine is 2000 SP4. The installation seems fine until the verification step.
    I verify the devices command
    cd C:\Symbian\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic
    cd group
    bldmake bldfiles
    after abld build
    I got
    C:\Symbian\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\group>abld build
    make -r -f "\Symbian\9.2\S60_3rd_FP1\EPOC32\BUILD\Symbian\9.2\S60_3rd_FP1\S60
    Ex\HelloWorldBasic\group\EXPORT.make" EXPORT VERBOSE=-s
    Nothing to do
    I can launch epoc but only have calendar, New Text Message, Web, Gallery, Massaging and Contacts and there is no Installed fold.

    Can somebody help me on this? Thanks a lot
    Last edited by Kathyqe; 2007-01-10 at 23:47.

  2. #2
    Super Contributor
    Join Date
    Jun 2004
    Location
    SymbianLand
    Posts
    763

    Re: S60 (FP1) Installation/Verification Problem

    You are in the Active Standby mode.
    Press the menu key as shown below to see the folders and then u will see the "Installed" folder.

    --Mayur.
    Attached Images Attached Images

  3. #3
    Registered User
    Join Date
    Jan 2007
    Posts
    7

    Re: S60 (FP1) Installation/Verification Problem

    Thanks. Now I can found the installed folder. but in that folder I can not find HelloWorld Basic application. I think that is because the application did not get build because of "Nothing to do" after abld build. I was trying to do C++ build for S60 3rd Edition for Symbian OS. I have VS.NET 2003 installed. I also download carbide.c++ express.

  4. #4
    Super Contributor
    Join Date
    Jun 2004
    Location
    SymbianLand
    Posts
    763

    Re: S60 (FP1) Installation/Verification Problem

    If you just type the abld command you will the following output:
    Code:
    D:\symbian_prjs\group>abld
    Common usage : abld [test] command [options] [platform] [build] [program]
      where command is build, target, etc.
        (type "abld help commands" for a list of commands)
      where options are -c, -k, etc.
        (type "abld help options" for a list of options)
      where parameters depend upon the command
        (type "abld help <command>" for command-specific help)
      where parameters default to 'ALL' if unspecified
    project platforms:
       WINSCW GCCXML EDG GCCE ARMV5 ARMV5_ABIV2 GCCE VS6 CW_IDE VS2003
    So just check the platforms supported and run the command
    Code:
    abld build winscw udeb
    Hope this helps.
    --Mayur.

  5. #5
    Registered User
    Join Date
    Mar 2007
    Posts
    6

    Re: S60 (FP1) Installation/Verification Problem

    I think I am getting the same problem, but the reply from mayur_24 assumes the CodeWarrior environment is installed, doesn't it? (I'm relying on the message "ERROR: Unable to identify a valid CodeWarrior for Symbian OS installation" for this interpretation, but suppose that's what the CW in WINCW stands for.)

    If I use no parameters (like the instructions in S60_CPP_SDK_3rd_FP1_InstallationGuide_1.0.pdf suggest), I get a single line that looks like this:
    Code:
    make -r  -f "\Symbian\9.2\S60_3rd_FP1\EPOC32\BUILD\Symbian\9.2\S60_3rd_FP1\S60Ex\HelloWorldBasic\group\EXPORT.make" EXPORT VERBOSE=-s
    Nothing to do
    When I tried "abld build ARMV5_ABIV2" I get more action, but including an error that seems to come from its attempt to use "armcc". The installation of the S60_CPP_SDK_3rd_FP1 automatically downloads the CSL ARM Q1C Toolchain, but that doesn't seem to include anything called "armcc."

    Then I checked further into the toolchain install (the installation manual says to continue with step 9 after installing it, although there are only 8 steps), but I see now that this target is a "abld build gcce urel" sort of target. That worked. Then I changed to the sis directory, and typed "makesis helloworldbasic_gcc.pkg" and it produced an SIS.

    Installing that to the phone gave a certificate error, but that's another problem. Seems to be working now.


    -- Mike.
    Last edited by menidd; 2007-03-09 at 16:49.

  6. #6
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: S60 (FP1) Installation/Verification Problem

    WINSCW is the emulator platform and yes, CW stands for CodeWarrior. The compiler is not included in the SDK, it comes with one of the supported IDEs (CodeWarrior, Carbide.c++ and Carbide.vs if you're using Microsot's Visual Studio).

    The ARMV5[_ABIV2] platform uses the RealView Compiler Tools (RVCT) which is not delivered with the SDK.

    The other platform defined for device builds is GCCE whic usess the CSL Arm Toolchain.

Similar Threads

  1. S60 3rd capabilities problem?
    By iulian_moldovan in forum Symbian
    Replies: 8
    Last Post: 2007-06-18, 14:35
  2. S60 2nd Compiling problem for ARMI .
    By nanara in forum Symbian
    Replies: 5
    Last Post: 2007-01-11, 14:08
  3. Problem with RMS files in S60 emulators
    By cutesridhar in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2006-10-27, 00:26
  4. Serious problem with Strinng on S60 with midp 1.0
    By kavaja in forum Mobile Java General
    Replies: 1
    Last Post: 2005-02-01, 09:20
  5. Http connect problem for S60 sdk
    By ewise in forum Mobile Java Networking & Messaging & Security
    Replies: 4
    Last Post: 2004-09-08, 04:34

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×