×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Jan 2006
    Posts
    279

    Light Api problems (part 2) N73

    Hello Guys, does anybody succeded to blink the light LED indicator on N73 or N93 (I have made it on E series and N80 only)
    Here is what I have tried one by one!
    Please help me, or you will see me on the news tomorrow the guy that jumps from the Golden Gate bridge!

    1. iLight->LightOnL(CHWRMLight::ECustomTarget1));
    LOG: Light status:before: 3 after :0 err: -5 (Not supported)
    2. iLight->LightOnL(CHWRMLight::ECustomTarget1, 10000));
    LOG: Light status:before: 0 after :0 err: -5
    3. iLight->LightOnL(CHWRMLight::ECustomTarget1, 10000, 100, EFalse));
    LOG: Light status:before: 0 after :1 err: 0
    4. iLight->LightOnL(CHWRMLight::ECustomTarget1, 10000, 10, EFalse));
    LOG: Light status:before: 1 after :1 err: 0
    5. iLight->LightOnL(CHWRMLight::ECustomTarget1, 10000, 100, ETrue));
    LOG: Light status:before: 1 after :1 err: 0
    6. iLight->LightOnL(CHWRMLight::ECustomTarget1, 10000, 0, ETrue));
    LOG: Light status:before: 1 after :0 err: -5
    7. iLight->LightOnL(CHWRMLight::ECustomTarget1, 10000, 0, EFalse));
    LOG: Light status:before: 0 after :0 err: -5
    8. iLight->LightBlinkL(CHWRMLight::ECustomTarget1));
    LOG: Light status:before: 2 after :0 err: -5
    9. iLight->LightBlinkL(CHWRMLight::ECustomTarget1, 10000));
    LOG: Light status:before: 0 after :3 err: 0
    11. iLight->LightBlinkL(CHWRMLight::ECustomTarget1, 10000, 1000, 2000, 100));
    LOG: Light status:before: 3 after :3 err: 0

    So you see some functions return KErrNone, and even the light status is set to Blinking (3) but in fact it is not blinking, did I tested on a crappy N73?

  2. #2
    Regular Contributor
    Join Date
    Feb 2004
    Posts
    63

    Smile Re: Light Api problems (part 2) N73

    I saw the guy on the news today, jumping from the bridge!
    He seemed really desperate, we could have saved him

  3. #3
    Regular Contributor
    Join Date
    May 2007
    Posts
    52

    Re: Light Api problems (part 2) N73

    Hi guys,

    I'm searching how to blink Notification light on devices.

    This code works perfectly on 3.1 devices, at least on E51 it works. Led indicator on the top left corner (E51) blinks appropriately.
    Code:
    iLight->LightBlinkL(CHWRMLight::ECustomTarget1, 10000, 1000, 2000, 100));
    But I have to control also notification light for 3.2 devices, exactly now I'm testing on E52. As you can observe E52 notification light are the lights around the direction keys and menu button, there is no separate Led indicator as on E51.

    I tested all possible targets (including ECustomTarget1, ECustomTarget2, ECustomTarget3, ECustomTarget4) from CHWRMLight API, but no one blinks appropriate lights around the direction keys.

    Hence my question, anybody know how to work with Notification Light on E52 device? Maybe I should use another API?

    Thanks in advance
    *strutv

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,752

    Re: Light Api problems (part 2) N73

    The E-Series plugins might have contained a custom light API, just the link is broken now (http://www.forum.nokia.com/Tools_Doc...ls/Other.xhtml) - and in fact I can not recall if there really was an E-Series plugin for FP2, regardless of what the table says.

  5. #5
    Regular Contributor
    Join Date
    May 2007
    Posts
    52

    Re: Light Api problems (part 2) N73

    I have "S60 3rd Ed SDK FP2 API Plug-In Pack v1.2" and it doesn't contain E-series plugin too.

    Any other suggestions?

Similar Threads

  1. Is there a C++ API for the video player
    By avbrozhko in forum Symbian
    Replies: 9
    Last Post: 2008-06-06, 14:34
  2. Wireless Toolkit + Nokia UI API problems
    By catman123 in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2003-04-13, 22:26
  3. NOKIA UI API: problems with Full canvas in 7210 and 3510
    By shibugp in forum Mobile Java General
    Replies: 0
    Last Post: 2003-02-17, 03:00
  4. Series 60 WAP API problems
    By gadolin in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2002-07-11, 11:08
  5. How to Keep Background Light ON in 7650 using API
    By rmuralidharan in forum Symbian User Interface
    Replies: 1
    Last Post: 1970-01-01, 02:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×