Namespaces

Variants
Actions

Please note that as of October 24, 2014, the Nokia Developer Wiki will no longer be accepting user contributions, including new entries, edits and comments, as we begin transitioning to our new home, in the Windows Phone Development Wiki. We plan to move over the majority of the existing entries over the next few weeks. Thanks for all your past and future contributions.

Archived:Getting started with new UIQ project in Carbide.c++

From Wiki
Jump to: navigation, search

Archived.pngArchived: This article is archived because it is not considered relevant for third-party developers creating commercial solutions today. If you think this article is still relevant, let us know by adding the template {{ReviewForRemovalFromArchive|user=~~~~|write your reason here}}.

UIQ is no longer a current or relevant software platform.

Article Metadata
Article
Created: rahulvala (30 Jan 2009)
Last edited: hamishwillee (21 Aug 2012)

Contents

New project window

The New Project Wizard leads you through each of the steps necessary to configure a project for use with the Carbide.c++ UI Designer. The wizard consists of a series of pages, each of which collects information of a specified type. When you complete all of the pages, Carbide.c++ will create a new project using the settings you have specified.

To activate the New Project Wizard, select the File > New > Symbian OS C++ Project menu option as shown in Figure 1 to display the first page in the wizard. Continue through each of the pages using the Next button. The Back button allows you to return to a previous page in the wizard. The Cancel button will terminate the wizard without creating a project. The Finish button (when available) will terminate the wizard and create your new project.

Figure 1 - Starting the New Project Wizard from the File menu

Select type of project

The New Project Wizard leads you through each of the steps necessary to configure a project for use with the Carbide.c++ UI Designer. The wizard consists of a series of pages, each of which collects information of a specified type. When you complete all of the pages, Carbide.c++ will create a new project using the settings you have specified.

Use the Select a Type of Project page of the New Project Wizard to select the appropriate template for your project. Select the 3rd Ed. GUI Application with UI Designer option as shown in Figure 2 to create a project for use with the Carbide.c++ UI Designer.

Figure 2 - the Select Type of Project page of the New Project Wizard


Adding a project name

The New Project Wizard leads you through each of the steps necessary to configure a project for use with the Carbide.c++ UI Designer. The wizard consists of a series of pages, each of which collects information of a specified type. When you complete all of the pages, Carbide.c++ will create a new project using the settings you have specified.

Use the New Symbian OS C++ Project page of the New Project Wizard to name your project and specify the location for its directory.

Figure 3 - The Symbian OS C++ Project page of the New Project Wizard

Selecting the sdk tool for the project

The New Project Wizard leads you through each of the steps necessary to configure a project for use with the Carbide.c++ UI Designer. The wizard consists of a series of pages, each of which collects information of a specified type. When you complete all of the pages, Carbide.c++ will create a new project using the settings you have specified.

Use the Symbian OS SDKs page of the New Project Wizard to select the desired SDKs and build configurations for your project.

Figure 4 - The Symbian OS SDKs page of the New Project Wizard

Define application name and language

The New Project Wizard leads you through each of the steps necessary to configure a project for use with the Carbide.c++ UI Designer. The wizard consists of a series of pages, each of which collects information of a specified type. When you complete all of the pages, Carbide.c++ will create a new project using the settings you have specified.

Use the Application Properties page of the New Project Wizard to select a name for your application, its baseline SDK, and initial language.

Figure 5 - The Application Properties page of the New Project Wizard

Selecting the unique ui design

The New Project Wizard leads you through each of the steps necessary to configure a project for use with the Carbide.c++ UI Designer. The wizard consists of a series of pages, each of which collects information of a specified type. When you complete all of the pages, Carbide.c++ will create a new project using the settings you have specified.

Use the UIQ UI Design Selection page of the New Project Wizard to select the top level container type for the initial screen in your application.

Figure 6 - The UIQ UI Design Selection page of the new project wizard

Configure initial setting of ui design

The New Project Wizard leads you through each of the steps necessary to configure a project for use with the Carbide.c++ UI Designer. The wizard consists of a series of pages, each of which collects information of a specified type. When you complete all of the pages, Carbide.c++ will create a new project using the settings you have specified.

Use the UIQ UI Design Properties page of the New Project Wizard to specify a name and container type for your initial screen.

Figure 7 - The UI Design Properties page of the New Project Wizard

Define basic setting properties

The New Project Wizard leads you through each of the steps necessary to configure a project for use with the Carbide.c++ UI Designer. The wizard consists of a series of pages, each of which collects information of a specified type. When you complete all of the pages, Carbide.c++ will create a new project using the settings you have specified.

Use the Basic Settings page of the New Project Wizard to specify a unique Application UID and to set the author and copyright notice for your application.

Figure 8 - The Basic Settings page of the New Project Wizard

Define directories for project

The New Project Wizard leads you through each of the steps necessary to configure a project for use with the Carbide.c++ UI Designer. The wizard consists of a series of pages, each of which collects information of a specified type. When you complete all of the pages, Carbide.c++ will create a new project using the settings you have specified.

Use the Project Directories page of the New Project Wizard to specify the names for each of the standard subdirectories within your project.

Figure 9 - The Project Directories page of the New Project Wizard

Assigning project directory names

  1. You may accept the default directory names, or enter custom names for any or all of the directories displayed in Figure 1.
    • Include
    • Source
    • Group
    • Install
    • Graphics
    • Resources
    • Registration
  2. When you are satisfied with the names for all directories, click the Finish button to complete the wizard.
    The wizard creates a new project and displays it in the Project Explorer view.

Then create new application in the window.

This page was last modified on 21 August 2012, at 05:29.
61 page views in the last 30 days.

Was this page helpful?

Your feedback about this content is important. Let us know what you think.

 

Thank you!

We appreciate your feedback.

×