×
Namespaces

Variants
Actions

Archived:Multi Lingual Hello World using Carbide 2.0

From Nokia Developer Wiki
Jump to: navigation, search

Archived.pngArchived: This article is archived because it is not considered relevant for third-party developers creating commercial solutions today. If you think this article is still relevant, let us know by adding the template {{ReviewForRemovalFromArchive|user=~~~~|write your reason here}}.

Carbide is no longer recommended for Qt development. See Using Symbian C++ in the Qt SDK for more information

Article Metadata
Compatibility
Platform(s):
Symbian
Article
Created: jimgilmour1 (02 Jan 2009)
Last edited: hamishwillee (01 Jul 2012)

Archived;Qt for beginners using Carbide 2.0

Contents

Introduction

In another article on Archived:Multi Language Hello World using QtDesign in Qt. The Qt cross-platform skills a developer learnt during development on other platforms e.g. Windows, Linux and Mac are now going to be used for Qt. Currently we have developers with Qt cross-platform skills and developers with Symbian S60 skills who want to gain skills in Qt. In Archived:Multi Language Hello World using QtDesign in Qt, Qt GUI Designer was used to build a project. All the code for Muti-Lingual Hello World was given. All developers will need a copy of this, currently before final release, were are putting this in directory.
Qt60 install path "\examples\QtS60App".


The article Archived:Multi Language Hello World using QtDesign in Qt showed how to compile using command line.Languages currently are:- English,Spanish,German,French,Russian,Portugese,Chinese. You will need the relevant character encoding to see the Russian and Chinese


An article by another author Getting started with Qt gives an illustrated guide of setting up Carbide.c++ 2.0 for Qt Symbian.
This article will use S60 IDE Carbide.c++ version 2.0, which has support for Qt and is the first free version. Carbide.c++ 2.0 can import the project designed with QtDesigner that is now saved in Qt60 install path "\examples\QtS60App".


Preconditions

  • Download and install the Qt SDK

Install Carbide.c++

Many people have Using Nokia SDKs and Tools on Windows Vista and before installing Carbide and S60 emulators you need check Using Nokia SDKs and Tools on Windows Vista and the download link is in the Carbide.c++ 2.0 section.

When Carbide.c++ 2.0 opens, the new workspace area default is given. New Carbide.c++ users should accept this and may want to tick the "Always use this as default workspace". The Welcome screen is shown you may want to look around this the click the "X" top left next to "Welcome" title,when finished. This can be accessed from Help menu whenever the Welcome screen is needed.

The screen opens and the windows are empty. In the main menu along the top select
(Window -> Preferences -> Select Qt from the left pane click "Add").

Add new version number of current kit e.g. 4.5. Select "Bin Path" Browse to "Qt60 install path \bin" and click "Finish".

The article by another author gives an illustrated description of how to set up the Qt for Carbide.c++ 2.0

The actions above will only need to be carried out when a new Carbide workspace is created

Importing and creating the QtS60App project

Click on the "File" menu and look down the list for "Import" and click this. Select "Qt" open this up and select "Qt Project"
Click next and browse to "Qt60 install path \examples\QtS60App".and the file filter will show QtS60App.pro, Click on the file icon to select and click "ok".
Click the S60 SDK you want to associate. If you are new to S60 Carbide then may be selecting one S60 3rd Edition SDK e.g. FP1.

The main screen popup will show processing and the left column the "Project Explorer" window will show the project. Right click on the Project Name, look down the list for "Build Project" and click this. Expand the Project view and click on the QtS60App.ui to start the embedded Qt GUI editor and display this as above. Click on the "Console" tab in the bottom window to see if the compilation was successful.

MultiLingualHelloWorldCarbide.jpg

Debugging the QtS60App

If you have enough memory on your PC you can start to debug your application by setting break points and stepping through your code.
Right click on the Project Name, look down the list for "Debug As" and at right arrow select the "Debug as Symbian Application" and click "Ok". The Debug perspective is now displayed and the Emulator will start to run. From the main screen use the arrows keys to go to the "Installed app" icon and open the the QtS60App application.

The details of usage of QtS60App were given in previous article

Summary

This and the previous article has shown how previous experience on other Qt platforms can be used to create new applications and to import projects from other platforms into the Qt using previously created projects. This article may have given the cross platform Qt developer the skills start porting and developing for Qt on Symbian.

Other related articles

This page was last modified on 1 July 2012, at 08:25.
42 page views in the last 30 days.
×