×
Namespaces

Variants
Actions

Archived:PKG requisite line for Nokia 6210 Navigator UID does not work (Known Issue)

From Nokia Developer Wiki
Jump to: navigation, search

Archived.pngArchived: This article is archived because it is not considered relevant for third-party developers creating commercial solutions today. If you think this article is still relevant, let us know by adding the template {{ReviewForRemovalFromArchive|user=~~~~|write your reason here}}.

Nokia 6210 Navigator does not have the stub SIS file containing the UID 0x2000DA54 in its ROM install folder. The same problem has also been reported for the Nokia 6220 classic, for which the UID is 0x2000DA52.

Article Metadata
Compatibility
Platform(s): S60 3rd Edition, Feature Pack 2
S60 3rd Edition FP2
Article
Created: User:Technical writer 1 (17 Sep 2008)
Updated: User:Technical writer 1 (10 Dec 2008)
Last edited: hamishwillee (09 May 2013)

Contents

Description

When using the mandatory line specifying the UID to be 0x2000DA54, the "application not compatible" note is still shown when an application is installed to a Nokia 6210 Navigator device.

How to reproduce

Remove the Series60ID line from the .pkg file, add the mandatory line with 0x2000DA54/0x2000DA52 UID, and observe the behaviour while installing.

Solution

The machine UID with the value 0x2000DA54/0x2000DA52 works, so you can use an IF-ELSE clause in the PKG file.

For example,

 ; Check compatibility with Nokia 6220 Classic
IF NOT (MachineUid=0x2000DA52)
"compatibility_warning.txt"-"", FT, TC
ENDIF

or

 ; Check compatibility with Nokia 6210 Navigator
IF NOT (MachineUid=0x2000DA54)
"compatibility_warning.txt"-"", FT, TC
ENDIF

See also

Product-specific dependency not recognised in Nokia 5800 XpressMusic (Known Issue)

This page was last modified on 9 May 2013, at 06:14.
70 page views in the last 30 days.
×