Namespaces

Variants
Actions

Please note that as of October 24, 2014, the Nokia Developer Wiki will no longer be accepting user contributions, including new entries, edits and comments, as we begin transitioning to our new home, in the Windows Phone Development Wiki. We plan to move over the majority of the existing entries over the next few weeks. Thanks for all your past and future contributions.

Archived:Possible workarounds to Emulator startup issues on Vista in S60 3rd Edition

From Wiki
Jump to: navigation, search

Archived.pngArchived: This article is archived because it is not considered relevant for third-party developers creating commercial solutions today. If you think this article is still relevant, let us know by adding the template {{ReviewForRemovalFromArchive|user=~~~~|write your reason here}}.

Note, that the incompabilities may also exist in newer SDKs, because the seem to inherit a lot of old code, and the problem are basically the same in Windows 7. Just on 2012-07-17 somebody asked in Java forum that they can not install S60_3rd_FP2 on Windows 7. And I also linked this page from another troubleshooting page. However this remains archived unless issues can be verified

Article Metadata
CompatibilityArticle
Created: User:Zuesegy (08 Apr 2009)
Last edited: hamishwillee (20 Aug 2012)

The Symbian Emulator in the S60 3rd Edition SDK does not always launch on Windows Vista. This article provides a workaround.

Possible causes

There are (at least) two possible reasons for this conflict:

  1. The realtek HD audio driver is present on Your PC
  2. Data Execution Prevention (DEP) that maintains security concerns on Vista.

Workaround

Try the following workaround in order to launch the Emulator:

  1. Disable the Audio HD driver from device manager
  2. Disable DEP option for Vista by:
    • Run a command prompt as administrator. From the start menu, select "All Programs", then "Accessories" and right-click on the "Command Prompt" shortcut and choose "Run As Administrator".
    • From here you can use the following command to disable Data Execution Prevention (DEP):
      bcdedit.exe /set {current} nx AlwaysOff
    • To re-enable DEP do:
      bcdedit.exe /set {current} nx AlwaysOn

Disabling DEP is not recommended. However this is the approach that worked for me.

See also

This page was last modified on 20 August 2012, at 00:46.
42 page views in the last 30 days.

Was this page helpful?

Your feedback about this content is important. Let us know what you think.

 

Thank you!

We appreciate your feedback.

×