Namespaces

Variants
Actions

Please note that as of October 24, 2014, the Nokia Developer Wiki will no longer be accepting user contributions, including new entries, edits and comments, as we begin transitioning to our new home, in the Windows Phone Development Wiki. We plan to move over the majority of the existing entries over the next few weeks. Thanks for all your past and future contributions.

Archived:Problems with Audio Routing API in S60 3rd Edition FP2 (Known Issue)

From Wiki
Jump to: navigation, search

Archived.pngArchived: This article is archived because it is not considered relevant for third-party developers creating commercial solutions today. If you think this article is still relevant, let us know by adding the template {{ReviewForRemovalFromArchive|user=~~~~|write your reason here}}.

The Audio Routing API does not work as expected in all devices based on S60 3rd Edition, Feature Pack 2.

Article Metadata
Tested with
Devices(s): Detected on Nokia 5630 XpressMusic, Nokia E52, Nokia E55, Nokia E72
Compatibility
Platform(s): S60 3rd Edition FP2
S60 3rd Edition FP2
Article
Created: User:Nokia Developer KB (17 Sep 2009)
Last edited: hamishwillee (14 Jun 2013)

Note.pngNote: This API is not part of the public SDK. It can be found in the SDK API Plug-in.

Description

This issue can be reproduced with the Audio Routing API example application.

The CAudioOutput::SetAudioOutputL() function of the Audio Routing API does not work as expected on affected devices. Instead, default routing is always used for audio playback, regardless of the value (TAudioOutputPreference) passed to SetAudioOutputL().

Solution

No solution currently available.

This page was last modified on 14 June 2013, at 05:04.
34 page views in the last 30 days.

Was this page helpful?

Your feedback about this content is important. Let us know what you think.

 

Thank you!

We appreciate your feedback.

×