×
Namespaces

Variants
Actions

Archived:Sensor plug-in for S60 3rd Edition cannot be used after Feature Pack 1 (Known Issue)

From Nokia Developer Wiki
Jump to: navigation, search

Archived.pngArchived: This article is archived because it is not considered relevant for third-party developers creating commercial solutions today. If you think this article is still relevant, let us know by adding the template {{ReviewForRemovalFromArchive|user=~~~~|write your reason here}}.

The Sensor plug-in for S60 3rd Edition cannot be used for S60 3rd Edition Feature Pack 2 or later.

Article Metadata
Tested with
Devices(s): Nokia 5500 Sport, S60 3rd Edition, FP1 (Nseries)
CompatibilityArticle
Created: User:Technical writer 1 (27 Nov 2007)
Last edited: hamishwillee (19 Jun 2012)

Description

The Sensor plug-in for S60 3rd Edition, available at the Nokia Developer website, was released as a device-specific plug-in API for the Nokia 5500 Sport. With minor modifications the same API can be used also for S60 3rd Edition, Feature Pack 1 devices with accelerometer functionality. For more information, see the Nokia Sensor APIs article.

However, the Sensor Plug-in API is not considered an S60 platform feature and therefore compatibility cannot be maintained across S60 3rd Edition Feature Packs. Developers using this plug-in should note that S60 3rd Edition, Feature Pack 2 devices will no longer support this API.

Solution

No solution. The sensor/accelerometer API used in S60 3rd Edition, Feature Pack 2 devices is not compatible with the Sensor API used in the Nokia 5500 Sport or S60 3rd Edition, FP1 Nseries devices.

This page was last modified on 19 June 2012, at 08:03.
37 page views in the last 30 days.

Was this page helpful?

Your feedback about this content is important. Let us know what you think.

 

Thank you!

We appreciate your feedback.

×